summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/use-imx-headers.bbclass19
-rw-r--r--recipes-bsp/imx-lib/imx-lib_git.bb7
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb11
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb5
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb7
-rw-r--r--recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb7
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb6
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb6
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb6
9 files changed, 42 insertions, 32 deletions
diff --git a/classes/use-imx-headers.bbclass b/classes/use-imx-headers.bbclass
new file mode 100644
index 00000000..9dcd864d
--- /dev/null
+++ b/classes/use-imx-headers.bbclass
@@ -0,0 +1,19 @@
1# Easy use of linux-imx-headers by packages
2#
3# This allow to easy reuse of binary packages among similar SoCs. The
4# usual use for this is to share SoC specific packages among different
5# boards independently of the kernel version it is using, as far it is
6# ABI compatible with the official version it will just work.
7#
8# All recipes using this class ought to depend on linux-imx-headers
9# and by default to use MACHINE_SOCARCH.
10#
11# Please use the STAGING_INCDIR_IMX variable to refer to the installed
12# headers.
13#
14# Copyright 2018 (C) O.S. Systems Software LTDA.
15
16DEPENDS_append_imx = " linux-imx-headers"
17PACKAGE_ARCH_imx ?= "${MACHINE_SOCARCH}"
18
19STAGING_INCDIR_IMX = "${STAGING_INCDIR}/imx"
diff --git a/recipes-bsp/imx-lib/imx-lib_git.bb b/recipes-bsp/imx-lib/imx-lib_git.bb
index d9258a1c..d94b2daa 100644
--- a/recipes-bsp/imx-lib/imx-lib_git.bb
+++ b/recipes-bsp/imx-lib/imx-lib_git.bb
@@ -6,8 +6,6 @@ DESCRIPTION = "Platform specific libraries for imx platform"
6LICENSE = "LGPLv2.1" 6LICENSE = "LGPLv2.1"
7SECTION = "multimedia" 7SECTION = "multimedia"
8 8
9DEPENDS = "linux-imx-headers"
10
11LIC_FILES_CHKSUM = "file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" 9LIC_FILES_CHKSUM = "file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
12 10
13PE = "1" 11PE = "1"
@@ -20,6 +18,8 @@ SRCREV = "3f777974c0c146817e2ff5cb0340ca66a1f99e57"
20 18
21S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
22 20
21inherit use-imx-headers
22
23PLATFORM_mx6q = "IMX6Q" 23PLATFORM_mx6q = "IMX6Q"
24PLATFORM_mx6dl = "IMX6Q" 24PLATFORM_mx6dl = "IMX6Q"
25PLATFORM_mx6sl = "IMX6S" 25PLATFORM_mx6sl = "IMX6S"
@@ -33,7 +33,7 @@ PARALLEL_MAKE="-j 1"
33EXTRA_OEMAKE = "" 33EXTRA_OEMAKE = ""
34 34
35do_compile () { 35do_compile () {
36 INCLUDE_DIR="-I${STAGING_INCDIR}/imx" 36 INCLUDE_DIR="-I${STAGING_INCDIR_IMX}"
37 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all 37 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all
38} 38}
39 39
@@ -42,4 +42,3 @@ do_install () {
42} 42}
43 43
44COMPATIBLE_MACHINE = "(mx6|mx7)" 44COMPATIBLE_MACHINE = "(mx6|mx7)"
45PACKAGE_ARCH = "${MACHINE_SOCARCH}"
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index 729e2670..fae459ca 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -8,7 +8,7 @@ SECTION = "base"
8LICENSE = "GPLv2" 8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
10 10
11DEPENDS = "linux-imx-headers alsa-lib libdrm" 11DEPENDS = "alsa-lib libdrm"
12DEPENDS_append_mx6 = " imx-lib" 12DEPENDS_append_mx6 = " imx-lib"
13DEPENDS_append_mx7 = " imx-lib" 13DEPENDS_append_mx7 = " imx-lib"
14 14
@@ -24,7 +24,7 @@ SRC_URI = " \
24SRCREV = "3a87347ae408ef0234314a279ee74d9b015f06be" 24SRCREV = "3a87347ae408ef0234314a279ee74d9b015f06be"
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
27inherit module-base 27inherit module-base use-imx-headers
28 28
29INHIBIT_PACKAGE_STRIP = "1" 29INHIBIT_PACKAGE_STRIP = "1"
30INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 30INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
@@ -55,9 +55,9 @@ do_compile() {
55 CFLAGS="${TOOLCHAIN_OPTIONS}" 55 CFLAGS="${TOOLCHAIN_OPTIONS}"
56 oe_runmake V=1 VERBOSE='' \ 56 oe_runmake V=1 VERBOSE='' \
57 CROSS_COMPILE=${TARGET_PREFIX} \ 57 CROSS_COMPILE=${TARGET_PREFIX} \
58 INC="-I${STAGING_INCDIR} \ 58 INC="-I${S}/include \
59 -I${S}/include \ 59 -I${STAGING_INCDIR} \
60 -I${STAGING_INCDIR}/imx" \ 60 -I${STAGING_INCDIR_IMX}" \
61 CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \ 61 CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \
62 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ 62 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
63 LINUXPATH=${STAGING_KERNEL_DIR} \ 63 LINUXPATH=${STAGING_KERNEL_DIR} \
@@ -82,5 +82,4 @@ RDEPENDS_${PN} = "bash"
82 82
83FILES_${PN}-dbg += "/unit_tests/.debug" 83FILES_${PN}-dbg += "/unit_tests/.debug"
84 84
85PACKAGE_ARCH = "${MACHINE_SOCARCH}"
86COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 85COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
index 25ef41ed..c49f90db 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
@@ -4,8 +4,6 @@ DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db" 5LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db"
6 6
7DEPENDS = "linux-imx-headers"
8
9PROVIDES = "virtual/imxvpu" 7PROVIDES = "virtual/imxvpu"
10 8
11SRC_URI = " \ 9SRC_URI = " \
@@ -15,7 +13,7 @@ SRC_URI = " \
15SRC_URI[md5sum] = "140796ddd6f1be47cffb7e5e2bfe0fb6" 13SRC_URI[md5sum] = "140796ddd6f1be47cffb7e5e2bfe0fb6"
16SRC_URI[sha256sum] = "c092a5b0f8897bae54154f58e47b6d2de033da01ee231a8cd779a51bbe962606" 14SRC_URI[sha256sum] = "c092a5b0f8897bae54154f58e47b6d2de033da01ee231a8cd779a51bbe962606"
17 15
18inherit fsl-eula-unpack 16inherit fsl-eula-unpack use-imx-headers
19 17
20PARALLEL_MAKE="-j 1" 18PARALLEL_MAKE="-j 1"
21 19
@@ -34,5 +32,4 @@ do_install () {
34 32
35FILES_${PN} += "/unit_tests" 33FILES_${PN} += "/unit_tests"
36 34
37PACKAGE_ARCH = "${MACHINE_ARCH}"
38COMPATIBLE_MACHINE = "(mx8mq|mx8mm)" 35COMPATIBLE_MACHINE = "(mx8mq|mx8mm)"
diff --git a/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb b/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb
index aebee4f0..185bb3d1 100644
--- a/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb
+++ b/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb
@@ -6,8 +6,6 @@ DESCRIPTION = "Freescale Chips&Media VPU library"
6LICENSE = "Proprietary" 6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=75abe2fa1d16ca79f87cde926f05f72d" 7LIC_FILES_CHKSUM = "file://COPYING;md5=75abe2fa1d16ca79f87cde926f05f72d"
8 8
9DEPENDS = "linux-imx-headers"
10
11PROVIDES = "virtual/imxvpu" 9PROVIDES = "virtual/imxvpu"
12 10
13PE = "1" 11PE = "1"
@@ -17,12 +15,12 @@ SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
17SRC_URI[md5sum] = "521d5f839829f8d1f2a6a0e60270243e" 15SRC_URI[md5sum] = "521d5f839829f8d1f2a6a0e60270243e"
18SRC_URI[sha256sum] = "34bed0ddf6c797f444bddfa5d5495adc751ff268b6431d8beb48129c89c9e47f" 16SRC_URI[sha256sum] = "34bed0ddf6c797f444bddfa5d5495adc751ff268b6431d8beb48129c89c9e47f"
19 17
20inherit fsl-eula-unpack 18inherit fsl-eula-unpack use-imx-headers
21 19
22PLATFORM_mx6 = "IMX6Q" 20PLATFORM_mx6 = "IMX6Q"
23 21
24do_compile () { 22do_compile () {
25 INCLUDE_DIR="-I${STAGING_INCDIR}/imx" 23 INCLUDE_DIR="-I${STAGING_INCDIR_IMX}"
26 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all 24 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all
27} 25}
28 26
@@ -30,5 +28,4 @@ do_install () {
30 oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install 28 oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install
31} 29}
32 30
33PACKAGE_ARCH = "${MACHINE_SOCARCH}"
34COMPATIBLE_MACHINE = "(mx6q|mx6dl)" 31COMPATIBLE_MACHINE = "(mx6q|mx6dl)"
diff --git a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
index 62aff0fb..c96a8835 100644
--- a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
+++ b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
@@ -4,7 +4,7 @@
4DESCRIPTION = "Freescale alsa-lib plugins" 4DESCRIPTION = "Freescale alsa-lib plugins"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6SECTION = "multimedia" 6SECTION = "multimedia"
7DEPENDS = "alsa-lib linux-imx-headers" 7DEPENDS = "alsa-lib"
8 8
9# For backwards compatibility 9# For backwards compatibility
10PROVIDES += "fsl-alsa-plugins" 10PROVIDES += "fsl-alsa-plugins"
@@ -14,7 +14,7 @@ RCONFLICTS_${PN} = "fsl-alsa-plugins"
14 14
15LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f" 15LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
16 16
17inherit autotools pkgconfig 17inherit autotools pkgconfig use-imx-headers
18 18
19SRCBRANCH = "nxp/master" 19SRCBRANCH = "nxp/master"
20SRC_URI = "git://source.codeaurora.org/external/imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}" 20SRC_URI = "git://source.codeaurora.org/external/imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}"
@@ -22,7 +22,7 @@ SRCREV = "9a63071e7734bd164017f3761b8d1944c017611f"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25INCLUDE_DIR = "-I${STAGING_INCDIR}/imx" 25INCLUDE_DIR = "-I${STAGING_INCDIR_IMX}"
26 26
27EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}"" 27EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}""
28 28
@@ -33,4 +33,3 @@ FILES_${PN}-dbg += "${libdir}/alsa-lib/.debug"
33FILES_${PN}-dev += "${libdir}/alsa-lib/*.la" 33FILES_${PN}-dev += "${libdir}/alsa-lib/*.la"
34 34
35COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx7ulp)" 35COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx7ulp)"
36PACKAGE_ARCH = "${MACHINE_SOCARCH}"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
index 21807911..0da9a2ea 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
5 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \ 5 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
6 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607" 6 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607"
7 7
8DEPENDS += "iso-codes util-linux linux-imx-headers" 8DEPENDS += "iso-codes util-linux"
9 9
10GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https" 10GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https"
11SRCBRANCH = "MM_04.04.02_1808_L4.9.123_MX8MM_GA" 11SRCBRANCH = "MM_04.04.02_1808_L4.9.123_MX8MM_GA"
@@ -33,7 +33,7 @@ PACKAGECONFIG_append = " pango "
33# Disable introspection to fix [GstGL-1.0.gir] Error 33# Disable introspection to fix [GstGL-1.0.gir] Error
34EXTRA_OECONF_append = " --disable-introspection --disable-opengl --enable-wayland" 34EXTRA_OECONF_append = " --disable-introspection --disable-opengl --enable-wayland"
35 35
36inherit gettext 36inherit gettext use-imx-headers
37 37
38PACKAGES_DYNAMIC =+ "^libgst.*" 38PACKAGES_DYNAMIC =+ "^libgst.*"
39 39
@@ -60,7 +60,7 @@ PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
60 60
61EXTRA_OECONF += " \ 61EXTRA_OECONF += " \
62 --enable-zlib \ 62 --enable-zlib \
63 CPPFLAGS="-I${STAGING_INCDIR}/imx" \ 63 CPPFLAGS="-I${STAGING_INCDIR_IMX}" \
64" 64"
65 65
66CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no" 66CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb
index 45016618..a74ff64b 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5SECTION = "multimedia" 5SECTION = "multimedia"
6# gstreamer1.0-plugins-bad is in DEPENDS because the build script scans for the 6# gstreamer1.0-plugins-bad is in DEPENDS because the build script scans for the
7# GstPhotography headers and libraries 7# GstPhotography headers and libraries
8DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad linux-imx-headers" 8DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
9# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers 9# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
10# for the uniaudio decoder, videoparsersbad for the VPU video decoder 10# for the uniaudio decoder, videoparsersbad for the VPU video decoder
11# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is 11# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is
@@ -22,7 +22,7 @@ SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25inherit pkgconfig waf 25inherit pkgconfig waf use-imx-headers
26 26
27# configure the eglvivsink element to use the appropriate EGL platform code 27# configure the eglvivsink element to use the appropriate EGL platform code
28# Wayland if 'wayland' is present in DISTRO_FEATURES, if not, 28# Wayland if 'wayland' is present in DISTRO_FEATURES, if not,
@@ -34,7 +34,7 @@ EGLVIVSINK_PLATFORM = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayla
34 34
35EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}" 35EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}"
36 36
37EXTRA_OECONF = "--kernel-headers=${STAGING_INCDIR}/imx ${PACKAGECONFIG_CONFARGS}" 37EXTRA_OECONF = "--kernel-headers=${STAGING_INCDIR_IMX} ${PACKAGECONFIG_CONFARGS}"
38 38
39EGLVIVSINK_DEPENDS = " \ 39EGLVIVSINK_DEPENDS = " \
40 virtual/egl virtual/libgles2 \ 40 virtual/egl virtual/libgles2 \
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb
index 55275ab9..986d4a1d 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb
@@ -7,7 +7,7 @@ DESCRIPTION = "Gstreamer freescale plugins"
7LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1" 7LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
8SECTION = "multimedia" 8SECTION = "multimedia"
9 9
10DEPENDS = "imx-codec imx-parser linux-imx-headers gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" 10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS_append_mx6 = " imx-lib" 11DEPENDS_append_mx6 = " imx-lib"
12DEPENDS_append_mx7 = " imx-lib" 12DEPENDS_append_mx7 = " imx-lib"
13DEPENDS_append_imxvpu = " imx-vpuwrap libdrm" 13DEPENDS_append_imxvpu = " imx-vpuwrap libdrm"
@@ -28,7 +28,7 @@ SRCREV = "23dd0315c7087e1c8eba836b9a458d7906187c7e"
28 28
29S = "${WORKDIR}/git" 29S = "${WORKDIR}/git"
30 30
31inherit autotools pkgconfig 31inherit autotools pkgconfig use-imx-headers
32 32
33PLATFORM_mx6 = "MX6" 33PLATFORM_mx6 = "MX6"
34PLATFORM_mx6sl = "MX6SL" 34PLATFORM_mx6sl = "MX6SL"
@@ -41,7 +41,7 @@ PLATFORM_mx8 = "MX8"
41 41
42# Todo add a mechanism to map possible build targets 42# Todo add a mechanism to map possible build targets
43EXTRA_OECONF = "PLATFORM=${PLATFORM} \ 43EXTRA_OECONF = "PLATFORM=${PLATFORM} \
44 CPPFLAGS="-I${STAGING_INCDIR}/imx" \ 44 CPPFLAGS="-I${STAGING_INCDIR_IMX}" \
45 CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \ 45 CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \
46 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}" 46 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}"
47 47