summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-04-16 22:17:45 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-16 20:04:08 -0300
commit4ab569fb67b9499e4782071aec9ba92174184786 (patch)
treef89923cd3947f2761bd0119eeda58ebf95836eb6 /recipes-bsp/imx-test
parentccf7a0a99308611bff0241b021681507b6ee78cc (diff)
downloadmeta-freescale-4ab569fb67b9499e4782071aec9ba92174184786.tar.gz
recipes-*: refine restrictions for NXP BSP
Certain packages are using linux-imx-headers, which enforces them to use NXP BSP since headers are provided from the NXP kernel tree. Those recipes, which requires NXP kernel headers, are now including the use-imx-headers class to make sure the correct headers package is used. Since the introduction of separation between NXP and Mainline BSP for certain machines, recipes which are NXP-dependent are getting their COMPATIBLE_HOST to be marked as (null) effectively making them incompatible with mainline BSP which is expected behavior. By extending this restriction into the use-imx-headers class, all recipes which inherits is (because it is required) are getting automatically restricted to NXP BSP, hence making package NXP-dependent much easier. linux-imx-headers is marked as "NXP-only" but it is done explicitly inside the recipe in order to avoid confusion of inheriting the class. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb4
1 files changed, 0 insertions, 4 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index dacef82f..81bbd3a3 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -79,7 +79,3 @@ FILES_${PN} += "/unit_tests /home/root/.profile"
79RDEPENDS_${PN} = "bash" 79RDEPENDS_${PN} = "bash"
80 80
81FILES_${PN}-dbg += "/unit_tests/.debug" 81FILES_${PN}-dbg += "/unit_tests/.debug"
82
83COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"
84COMPATIBLE_HOST ?= "(none)"
85COMPATIBLE_HOST_use-nxp-bsp = "(.*)"