summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-04-16 22:17:45 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-16 20:04:08 -0300
commit4ab569fb67b9499e4782071aec9ba92174184786 (patch)
treef89923cd3947f2761bd0119eeda58ebf95836eb6
parentccf7a0a99308611bff0241b021681507b6ee78cc (diff)
downloadmeta-freescale-4ab569fb67b9499e4782071aec9ba92174184786.tar.gz
recipes-*: refine restrictions for NXP BSP
Certain packages are using linux-imx-headers, which enforces them to use NXP BSP since headers are provided from the NXP kernel tree. Those recipes, which requires NXP kernel headers, are now including the use-imx-headers class to make sure the correct headers package is used. Since the introduction of separation between NXP and Mainline BSP for certain machines, recipes which are NXP-dependent are getting their COMPATIBLE_HOST to be marked as (null) effectively making them incompatible with mainline BSP which is expected behavior. By extending this restriction into the use-imx-headers class, all recipes which inherits is (because it is required) are getting automatically restricted to NXP BSP, hence making package NXP-dependent much easier. linux-imx-headers is marked as "NXP-only" but it is done explicitly inside the recipe in order to avoid confusion of inheriting the class. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
-rw-r--r--classes/use-imx-headers.bbclass12
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb4
-rw-r--r--recipes-kernel/linux/linux-imx-headers_5.4.3.bb7
3 files changed, 17 insertions, 6 deletions
diff --git a/classes/use-imx-headers.bbclass b/classes/use-imx-headers.bbclass
index 9dcd864d..d2214b6d 100644
--- a/classes/use-imx-headers.bbclass
+++ b/classes/use-imx-headers.bbclass
@@ -17,3 +17,15 @@ DEPENDS_append_imx = " linux-imx-headers"
17PACKAGE_ARCH_imx ?= "${MACHINE_SOCARCH}" 17PACKAGE_ARCH_imx ?= "${MACHINE_SOCARCH}"
18 18
19STAGING_INCDIR_IMX = "${STAGING_INCDIR}/imx" 19STAGING_INCDIR_IMX = "${STAGING_INCDIR}/imx"
20
21# Recipes that inherit this class are contracted to use NXP BSP only.
22# This is done by overriding the COMPATIBLE_HOST, as this would effectively
23# cause recipes to be skipped in case if 'use-nxp-bsp' override is not
24# defined for them. This effectively marks recipes that should only be
25# built using NXP BSP, and gives an indication to mainline BSP creators
26# that recipe is not compatible with mainline.
27#
28# Typical example here would be imx-vpu-hantro recipe, which requires NXP
29# BSP and is not compatible with mainline.
30COMPATIBLE_HOST = '(null)'
31COMPATIBLE_HOST_use-nxp-bsp = '.*'
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index dacef82f..81bbd3a3 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -79,7 +79,3 @@ FILES_${PN} += "/unit_tests /home/root/.profile"
79RDEPENDS_${PN} = "bash" 79RDEPENDS_${PN} = "bash"
80 80
81FILES_${PN}-dbg += "/unit_tests/.debug" 81FILES_${PN}-dbg += "/unit_tests/.debug"
82
83COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"
84COMPATIBLE_HOST ?= "(none)"
85COMPATIBLE_HOST_use-nxp-bsp = "(.*)"
diff --git a/recipes-kernel/linux/linux-imx-headers_5.4.3.bb b/recipes-kernel/linux/linux-imx-headers_5.4.3.bb
index 1517c647..8d52233d 100644
--- a/recipes-kernel/linux/linux-imx-headers_5.4.3.bb
+++ b/recipes-kernel/linux/linux-imx-headers_5.4.3.bb
@@ -63,5 +63,8 @@ INHIBIT_DEFAULT_DEPS = "1"
63DEPENDS += "unifdef-native bison-native rsync-native" 63DEPENDS += "unifdef-native bison-native rsync-native"
64 64
65PACKAGE_ARCH = "${MACHINE_SOCARCH}" 65PACKAGE_ARCH = "${MACHINE_SOCARCH}"
66COMPATIBLE_HOST_imx = "(use-nxp-bsp)" 66
67COMPATIBLE_HOST ?= "(none)" 67# Restrict this recipe to NXP BSP only, this recipe is not compatible
68# with mainline BSP
69COMPATIBLE_HOST = '(null)'
70COMPATIBLE_HOST_use-nxp-bsp = '.*'