diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2024-09-11 09:46:22 -0700 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2024-09-16 04:36:03 -0700 |
commit | ef8b4c41cf0abb41ade7371c2abb16ffe708a8c9 (patch) | |
tree | 7ce6114ed9d4ad11b74883411c5b667e9cb778f0 /recipes-bsp/imx-mkimage | |
parent | 0e3a84c9d46abfd62143887ada7a58b8127ff747 (diff) | |
download | meta-freescale-ef8b4c41cf0abb41ade7371c2abb16ffe708a8c9.tar.gz |
boot: Fix UUU tagging, extend to fslc
Using the UUU-tagged bootloader image directly with UUU can cause UUU
to hang. The bootloader image is split on a certain transmit size, and
the hang occurs if the tag does not fit with the final bytes of the
bootloader image and must be split into a new transmit package.
The UUU tag is needed by UUU only in the SD Card image file itself so
that UUU can find the end of the boot partition.
Rework the design so the default bootloader and the default imx-boot
binaries are not tagged.
Also, extend the UUU tagging to fslc so it can gain the same benefit.
Fixes: https://github.com/Freescale/meta-freescale/pull/1762
Fixes: https://github.com/nxp-imx/mfgtools/issues/416
Co-authored-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 4 |
1 files changed, 1 insertions, 3 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index ed6a155f..3c027044 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -22,9 +22,7 @@ DEPENDS:append:mx93-generic-bsp = " u-boot-mkimage-native dtc-native" | |||
22 | 22 | ||
23 | inherit deploy uuu_bootloader_tag | 23 | inherit deploy uuu_bootloader_tag |
24 | 24 | ||
25 | UUU_BOOTLOADER = "imx-boot" | 25 | UUU_BOOTLOADER = "imx-boot" |
26 | UUU_BOOTLOADER_TAGGED = "imx-boot-tagged" | ||
27 | UUU_BOOTLOADER_UNTAGGED = "imx-boot-untagged" | ||
28 | 26 | ||
29 | # Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build | 27 | # Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build |
30 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" | 28 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" |