summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-mkimage
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2024-09-11 09:46:22 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2024-09-16 04:35:50 -0700
commit0e3a84c9d46abfd62143887ada7a58b8127ff747 (patch)
tree0c29de0c2763a6979cd1ed8b5819911cfe051f17 /recipes-bsp/imx-mkimage
parent1cbbde1666e8809398a847e33a586f033e57af00 (diff)
downloadmeta-freescale-0e3a84c9d46abfd62143887ada7a58b8127ff747.tar.gz
imx-boot: Drop un-necessary variable BOOT_NAME
The variable suggests the ability to override when there is no reason to override. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb20
1 files changed, 9 insertions, 11 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index 83b9ad78..ed6a155f 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -19,14 +19,12 @@ DEPENDS += " \
19DEPENDS += "xxd-native" 19DEPENDS += "xxd-native"
20DEPENDS:append:mx8m-generic-bsp = " u-boot-mkimage-native dtc-native" 20DEPENDS:append:mx8m-generic-bsp = " u-boot-mkimage-native dtc-native"
21DEPENDS:append:mx93-generic-bsp = " u-boot-mkimage-native dtc-native" 21DEPENDS:append:mx93-generic-bsp = " u-boot-mkimage-native dtc-native"
22BOOT_NAME = "imx-boot"
23PROVIDES = "${BOOT_NAME}"
24 22
25inherit deploy uuu_bootloader_tag 23inherit deploy uuu_bootloader_tag
26 24
27UUU_BOOTLOADER = "${BOOT_NAME}" 25UUU_BOOTLOADER = "imx-boot"
28UUU_BOOTLOADER_TAGGED = "${BOOT_NAME}-tagged" 26UUU_BOOTLOADER_TAGGED = "imx-boot-tagged"
29UUU_BOOTLOADER_UNTAGGED = "${BOOT_NAME}-untagged" 27UUU_BOOTLOADER_UNTAGGED = "imx-boot-untagged"
30 28
31# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build 29# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build
32CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" 30CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}"
@@ -222,7 +220,7 @@ do_compile() {
222 UBOOT_DTB_NAME_EXTRA="${dtb_name}" 220 UBOOT_DTB_NAME_EXTRA="${dtb_name}"
223 fi 221 fi
224 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}" 222 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}"
225 BOOT_CONFIG_MACHINE_EXTRA="${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin" 223 BOOT_CONFIG_MACHINE_EXTRA="imx-boot-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin"
226 224
227 for target in ${IMXBOOT_TARGETS}; do 225 for target in ${IMXBOOT_TARGETS}; do
228 compile_${SOC_FAMILY} 226 compile_${SOC_FAMILY}
@@ -273,7 +271,7 @@ do_install () {
273 bbnote "UBOOT_CONFIG = $type" 271 bbnote "UBOOT_CONFIG = $type"
274 272
275 UBOOT_CONFIG_EXTRA="$type" 273 UBOOT_CONFIG_EXTRA="$type"
276 BOOT_CONFIG_MACHINE_EXTRA="${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin" 274 BOOT_CONFIG_MACHINE_EXTRA="imx-boot-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin"
277 275
278 for target in ${IMXBOOT_TARGETS}; do 276 for target in ${IMXBOOT_TARGETS}; do
279 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${D}/boot/ 277 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${D}/boot/
@@ -380,7 +378,7 @@ do_deploy() {
380 for type in ${UBOOT_CONFIG}; do 378 for type in ${UBOOT_CONFIG}; do
381 UBOOT_CONFIG_EXTRA="$type" 379 UBOOT_CONFIG_EXTRA="$type"
382 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}" 380 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}"
383 BOOT_CONFIG_MACHINE_EXTRA="${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin" 381 BOOT_CONFIG_MACHINE_EXTRA="imx-boot-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin"
384 382
385 if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} ] ; then 383 if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} ] ; then
386 install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \ 384 install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \
@@ -399,9 +397,9 @@ do_deploy() {
399 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${DEPLOYDIR} 397 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${DEPLOYDIR}
400 done 398 done
401 399
402 # The first UBOOT_CONFIG listed will be the ${BOOT_NAME} binary 400 # The first UBOOT_CONFIG listed will be the imx-boot binary
403 if [ ! -f "${DEPLOYDIR}/${UUU_BOOTLOADER}" ]; then 401 if [ ! -f "${DEPLOYDIR}/imx-boot" ]; then
404 ln -sf ${BOOT_CONFIG_MACHINE_EXTRA}-${IMAGE_IMXBOOT_TARGET} ${DEPLOYDIR}/${BOOT_NAME} 402 ln -sf ${BOOT_CONFIG_MACHINE_EXTRA}-${IMAGE_IMXBOOT_TARGET} ${DEPLOYDIR}/imx-boot
405 else 403 else
406 bbwarn "Use custom wks.in for $UBOOT_CONFIG = $type" 404 bbwarn "Use custom wks.in for $UBOOT_CONFIG = $type"
407 fi 405 fi