diff options
author | Ting Liu <b28495@freescale.com> | 2014-07-11 02:49:10 -0500 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@freescale.com> | 2014-07-15 14:13:20 +0800 |
commit | 4f980553868ff8f99acf61eba3a1c578c7a1c02b (patch) | |
tree | 0afac9fc41745c1805dde3b4bda85ef83cd37e50 /meta-fsl-ppc/recipes-kernel/ceetm | |
parent | 2e419bc61584edb7160e1f11bbd5ff35f69861da (diff) | |
download | meta-freescale-4f980553868ff8f99acf61eba3a1c578c7a1c02b.tar.gz |
inherit qoriq_build_64bit_kernel for kernel/module recipes
ppce6500 is a specific core which only support 64bit kernel, the duplicate
hack codes were packaged into qoriq_build_64bit_kernel.bbclass, use it.
Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'meta-fsl-ppc/recipes-kernel/ceetm')
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb | 21 |
1 files changed, 1 insertions, 20 deletions
diff --git a/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb b/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb index 7620cdbc..266261eb 100644 --- a/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb +++ b/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb | |||
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" | |||
4 | 4 | ||
5 | DEPENDS="virtual/kernel" | 5 | DEPENDS="virtual/kernel" |
6 | 6 | ||
7 | inherit module | 7 | inherit module qoriq_build_64bit_kernel |
8 | 8 | ||
9 | SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;nobranch=1" | 9 | SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;nobranch=1" |
10 | SRCREV = "ecf55c9ca0cd42a212653e1f99c19cd611e3a008" | 10 | SRCREV = "ecf55c9ca0cd42a212653e1f99c19cd611e3a008" |
@@ -14,25 +14,6 @@ S = "${WORKDIR}/git" | |||
14 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" | 14 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" |
15 | export KERNEL_PATH = "${STAGING_KERNEL_DIR}" | 15 | export KERNEL_PATH = "${STAGING_KERNEL_DIR}" |
16 | 16 | ||
17 | python () { | ||
18 | ma = d.getVar("DISTRO_FEATURES", True) | ||
19 | arch = d.getVar("OVERRIDES", True) | ||
20 | |||
21 | # the : after the arch is to skip the message on 64b | ||
22 | if not "multiarch" in ma and "e6500:" in arch: | ||
23 | raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES") | ||
24 | |||
25 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
26 | |||
27 | if promote_kernel == "1": | ||
28 | d.setVar('KERNEL_CC_append', ' -m64') | ||
29 | d.setVar('KERNEL_LD_append', ' -melf64ppc') | ||
30 | |||
31 | error_qa = d.getVar('ERROR_QA', True) | ||
32 | if 'arch' in error_qa: | ||
33 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
34 | } | ||
35 | |||
36 | do_install(){ | 17 | do_install(){ |
37 | mkdir -p ${D}/usr/driver/ceetm | 18 | mkdir -p ${D}/usr/driver/ceetm |
38 | mkdir -p ${D}/${libdir}/tc | 19 | mkdir -p ${D}/${libdir}/tc |