diff options
author | Ting Liu <b28495@freescale.com> | 2014-07-11 02:49:10 -0500 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@freescale.com> | 2014-07-15 14:13:20 +0800 |
commit | 4f980553868ff8f99acf61eba3a1c578c7a1c02b (patch) | |
tree | 0afac9fc41745c1805dde3b4bda85ef83cd37e50 /meta-fsl-ppc | |
parent | 2e419bc61584edb7160e1f11bbd5ff35f69861da (diff) | |
download | meta-freescale-4f980553868ff8f99acf61eba3a1c578c7a1c02b.tar.gz |
inherit qoriq_build_64bit_kernel for kernel/module recipes
ppce6500 is a specific core which only support 64bit kernel, the duplicate
hack codes were packaged into qoriq_build_64bit_kernel.bbclass, use it.
Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'meta-fsl-ppc')
-rw-r--r-- | meta-fsl-ppc/recipes-bsp/ipc/ipc-modules.inc | 20 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/asf/asf_git.bb | 21 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb | 21 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/linux/linux-qoriq.inc | 25 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/lttng/lttng-modules_%.bbappend | 18 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/pkc-host/pkc-host_git.bb | 21 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/qoriq-debug/qoriq-debug_git.bb | 21 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/skmm-host/skmm-host_git.bb | 21 |
8 files changed, 8 insertions, 160 deletions
diff --git a/meta-fsl-ppc/recipes-bsp/ipc/ipc-modules.inc b/meta-fsl-ppc/recipes-bsp/ipc/ipc-modules.inc index 015a91bc..3d7dfa66 100644 --- a/meta-fsl-ppc/recipes-bsp/ipc/ipc-modules.inc +++ b/meta-fsl-ppc/recipes-bsp/ipc/ipc-modules.inc | |||
@@ -5,27 +5,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10" | |||
5 | 5 | ||
6 | require ipc.inc | 6 | require ipc.inc |
7 | 7 | ||
8 | inherit module | 8 | inherit module qoriq_build_64bit_kernel |
9 | 9 | ||
10 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
11 | python () { | ||
12 | ma = d.getVar("DISTRO_FEATURES", True) | ||
13 | arch = d.getVar("OVERRIDES", True) | ||
14 | |||
15 | # the : after the arch is to skip the message on 64b | ||
16 | if not "multiarch" in ma and ("e5500:" in arch or "e6500:" in arch): | ||
17 | raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES") | ||
18 | |||
19 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
20 | |||
21 | if promote_kernel == "1": | ||
22 | d.setVar('KERNEL_CC_append', ' -m64') | ||
23 | d.setVar('KERNEL_LD_append', ' -melf64ppc') | ||
24 | |||
25 | error_qa = d.getVar('ERROR_QA', True) | ||
26 | if 'arch' in error_qa: | ||
27 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
28 | } | ||
29 | 11 | ||
30 | do_compile_prepend () { | 12 | do_compile_prepend () { |
31 | cd ${S}/kernel | 13 | cd ${S}/kernel |
diff --git a/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb b/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb index 743ce62e..9597257c 100644 --- a/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb +++ b/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb | |||
@@ -9,32 +9,13 @@ SRCREV = "f107bc7dac7fe74d765dc09f66dca84951921d2c" | |||
9 | DEPENDS="virtual/kernel" | 9 | DEPENDS="virtual/kernel" |
10 | RDEPENDS_${PN} += "ipsec-tools" | 10 | RDEPENDS_${PN} += "ipsec-tools" |
11 | 11 | ||
12 | inherit module | 12 | inherit module qoriq_build_64bit_kernel |
13 | 13 | ||
14 | S = "${WORKDIR}/git/asfmodule" | 14 | S = "${WORKDIR}/git/asfmodule" |
15 | 15 | ||
16 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" | 16 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" |
17 | export KERNEL_PATH = "${STAGING_KERNEL_DIR}" | 17 | export KERNEL_PATH = "${STAGING_KERNEL_DIR}" |
18 | 18 | ||
19 | python () { | ||
20 | ma = d.getVar("DISTRO_FEATURES", True) | ||
21 | arch = d.getVar("OVERRIDES", True) | ||
22 | |||
23 | # the : after the arch is to skip the message on 64b | ||
24 | if not "multiarch" in ma and "e6500:" in arch: | ||
25 | raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES") | ||
26 | |||
27 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
28 | |||
29 | if promote_kernel == "1": | ||
30 | d.setVar('KERNEL_CC_append', ' -m64') | ||
31 | d.setVar('KERNEL_LD_append', ' -melf64ppc') | ||
32 | |||
33 | error_qa = d.getVar('ERROR_QA', True) | ||
34 | if 'arch' in error_qa: | ||
35 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
36 | } | ||
37 | |||
38 | do_install(){ | 19 | do_install(){ |
39 | mkdir -p ${D}/usr/driver/asf | 20 | mkdir -p ${D}/usr/driver/asf |
40 | cp -rf ${S}/bin/full ${D}/usr/driver/asf | 21 | cp -rf ${S}/bin/full ${D}/usr/driver/asf |
diff --git a/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb b/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb index 7620cdbc..266261eb 100644 --- a/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb +++ b/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb | |||
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" | |||
4 | 4 | ||
5 | DEPENDS="virtual/kernel" | 5 | DEPENDS="virtual/kernel" |
6 | 6 | ||
7 | inherit module | 7 | inherit module qoriq_build_64bit_kernel |
8 | 8 | ||
9 | SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;nobranch=1" | 9 | SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;nobranch=1" |
10 | SRCREV = "ecf55c9ca0cd42a212653e1f99c19cd611e3a008" | 10 | SRCREV = "ecf55c9ca0cd42a212653e1f99c19cd611e3a008" |
@@ -14,25 +14,6 @@ S = "${WORKDIR}/git" | |||
14 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" | 14 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" |
15 | export KERNEL_PATH = "${STAGING_KERNEL_DIR}" | 15 | export KERNEL_PATH = "${STAGING_KERNEL_DIR}" |
16 | 16 | ||
17 | python () { | ||
18 | ma = d.getVar("DISTRO_FEATURES", True) | ||
19 | arch = d.getVar("OVERRIDES", True) | ||
20 | |||
21 | # the : after the arch is to skip the message on 64b | ||
22 | if not "multiarch" in ma and "e6500:" in arch: | ||
23 | raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES") | ||
24 | |||
25 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
26 | |||
27 | if promote_kernel == "1": | ||
28 | d.setVar('KERNEL_CC_append', ' -m64') | ||
29 | d.setVar('KERNEL_LD_append', ' -melf64ppc') | ||
30 | |||
31 | error_qa = d.getVar('ERROR_QA', True) | ||
32 | if 'arch' in error_qa: | ||
33 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
34 | } | ||
35 | |||
36 | do_install(){ | 17 | do_install(){ |
37 | mkdir -p ${D}/usr/driver/ceetm | 18 | mkdir -p ${D}/usr/driver/ceetm |
38 | mkdir -p ${D}/${libdir}/tc | 19 | mkdir -p ${D}/${libdir}/tc |
diff --git a/meta-fsl-ppc/recipes-kernel/linux/linux-qoriq.inc b/meta-fsl-ppc/recipes-kernel/linux/linux-qoriq.inc index 00fe526f..9e463ddb 100644 --- a/meta-fsl-ppc/recipes-kernel/linux/linux-qoriq.inc +++ b/meta-fsl-ppc/recipes-kernel/linux/linux-qoriq.inc | |||
@@ -1,4 +1,4 @@ | |||
1 | inherit kernel | 1 | inherit kernel qoriq_build_64bit_kernel |
2 | require recipes-kernel/linux/linux-dtb.inc | 2 | require recipes-kernel/linux/linux-dtb.inc |
3 | 3 | ||
4 | DESCRIPTION = "Linux kernel for Freescale platforms" | 4 | DESCRIPTION = "Linux kernel for Freescale platforms" |
@@ -9,29 +9,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | |||
9 | KSRC ?= "" | 9 | KSRC ?= "" |
10 | S = '${@base_conditional("KSRC", "", "${WORKDIR}/git", "${KSRC}", d)}' | 10 | S = '${@base_conditional("KSRC", "", "${WORKDIR}/git", "${KSRC}", d)}' |
11 | 11 | ||
12 | python () { | ||
13 | ma = d.getVar("DISTRO_FEATURES", True) | ||
14 | arch = d.getVar("OVERRIDES", True) | ||
15 | |||
16 | # the : after the arch is to skip the message on 64b | ||
17 | if not "multiarch" in ma and ("e5500:" in arch or "e6500:" in arch): | ||
18 | raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES") | ||
19 | |||
20 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
21 | |||
22 | if promote_kernel == "1": | ||
23 | d.setVar('KERNEL_CC_append', ' -m64') | ||
24 | d.setVar('KERNEL_LD_append', ' -melf64ppc') | ||
25 | |||
26 | error_qa = d.getVar('ERROR_QA', True) | ||
27 | if 'arch' in error_qa: | ||
28 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
29 | |||
30 | all_qa = d.getVar('ALL_QA', True) | ||
31 | if 'arch' in all_qa: | ||
32 | d.setVar('ALL_QA', all_qa.replace(' arch', '')) | ||
33 | } | ||
34 | |||
35 | DEPENDS_append = " libgcc" | 12 | DEPENDS_append = " libgcc" |
36 | KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" | 13 | KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" |
37 | KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" | 14 | KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" |
diff --git a/meta-fsl-ppc/recipes-kernel/lttng/lttng-modules_%.bbappend b/meta-fsl-ppc/recipes-kernel/lttng/lttng-modules_%.bbappend index 5415f16e..5ff765d4 100644 --- a/meta-fsl-ppc/recipes-kernel/lttng/lttng-modules_%.bbappend +++ b/meta-fsl-ppc/recipes-kernel/lttng/lttng-modules_%.bbappend | |||
@@ -1,18 +1,2 @@ | |||
1 | inherit distro_features_check | 1 | inherit qoriq_build_64bit_kernel |
2 | 2 | ||
3 | REQUIRED_DISTRO_FEATURES_append_e6500 ?= "multiarch" | ||
4 | |||
5 | python () { | ||
6 | |||
7 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
8 | |||
9 | if promote_kernel == "1": | ||
10 | d.appendVar('KERNEL_CC', ' -m64') | ||
11 | d.appendVar('KERNEL_LD', ' -melf64ppc') | ||
12 | |||
13 | |||
14 | error_qa = d.getVar('ERROR_QA', True) | ||
15 | if 'arch' in error_qa: | ||
16 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
17 | |||
18 | } | ||
diff --git a/meta-fsl-ppc/recipes-kernel/pkc-host/pkc-host_git.bb b/meta-fsl-ppc/recipes-kernel/pkc-host/pkc-host_git.bb index 9535005d..2e579c1e 100644 --- a/meta-fsl-ppc/recipes-kernel/pkc-host/pkc-host_git.bb +++ b/meta-fsl-ppc/recipes-kernel/pkc-host/pkc-host_git.bb | |||
@@ -3,7 +3,7 @@ SECTION = "pkc-host" | |||
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=6a26ed8e76a8ea2e019c525369ed0f03" | 4 | LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=6a26ed8e76a8ea2e019c525369ed0f03" |
5 | 5 | ||
6 | inherit module | 6 | inherit module qoriq_build_64bit_kernel |
7 | 7 | ||
8 | SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;nobranch=1" | 8 | SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;nobranch=1" |
9 | SRCREV = "cae512c94e2a26cc6b0d6393d307cdea2d7282c9" | 9 | SRCREV = "cae512c94e2a26cc6b0d6393d307cdea2d7282c9" |
@@ -12,25 +12,6 @@ S = "${WORKDIR}/git" | |||
12 | 12 | ||
13 | EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' | 13 | EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' |
14 | 14 | ||
15 | python () { | ||
16 | ma = d.getVar("DISTRO_FEATURES", True) | ||
17 | arch = d.getVar("OVERRIDES", True) | ||
18 | |||
19 | # the : after the arch is to skip the message on 64b | ||
20 | if not "multiarch" in ma and ("e5500:" in arch or "e6500:" in arch): | ||
21 | raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES") | ||
22 | |||
23 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
24 | |||
25 | if promote_kernel == "1": | ||
26 | d.setVar('KERNEL_CC_append', ' -m64') | ||
27 | d.setVar('KERNEL_LD_append', ' -melf64ppc') | ||
28 | |||
29 | error_qa = d.getVar('ERROR_QA', True) | ||
30 | if 'arch' in error_qa: | ||
31 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
32 | } | ||
33 | |||
34 | do_install() { | 15 | do_install() { |
35 | install -d ${D}/lib/modules/c2x0 | 16 | install -d ${D}/lib/modules/c2x0 |
36 | install -d ${D}/etc/crypto | 17 | install -d ${D}/etc/crypto |
diff --git a/meta-fsl-ppc/recipes-kernel/qoriq-debug/qoriq-debug_git.bb b/meta-fsl-ppc/recipes-kernel/qoriq-debug/qoriq-debug_git.bb index 5dd2468d..c08f057f 100644 --- a/meta-fsl-ppc/recipes-kernel/qoriq-debug/qoriq-debug_git.bb +++ b/meta-fsl-ppc/recipes-kernel/qoriq-debug/qoriq-debug_git.bb | |||
@@ -3,7 +3,7 @@ SECTION = "qoriq-debug" | |||
3 | LICENSE = "GPLv2+" | 3 | LICENSE = "GPLv2+" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=e29234dd5d40dc352cc60cc0c93437ba" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=e29234dd5d40dc352cc60cc0c93437ba" |
5 | 5 | ||
6 | inherit module autotools-brokensep | 6 | inherit module autotools-brokensep qoriq_build_64bit_kernel |
7 | 7 | ||
8 | SRC_URI = "git://git.freescale.com/ppc/sdk/qoriq-debug.git;nobranch=1" | 8 | SRC_URI = "git://git.freescale.com/ppc/sdk/qoriq-debug.git;nobranch=1" |
9 | SRCREV = "20615c1ea332102635f8314cee5787c48c1a4254" | 9 | SRCREV = "20615c1ea332102635f8314cee5787c48c1a4254" |
@@ -13,22 +13,3 @@ S = "${WORKDIR}/git" | |||
13 | EXTRA_OECONF += "--with-linux=${STAGING_KERNEL_DIR}" | 13 | EXTRA_OECONF += "--with-linux=${STAGING_KERNEL_DIR}" |
14 | EXTRA_OEMAKE += 'SYSROOT="${D}"' | 14 | EXTRA_OEMAKE += 'SYSROOT="${D}"' |
15 | 15 | ||
16 | python () { | ||
17 | ma = d.getVar("DISTRO_FEATURES", True) | ||
18 | arch = d.getVar("OVERRIDES", True) | ||
19 | |||
20 | # the : after the arch is to skip the message on 64b | ||
21 | if not "multiarch" in ma and ("e5500:" in arch or "e6500:" in arch): | ||
22 | raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES") | ||
23 | |||
24 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
25 | |||
26 | if promote_kernel == "1": | ||
27 | d.setVar('KERNEL_CC_append', ' -m64') | ||
28 | d.setVar('KERNEL_LD_append', ' -melf64ppc') | ||
29 | |||
30 | error_qa = d.getVar('ERROR_QA', True) | ||
31 | if 'arch' in error_qa: | ||
32 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
33 | } | ||
34 | |||
diff --git a/meta-fsl-ppc/recipes-kernel/skmm-host/skmm-host_git.bb b/meta-fsl-ppc/recipes-kernel/skmm-host/skmm-host_git.bb index 9ce8a1dd..a1c43f35 100644 --- a/meta-fsl-ppc/recipes-kernel/skmm-host/skmm-host_git.bb +++ b/meta-fsl-ppc/recipes-kernel/skmm-host/skmm-host_git.bb | |||
@@ -3,7 +3,7 @@ SECTION = "c293-skmm-host" | |||
3 | LICENSE = "Freescale-EULA" | 3 | LICENSE = "Freescale-EULA" |
4 | LIC_FILES_CHKSUM = "file://Makefile;endline=7;md5=edffaac1da9e809ade0d2fcfcc18d8df" | 4 | LIC_FILES_CHKSUM = "file://Makefile;endline=7;md5=edffaac1da9e809ade0d2fcfcc18d8df" |
5 | 5 | ||
6 | inherit module | 6 | inherit module qoriq_build_64bit_kernel |
7 | 7 | ||
8 | SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-host.git;nobranch=1" | 8 | SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-host.git;nobranch=1" |
9 | SRCREV = "97c9241a359edccdf8913cb9accbfe4ceb511523" | 9 | SRCREV = "97c9241a359edccdf8913cb9accbfe4ceb511523" |
@@ -12,23 +12,4 @@ S = "${WORKDIR}/git" | |||
12 | 12 | ||
13 | EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' | 13 | EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' |
14 | 14 | ||
15 | python () { | ||
16 | ma = d.getVar("DISTRO_FEATURES", True) | ||
17 | arch = d.getVar("OVERRIDES", True) | ||
18 | |||
19 | # the : after the arch is to skip the message on 64b | ||
20 | if not "multiarch" in ma and ("e5500:" in arch or "e6500:" in arch): | ||
21 | raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES") | ||
22 | |||
23 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
24 | |||
25 | if promote_kernel == "1": | ||
26 | d.setVar('KERNEL_CC_append', ' -m64') | ||
27 | d.setVar('KERNEL_LD_append', ' -melf64ppc') | ||
28 | |||
29 | error_qa = d.getVar('ERROR_QA', True) | ||
30 | if 'arch' in error_qa: | ||
31 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
32 | } | ||
33 | |||
34 | FILES_${PN} += "/etc/skmm/" | 15 | FILES_${PN} += "/etc/skmm/" |