summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Klauer <daniel.klauer@gin.de>2019-08-01 11:06:56 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-08-15 14:49:22 -0300
commitc090df937b5f9e5487c045d1a6c958ef65abd87d (patch)
treed402d5b7cf7d0d30fd4e89c0edb32803c2c1ac4b
parentaac5d31be8cca3dc58513fb3ad1d81d041fba140 (diff)
downloadmeta-freescale-c090df937b5f9e5487c045d1a6c958ef65abd87d.tar.gz
Split fiptool build into separate recipe
Previously, ddr-phy built native fiptool during its own build process, but without using Yocto's native toolchain settings. This results in unexpected host dependencies. For example, fiptool depends on openssl, which may or may not be installed on the host. So now fiptool is built in a separate recipe (atf-tools-native) which can easily depend on openssl. Signed-off-by: Daniel Klauer <daniel.klauer@gin.de>
-rw-r--r--recipes-bsp/atf/atf-tools_git.bb19
-rw-r--r--recipes-bsp/ddr-phy/ddr-phy_git.bb14
2 files changed, 27 insertions, 6 deletions
diff --git a/recipes-bsp/atf/atf-tools_git.bb b/recipes-bsp/atf/atf-tools_git.bb
new file mode 100644
index 00000000..a5998fe2
--- /dev/null
+++ b/recipes-bsp/atf/atf-tools_git.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Tools for ARM Trusted Firmware, e.g. FIP image creation tool"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://license.rst;md5=e927e02bca647e14efd87e9e914b2443"
4
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1"
6SRCREV = "17f94e4315e81e3d1b22d863d9614d724e8273dc"
7
8S = "${WORKDIR}/git"
9
10DEPENDS += "openssl"
11
12EXTRA_OEMAKE = "fiptool V=1 HOSTCC='${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}'"
13
14do_install () {
15 install -m 0755 -d ${D}/${bindir}
16 install -m 0755 ${S}/tools/fiptool/fiptool ${D}/${bindir}/
17}
18
19BBCLASSEXTEND = "native"
diff --git a/recipes-bsp/ddr-phy/ddr-phy_git.bb b/recipes-bsp/ddr-phy/ddr-phy_git.bb
index 98a9b029..d98d102f 100644
--- a/recipes-bsp/ddr-phy/ddr-phy_git.bb
+++ b/recipes-bsp/ddr-phy/ddr-phy_git.bb
@@ -4,19 +4,18 @@ LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=89cc852481956e861228286ac7430
4 4
5inherit deploy fsl-eula-unpack 5inherit deploy fsl-eula-unpack
6 6
7SRC_URI = "git://github.com/nxp/ddr-phy-binary.git;fsl-eula=true;nobranch=1 \ 7SRC_URI = "git://github.com/nxp/ddr-phy-binary.git;fsl-eula=true;nobranch=1"
8 git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1;destsuffix=git/atf;name=atf"
9SRCREV = "14d03e6e748ed5ebb9440f264bb374f1280b061c" 8SRCREV = "14d03e6e748ed5ebb9440f264bb374f1280b061c"
10SRCREV_atf = "17f94e4315e81e3d1b22d863d9614d724e8273dc"
11 9
12S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
13 11
14REGLEX_lx2160a = "lx2160a" 12REGLEX_lx2160a = "lx2160a"
15 13
16do_install () { 14DEPENDS += "atf-tools-native"
17 oe_runmake -C ${S}/atf fiptool 15
16do_compile() {
18 cd ${S}/${REGLEX} 17 cd ${S}/${REGLEX}
19 ${S}/atf/tools/fiptool/fiptool create --ddr-immem-udimm-1d ddr4_pmu_train_imem.bin \ 18 fiptool create --ddr-immem-udimm-1d ddr4_pmu_train_imem.bin \
20 --ddr-immem-udimm-2d ddr4_2d_pmu_train_imem.bin \ 19 --ddr-immem-udimm-2d ddr4_2d_pmu_train_imem.bin \
21 --ddr-dmmem-udimm-1d ddr4_pmu_train_dmem.bin \ 20 --ddr-dmmem-udimm-1d ddr4_pmu_train_dmem.bin \
22 --ddr-dmmem-udimm-2d ddr4_2d_pmu_train_dmem.bin \ 21 --ddr-dmmem-udimm-2d ddr4_2d_pmu_train_dmem.bin \
@@ -25,6 +24,9 @@ do_install () {
25 --ddr-dmmem-rdimm-1d ddr4_rdimm_pmu_train_dmem.bin \ 24 --ddr-dmmem-rdimm-1d ddr4_rdimm_pmu_train_dmem.bin \
26 --ddr-dmmem-rdimm-2d ddr4_rdimm2d_pmu_train_dmem.bin \ 25 --ddr-dmmem-rdimm-2d ddr4_rdimm2d_pmu_train_dmem.bin \
27 fip_ddr_all.bin 26 fip_ddr_all.bin
27}
28
29do_install () {
28 install -d ${D}/boot 30 install -d ${D}/boot
29 install -m 755 ${S}/${REGLEX}/*.bin ${D}/boot 31 install -m 755 ${S}/${REGLEX}/*.bin ${D}/boot
30} 32}