summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlban Bedel <alban.bedel@aerq.com>2019-08-15 11:39:18 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-08-15 14:48:45 -0300
commitaac5d31be8cca3dc58513fb3ad1d81d041fba140 (patch)
tree321da9dfc4b5ab3f73d815b08d86fc42c59c405d
parent8788edcb649ef537a6c0972f302a1d00faefbee7 (diff)
downloadmeta-freescale-aac5d31be8cca3dc58513fb3ad1d81d041fba140.tar.gz
atf: Only enable and depends on optee when supported
Use the new optee machine feature to only enable it when it is supported by the machine and the distro. We use a package config switch to only add the dependency when it is needed. This prevent a build failure on machines that don't support optee. Signed-off-by: Alban Bedel <alban.bedel@aerq.com>
-rw-r--r--recipes-bsp/atf/atf_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb
index 0f70d730..bc182ebe 100644
--- a/recipes-bsp/atf/atf_git.bb
+++ b/recipes-bsp/atf/atf_git.bb
@@ -7,7 +7,6 @@ inherit deploy
7 7
8DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native mbedtls rcw cst-native" 8DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native mbedtls rcw cst-native"
9DEPENDS_append_lx2160a += "ddr-phy" 9DEPENDS_append_lx2160a += "ddr-phy"
10DEPENDS_append_qoriq-arm64 += "optee-os-qoriq"
11do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy" 10do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy"
12 11
13S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
@@ -32,9 +31,14 @@ LD[unexport] = "1"
32 31
33BOOTTYPE ?= "nor nand qspi flexspi_nor sd emmc" 32BOOTTYPE ?= "nor nand qspi flexspi_nor sd emmc"
34BUILD_SECURE = "${@bb.utils.contains('DISTRO_FEATURES', 'secure', 'true', 'false', d)}" 33BUILD_SECURE = "${@bb.utils.contains('DISTRO_FEATURES', 'secure', 'true', 'false', d)}"
35BUILD_OPTEE = "${@bb.utils.contains('DISTRO_FEATURES', 'optee', 'true', 'false', d)}" 34BUILD_OPTEE = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', 'true', 'false', d)}"
36BUILD_FUSE = "${@bb.utils.contains('DISTRO_FEATURES', 'fuse', 'true', 'false', d)}" 35BUILD_FUSE = "${@bb.utils.contains('DISTRO_FEATURES', 'fuse', 'true', 'false', d)}"
37 36
37PACKAGECONFIG ??= " \
38 ${@bb.utils.filter('COMBINED_FEATURES', 'optee', d)} \
39"
40PACKAGECONFIG[optee] = ",,optee-os-qoriq"
41
38uboot_boot_sec ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa-secure-boot" 42uboot_boot_sec ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa-secure-boot"
39uboot_boot ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa" 43uboot_boot ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa"
40rcw ?= "" 44rcw ?= ""