summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristian Bercaru <cristian.bercaru@enea.com>2018-05-14 15:09:15 +0200
committerCristian Bercaru <cristian.bercaru@enea.com>2018-05-14 15:09:15 +0200
commitc4127de63ca38ca6bdcfb8b75c84589ab887893f (patch)
tree1af5f1e669eeaafbd19e470094fb725283094271
parent522cbc53e56efb9ca3b9b775e8ee1bb095fc220a (diff)
downloadmeta-freescale-pyro-fnc-el7.tar.gz
openssl-qoriq: add version 1.1.0hpyro-fnc-el7
-rw-r--r--openssl-1.1.0h.patch409
-rwxr-xr-xrecipes-connectivity/openssl/openssl-qoriq/perlpath.pl35
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq/run-ptest.new4
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb79
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.1.0h.inc267
5 files changed, 794 insertions, 0 deletions
diff --git a/openssl-1.1.0h.patch b/openssl-1.1.0h.patch
new file mode 100644
index 00000000..0cb5a1a8
--- /dev/null
+++ b/openssl-1.1.0h.patch
@@ -0,0 +1,409 @@
1diff --git a/recipes-connectivity/openssl/openssl-qoriq/perlpath.pl b/recipes-connectivity/openssl/openssl-qoriq/perlpath.pl
2new file mode 100755
3index 0000000..79d4a40
4--- /dev/null
5+++ b/recipes-connectivity/openssl/openssl-qoriq/perlpath.pl
6@@ -0,0 +1,35 @@
7+#!/media/data/fb/daaz/p2040/tmp/work/ppce500mc-qoriq-poky-linux/openssl-qoriq/1.0.2l-r0/recipe-sysroot-native/usr/bin/perl
8+#
9+# modify the '#!/usr/local/bin/perl'
10+# line in all scripts that rely on perl.
11+#
12+
13+require "find.pl";
14+
15+$#ARGV == 0 || print STDERR "usage: perlpath newpath (eg /usr/bin)\n";
16+&find(".");
17+
18+sub wanted
19+ {
20+ return unless /\.pl$/ || /^[Cc]onfigur/;
21+
22+ open(IN,"<$_") || die "unable to open $dir/$_:$!\n";
23+ @a=<IN>;
24+ close(IN);
25+
26+ if (-d $ARGV[0]) {
27+ $a[0]="#!$ARGV[0]/perl\n";
28+ }
29+ else {
30+ $a[0]="#!$ARGV[0]\n";
31+ }
32+
33+ # Playing it safe...
34+ $new="$_.new";
35+ open(OUT,">$new") || die "unable to open $dir/$new:$!\n";
36+ print OUT @a;
37+ close(OUT);
38+
39+ rename($new,$_) || die "unable to rename $dir/$new:$!\n";
40+ chmod(0755,$_) || die "unable to chmod $dir/$new:$!\n";
41+ }
42diff --git a/recipes-connectivity/openssl/openssl-qoriq/run-ptest.new b/recipes-connectivity/openssl/openssl-qoriq/run-ptest.new
43new file mode 100644
44index 0000000..65c6cc7
45--- /dev/null
46+++ b/recipes-connectivity/openssl/openssl-qoriq/run-ptest.new
47@@ -0,0 +1,4 @@
48+#!/bin/sh
49+cd test
50+OPENSSL_ENGINES=../engines BLDTOP=.. SRCTOP=.. perl run_tests.pl
51+cd ..
52diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb
53new file mode 100644
54index 0000000..53a2181
55--- /dev/null
56+++ b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb
57@@ -0,0 +1,79 @@
58+require openssl-qoriq_1.1.0h.inc
59+
60+DISABLE_STATIC = ""
61+# For target side versions of openssl enable support for OCF Linux driver
62+# if they are available.
63+DEPENDS += "cryptodev-linux"
64+
65+CFLAGS += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
66+
67+LIC_FILES_CHKSUM = "file://LICENSE;md5=d57d511030c9d66ef5f5966bee5a7eff"
68+
69+SRC_URI[md5sum] = "5271477e4d93f4ea032b665ef095ff24"
70+
71+export DIRS = "crypto ssl apps engines"
72+export OE_LDFLAGS="${LDFLAGS}"
73+
74+SRC_URI = " \
75+ https://www.openssl.org/source/openssl-1.1.0h.tar.gz \
76+ file://openssl-c_rehash.sh \
77+ file://run-ptest \
78+ file://perlpath.pl \
79+ file://find.pl \
80+ file://debian/pic.patch \
81+ file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
82+ file://openssl-1.0.2a-x32-asm.patch \
83+ "
84+# file://0001-Fix-build-with-clang-using-external-assembler.patch \
85+# file://Use-SHA256-not-MD5-as-default-digest.patch \
86+# file://openssl-util-perlpath.pl-cwd.patch \
87+# file://parallel.patch \
88+# file://configure-musl-target.patch \
89+# file://ptest_makefile_deps.patch \
90+# file://ptest-deps.patch \
91+# file://Makefiles-ptest.patch \
92+# file://openssl-fix-des.pod-error.patch \
93+# file://openssl_fix_for_x32.patch \
94+# file://debian1.0.2/soname.patch \
95+# file://debian1.0.2/version-script.patch \
96+# file://debian/no-symbolic.patch \
97+# file://debian/no-rpath.patch \
98+# file://debian/man-dir.patch \
99+# file://debian/man-section.patch \
100+# file://debian/debian-targets.patch \
101+# file://debian/c_rehash-compat.patch \
102+# file://debian/ca.patch \
103+# file://debian1.0.2/block_digicert_malaysia.patch \
104+# file://debian1.0.2/block_diginotar.patch \
105+# file://engines-install-in-libdir-ssl.patch \
106+# file://oe-ldflags.patch \
107+# file://shared-libs.patch \
108+# file://configure-targets.patch
109+#
110+
111+S = "${WORKDIR}/openssl-1.1.0h/"
112+
113+PACKAGES =+ "${PN}-engines"
114+
115+FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines ${libdir}/engines-1.1/*.so"
116+
117+# The crypto_use_bigint patch means that perl's bignum module needs to be
118+# installed, but some distributions (for example Fedora 23) don't ship it by
119+# default. As the resulting error is very misleading check for bignum before
120+# building.
121+do_configure_prepend() {
122+ mkdir -p ${S}/util/
123+ cp ${WORKDIR}/perlpath.pl ${S}/util/
124+ cp ${WORKDIR}/find.pl ${S}/util/
125+ if ! perl -Mbigint -e true; then
126+ bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
127+ fi
128+}
129+
130+do_compile_ptest_base() {
131+ echo
132+}
133+
134+TARGET_CC_ARCH += "${LDFLAGS}"
135+
136+COMPATIBLE_MACHINE = "(qoriq)"
137diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.inc b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.inc
138new file mode 100644
139index 0000000..f58774f
140--- /dev/null
141+++ b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.inc
142@@ -0,0 +1,267 @@
143+SUMMARY = "Secure Socket Layer"
144+DESCRIPTION = "Secure Socket Layer (SSL) binary and related cryptographic tools."
145+HOMEPAGE = "http://www.openssl.org/"
146+BUGTRACKER = "http://www.openssl.org/news/vulnerabilities.html"
147+SECTION = "libs/network"
148+
149+# "openssl | SSLeay" dual license
150+LICENSE = "openssl"
151+LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
152+
153+DEPENDS = "makedepend-native hostperl-runtime-native"
154+DEPENDS_append_class-target = " openssl-native"
155+
156+PROVIDES = "openssl"
157+
158+python() {
159+ pkgs = d.getVar('PACKAGES', True).split()
160+ for p in pkgs:
161+ if 'openssl-qoriq' in p:
162+ d.appendVar("RPROVIDES_%s" % p, p.replace('openssl-qoriq', 'openssl'))
163+ d.appendVar("RCONFLICTS_%s" % p, p.replace('openssl-qoriq', 'openssl'))
164+ d.appendVar("RREPLACES_%s" % p, p.replace('openssl-qoriq', 'openssl'))
165+}
166+
167+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/openssl;nobranch=1"
168+
169+S = "${WORKDIR}/git"
170+
171+PACKAGECONFIG[perl] = ",,,"
172+
173+TERMIO_libc-musl = "-DTERMIOS"
174+TERMIO ?= "-DTERMIO"
175+# Avoid binaries being marked as requiring an executable stack since it
176+# doesn't(which causes and this causes issues with SELinux
177+CFLAG = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
178+ ${TERMIO} ${CFLAGS} -Wall -Wa,--noexecstack"
179+
180+export DIRS = "crypto ssl apps"
181+export EX_LIBS = "-lgcc -ldl"
182+export AS = "${CC} -c"
183+
184+inherit pkgconfig siteinfo multilib_header ptest relative_symlinks
185+
186+PACKAGES =+ "libcrypto libssl ${PN}-misc ${PN}-conf"
187+FILES_libcrypto = "${libdir}/libcrypto${SOLIBS}"
188+FILES_libssl = "${libdir}/libssl${SOLIBS}"
189+FILES_${PN} =+ " ${libdir}/ssl/*"
190+FILES_${PN}-misc = "${libdir}/ssl/misc"
191+RDEPENDS_${PN}-misc = "${@bb.utils.filter('PACKAGECONFIG', 'perl', d)}"
192+
193+PROVIDES += "openssl10"
194+
195+# Add the openssl.cnf file to the openssl-conf package. Make the libcrypto
196+# package RRECOMMENDS on this package. This will enable the configuration
197+# file to be installed for both the base openssl package and the libcrypto
198+# package since the base openssl package depends on the libcrypto package.
199+FILES_${PN}-conf = "${sysconfdir}/ssl/openssl.cnf"
200+CONFFILES_${PN}-conf = "${sysconfdir}/ssl/openssl.cnf"
201+RRECOMMENDS_libcrypto += "${PN}-conf"
202+RDEPENDS_${PN}-ptest += "${PN}-misc make perl perl-module-filehandle bc"
203+
204+# Remove this to enable SSLv3. SSLv3 is defaulted to disabled due to the POODLE
205+# vulnerability
206+EXTRA_OECONF = " -no-ssl3"
207+
208+do_configure_prepend_darwin () {
209+ sed -i -e '/version-script=openssl\.ld/d' Configure
210+}
211+
212+do_configure () {
213+ cd util
214+ perl perlpath.pl ${STAGING_BINDIR_NATIVE}
215+ cd ..
216+ ln -sf apps/openssl.pod crypto/crypto.pod ssl/ssl.pod doc/
217+
218+ os=${HOST_OS}
219+ case $os in
220+ linux-uclibc |\
221+ linux-uclibceabi |\
222+ linux-gnueabi |\
223+ linux-uclibcspe |\
224+ linux-gnuspe |\
225+ linux-musl*)
226+ os=linux
227+ ;;
228+ *)
229+ ;;
230+ esac
231+ target="$os-${HOST_ARCH}"
232+ case $target in
233+ linux-arm)
234+ target=linux-armv4
235+ ;;
236+ linux-armeb)
237+ target=linux-elf-armeb
238+ ;;
239+ linux-aarch64*)
240+ target=linux-aarch64
241+ ;;
242+ linux-sh3)
243+ target=debian-sh3
244+ ;;
245+ linux-sh4)
246+ target=debian-sh4
247+ ;;
248+ linux-i486)
249+ target=debian-i386-i486
250+ ;;
251+ linux-i586 | linux-viac3)
252+ target=debian-i386-i586
253+ ;;
254+ linux-i686)
255+ target=debian-i386-i686/cmov
256+ ;;
257+ linux-gnux32-x86_64)
258+ target=linux-x32
259+ ;;
260+ linux-gnu64-x86_64)
261+ target=linux-x86_64
262+ ;;
263+ linux-gnun32-mips*el)
264+ target=debian-mipsn32el
265+ ;;
266+ linux-gnun32-mips*)
267+ target=debian-mipsn32
268+ ;;
269+ linux-mips*64*el)
270+ target=debian-mips64el
271+ ;;
272+ linux-mips*64*)
273+ target=debian-mips64
274+ ;;
275+ linux-mips*el)
276+ target=debian-mipsel
277+ ;;
278+ linux-mips*)
279+ target=debian-mips
280+ ;;
281+ linux-microblaze*|linux-nios2*)
282+ target=linux-generic32
283+ ;;
284+ linux-powerpc)
285+ target=linux-ppc
286+ ;;
287+ linux-powerpc64)
288+ target=linux-ppc64
289+ ;;
290+ linux-supersparc)
291+ target=linux-sparcv8
292+ ;;
293+ linux-sparc)
294+ target=linux-sparcv8
295+ ;;
296+ darwin-i386)
297+ target=darwin-i386-cc
298+ ;;
299+ esac
300+ # inject machine-specific flags
301+ sed -i -e "s|^\(\"$target\",\s*\"[^:]\+\):\([^:]\+\)|\1:${CFLAG}|g" Configure
302+ useprefix=${prefix}
303+ if [ "x$useprefix" = "x" ]; then
304+ useprefix=/
305+ fi
306+ perl ./Configure ${EXTRA_OECONF} shared --prefix=$useprefix --openssldir=${libdir}/ssl --libdir=`basename ${libdir}` $target
307+}
308+
309+do_compile_prepend_class-target () {
310+ sed -i 's/\((OPENSSL=\)".*"/\1"openssl"/' Makefile
311+}
312+
313+do_compile () {
314+ oe_runmake depend
315+ oe_runmake
316+}
317+
318+do_compile_ptest () {
319+ # build dependencies for test directory too
320+ rm -rf test/ssltest_old
321+ rm -rf test/x509aux
322+ rm -rf test/v3ext
323+ export DIRS="$DIRS test"
324+ oe_runmake depend
325+ oe_runmake buildtest
326+}
327+
328+do_install () {
329+ # Create ${D}/${prefix} to fix parallel issues
330+ mkdir -p ${D}/${prefix}/
331+
332+ oe_runmake INSTALL_PREFIX="${D}" MANDIR="${mandir}" DESTDIR="${D}" install
333+
334+ oe_libinstall -so libcrypto ${D}${libdir}
335+ oe_libinstall -so libssl ${D}${libdir}
336+ oe_libinstall -so capi ${D}${libdir}
337+ oe_libinstall -so padlock ${D}${libdir}
338+
339+ install -d ${D}${includedir}
340+ cp --dereference -R include/openssl ${D}${includedir}
341+
342+ install -Dm 0755 ${WORKDIR}/openssl-c_rehash.sh ${D}${bindir}/c_rehash
343+ sed -i -e 's,/etc/openssl,${sysconfdir}/ssl,g' ${D}${bindir}/c_rehash
344+
345+ oe_multilib_header openssl/opensslconf.h
346+ if [ "${@bb.utils.filter('PACKAGECONFIG', 'perl', d)}" ]; then
347+ sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${libdir}/ssl/misc/CA.pl
348+ sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${libdir}/ssl/misc/tsget
349+ else
350+ rm -f ${D}${libdir}/ssl/misc/CA.pl ${D}${libdir}/ssl/misc/tsget
351+ fi
352+
353+ # Create SSL structure
354+ install -d ${D}${sysconfdir}/ssl/
355+ mv ${D}${libdir}/ssl/openssl.cnf \
356+ ${D}${libdir}/ssl/certs \
357+ ${D}${libdir}/ssl/private \
358+ \
359+ ${D}${sysconfdir}/ssl/
360+ ln -sf ${sysconfdir}/ssl/certs ${D}${libdir}/ssl/certs
361+ ln -sf ${sysconfdir}/ssl/private ${D}${libdir}/ssl/private
362+ ln -sf ${sysconfdir}/ssl/openssl.cnf ${D}${libdir}/ssl/openssl.cnf
363+}
364+
365+do_install_ptest () {
366+ # cp -r -L Makefile.org Makefile test ${D}${PTEST_PATH}
367+ cp -r -L Makefile test ${D}${PTEST_PATH}
368+
369+ # Replace the path to native perl with the path to target perl
370+ sed -i 's,^PERL=.*,PERL=${bindir}/perl,' ${D}${PTEST_PATH}/Makefile
371+
372+ cp Configure config e_os.h ${D}${PTEST_PATH}
373+ cp -r -L include ${D}${PTEST_PATH}
374+ ln -sf ${libdir}/libcrypto.a ${D}${PTEST_PATH}
375+ ln -sf ${libdir}/libssl.a ${D}${PTEST_PATH}
376+ mkdir -p ${D}${PTEST_PATH}/crypto
377+ cp include/internal/constant_time_locl.h ${D}${PTEST_PATH}/crypto
378+ cp -r demos/certs ${D}${PTEST_PATH}
379+ mkdir -p ${D}${PTEST_PATH}/apps
380+ ln -sf ${libdir}/ssl/misc/CA.sh ${D}${PTEST_PATH}/apps
381+ ln -sf ${sysconfdir}/ssl/openssl.cnf ${D}${PTEST_PATH}/apps
382+ ln -sf ${bindir}/openssl ${D}${PTEST_PATH}/apps
383+ cp apps/server.pem ${D}${PTEST_PATH}/apps
384+ cp apps/server2.pem ${D}${PTEST_PATH}/apps
385+ mkdir -p ${D}${PTEST_PATH}/util
386+ install util/opensslwrap.sh ${D}${PTEST_PATH}/util
387+ install util/shlib_wrap.sh ${D}${PTEST_PATH}/util
388+ # Time stamps are relevant for "make alltests", otherwise
389+ # make may try to recompile binaries. Not only must the
390+ # binary files be newer than the sources, they also must
391+ # be more recent than the header files in /usr/include.
392+ #
393+ # Using "cp -a" is not sufficient, because do_install
394+ # does not preserve the original time stamps.
395+ #
396+ # So instead of using the original file stamps, we set
397+ # the current time for all files. Binaries will get
398+ # modified again later when stripping them, but that's okay.
399+ touch ${D}${PTEST_PATH}
400+ find ${D}${PTEST_PATH} -type f -print0 | xargs --verbose -0 touch -r ${D}${PTEST_PATH}
401+}
402+
403+do_install_append_class-native() {
404+ create_wrapper ${D}${bindir}/openssl \
405+ OPENSSL_CONF=${libdir}/ssl/openssl.cnf \
406+ SSL_CERT_DIR=${libdir}/ssl/certs \
407+ SSL_CERT_FILE=${libdir}/ssl/cert.pem \
408+ OPENSSL_ENGINES=${libdir}/ssl/engines
409+}
diff --git a/recipes-connectivity/openssl/openssl-qoriq/perlpath.pl b/recipes-connectivity/openssl/openssl-qoriq/perlpath.pl
new file mode 100755
index 00000000..79d4a406
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl-qoriq/perlpath.pl
@@ -0,0 +1,35 @@
1#!/media/data/fb/daaz/p2040/tmp/work/ppce500mc-qoriq-poky-linux/openssl-qoriq/1.0.2l-r0/recipe-sysroot-native/usr/bin/perl
2#
3# modify the '#!/usr/local/bin/perl'
4# line in all scripts that rely on perl.
5#
6
7require "find.pl";
8
9$#ARGV == 0 || print STDERR "usage: perlpath newpath (eg /usr/bin)\n";
10&find(".");
11
12sub wanted
13 {
14 return unless /\.pl$/ || /^[Cc]onfigur/;
15
16 open(IN,"<$_") || die "unable to open $dir/$_:$!\n";
17 @a=<IN>;
18 close(IN);
19
20 if (-d $ARGV[0]) {
21 $a[0]="#!$ARGV[0]/perl\n";
22 }
23 else {
24 $a[0]="#!$ARGV[0]\n";
25 }
26
27 # Playing it safe...
28 $new="$_.new";
29 open(OUT,">$new") || die "unable to open $dir/$new:$!\n";
30 print OUT @a;
31 close(OUT);
32
33 rename($new,$_) || die "unable to rename $dir/$new:$!\n";
34 chmod(0755,$_) || die "unable to chmod $dir/$new:$!\n";
35 }
diff --git a/recipes-connectivity/openssl/openssl-qoriq/run-ptest.new b/recipes-connectivity/openssl/openssl-qoriq/run-ptest.new
new file mode 100644
index 00000000..65c6cc7b
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl-qoriq/run-ptest.new
@@ -0,0 +1,4 @@
1#!/bin/sh
2cd test
3OPENSSL_ENGINES=../engines BLDTOP=.. SRCTOP=.. perl run_tests.pl
4cd ..
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb
new file mode 100644
index 00000000..53a21814
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb
@@ -0,0 +1,79 @@
1require openssl-qoriq_1.1.0h.inc
2
3DISABLE_STATIC = ""
4# For target side versions of openssl enable support for OCF Linux driver
5# if they are available.
6DEPENDS += "cryptodev-linux"
7
8CFLAGS += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=d57d511030c9d66ef5f5966bee5a7eff"
11
12SRC_URI[md5sum] = "5271477e4d93f4ea032b665ef095ff24"
13
14export DIRS = "crypto ssl apps engines"
15export OE_LDFLAGS="${LDFLAGS}"
16
17SRC_URI = " \
18 https://www.openssl.org/source/openssl-1.1.0h.tar.gz \
19 file://openssl-c_rehash.sh \
20 file://run-ptest \
21 file://perlpath.pl \
22 file://find.pl \
23 file://debian/pic.patch \
24 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
25 file://openssl-1.0.2a-x32-asm.patch \
26 "
27# file://0001-Fix-build-with-clang-using-external-assembler.patch \
28# file://Use-SHA256-not-MD5-as-default-digest.patch \
29# file://openssl-util-perlpath.pl-cwd.patch \
30# file://parallel.patch \
31# file://configure-musl-target.patch \
32# file://ptest_makefile_deps.patch \
33# file://ptest-deps.patch \
34# file://Makefiles-ptest.patch \
35# file://openssl-fix-des.pod-error.patch \
36# file://openssl_fix_for_x32.patch \
37# file://debian1.0.2/soname.patch \
38# file://debian1.0.2/version-script.patch \
39# file://debian/no-symbolic.patch \
40# file://debian/no-rpath.patch \
41# file://debian/man-dir.patch \
42# file://debian/man-section.patch \
43# file://debian/debian-targets.patch \
44# file://debian/c_rehash-compat.patch \
45# file://debian/ca.patch \
46# file://debian1.0.2/block_digicert_malaysia.patch \
47# file://debian1.0.2/block_diginotar.patch \
48# file://engines-install-in-libdir-ssl.patch \
49# file://oe-ldflags.patch \
50# file://shared-libs.patch \
51# file://configure-targets.patch
52#
53
54S = "${WORKDIR}/openssl-1.1.0h/"
55
56PACKAGES =+ "${PN}-engines"
57
58FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines ${libdir}/engines-1.1/*.so"
59
60# The crypto_use_bigint patch means that perl's bignum module needs to be
61# installed, but some distributions (for example Fedora 23) don't ship it by
62# default. As the resulting error is very misleading check for bignum before
63# building.
64do_configure_prepend() {
65 mkdir -p ${S}/util/
66 cp ${WORKDIR}/perlpath.pl ${S}/util/
67 cp ${WORKDIR}/find.pl ${S}/util/
68 if ! perl -Mbigint -e true; then
69 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
70 fi
71}
72
73do_compile_ptest_base() {
74 echo
75}
76
77TARGET_CC_ARCH += "${LDFLAGS}"
78
79COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.inc b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.inc
new file mode 100644
index 00000000..db768084
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.inc
@@ -0,0 +1,267 @@
1SUMMARY = "Secure Socket Layer"
2DESCRIPTION = "Secure Socket Layer (SSL) binary and related cryptographic tools."
3HOMEPAGE = "http://www.openssl.org/"
4BUGTRACKER = "http://www.openssl.org/news/vulnerabilities.html"
5SECTION = "libs/network"
6
7# "openssl | SSLeay" dual license
8LICENSE = "openssl"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
10
11DEPENDS = "makedepend-native hostperl-runtime-native"
12DEPENDS_append_class-target = " openssl-native"
13
14PROVIDES = "openssl"
15
16python() {
17 pkgs = d.getVar('PACKAGES', True).split()
18 for p in pkgs:
19 if 'openssl-qoriq' in p:
20 d.appendVar("RPROVIDES_%s" % p, p.replace('openssl-qoriq', 'openssl'))
21 d.appendVar("RCONFLICTS_%s" % p, p.replace('openssl-qoriq', 'openssl'))
22 d.appendVar("RREPLACES_%s" % p, p.replace('openssl-qoriq', 'openssl'))
23}
24
25SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/openssl;nobranch=1"
26
27S = "${WORKDIR}/git"
28
29PACKAGECONFIG[perl] = ",,,"
30
31TERMIO_libc-musl = "-DTERMIOS"
32TERMIO ?= "-DTERMIO"
33# Avoid binaries being marked as requiring an executable stack since it
34# doesn't(which causes and this causes issues with SELinux
35CFLAG = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
36 ${TERMIO} ${CFLAGS} -Wall -Wa,--noexecstack"
37
38export DIRS = "crypto ssl apps"
39export EX_LIBS = "-lgcc -ldl"
40export AS = "${CC} -c"
41
42inherit pkgconfig siteinfo multilib_header ptest relative_symlinks
43
44PACKAGES =+ "libcrypto libssl ${PN}-misc ${PN}-conf"
45FILES_libcrypto = "${libdir}/libcrypto${SOLIBS}"
46FILES_libssl = "${libdir}/libssl${SOLIBS}"
47FILES_${PN} =+ " ${libdir}/ssl/*"
48FILES_${PN}-misc = "${libdir}/ssl/misc"
49RDEPENDS_${PN}-misc = "${@bb.utils.filter('PACKAGECONFIG', 'perl', d)}"
50
51PROVIDES += "openssl10"
52
53# Add the openssl.cnf file to the openssl-conf package. Make the libcrypto
54# package RRECOMMENDS on this package. This will enable the configuration
55# file to be installed for both the base openssl package and the libcrypto
56# package since the base openssl package depends on the libcrypto package.
57FILES_${PN}-conf = "${sysconfdir}/ssl/openssl.cnf"
58CONFFILES_${PN}-conf = "${sysconfdir}/ssl/openssl.cnf"
59RRECOMMENDS_libcrypto += "${PN}-conf"
60RDEPENDS_${PN}-ptest += "${PN}-misc make perl perl-module-filehandle bc"
61
62# Remove this to enable SSLv3. SSLv3 is defaulted to disabled due to the POODLE
63# vulnerability
64EXTRA_OECONF = " -no-ssl3"
65
66do_configure_prepend_darwin () {
67 sed -i -e '/version-script=openssl\.ld/d' Configure
68}
69
70do_configure () {
71 cd util
72 perl perlpath.pl ${STAGING_BINDIR_NATIVE}
73 cd ..
74 ln -sf apps/openssl.pod crypto/crypto.pod ssl/ssl.pod doc/
75
76 os=${HOST_OS}
77 case $os in
78 linux-uclibc |\
79 linux-uclibceabi |\
80 linux-gnueabi |\
81 linux-uclibcspe |\
82 linux-gnuspe |\
83 linux-musl*)
84 os=linux
85 ;;
86 *)
87 ;;
88 esac
89 target="$os-${HOST_ARCH}"
90 case $target in
91 linux-arm)
92 target=linux-armv4
93 ;;
94 linux-armeb)
95 target=linux-elf-armeb
96 ;;
97 linux-aarch64*)
98 target=linux-aarch64
99 ;;
100 linux-sh3)
101 target=debian-sh3
102 ;;
103 linux-sh4)
104 target=debian-sh4
105 ;;
106 linux-i486)
107 target=debian-i386-i486
108 ;;
109 linux-i586 | linux-viac3)
110 target=debian-i386-i586
111 ;;
112 linux-i686)
113 target=debian-i386-i686/cmov
114 ;;
115 linux-gnux32-x86_64)
116 target=linux-x32
117 ;;
118 linux-gnu64-x86_64)
119 target=linux-x86_64
120 ;;
121 linux-gnun32-mips*el)
122 target=debian-mipsn32el
123 ;;
124 linux-gnun32-mips*)
125 target=debian-mipsn32
126 ;;
127 linux-mips*64*el)
128 target=debian-mips64el
129 ;;
130 linux-mips*64*)
131 target=debian-mips64
132 ;;
133 linux-mips*el)
134 target=debian-mipsel
135 ;;
136 linux-mips*)
137 target=debian-mips
138 ;;
139 linux-microblaze*|linux-nios2*)
140 target=linux-generic32
141 ;;
142 linux-powerpc)
143 target=linux-ppc
144 ;;
145 linux-powerpc64)
146 target=linux-ppc64
147 ;;
148 linux-supersparc)
149 target=linux-sparcv8
150 ;;
151 linux-sparc)
152 target=linux-sparcv8
153 ;;
154 darwin-i386)
155 target=darwin-i386-cc
156 ;;
157 esac
158 # inject machine-specific flags
159 sed -i -e "s|^\(\"$target\",\s*\"[^:]\+\):\([^:]\+\)|\1:${CFLAG}|g" Configure
160 useprefix=${prefix}
161 if [ "x$useprefix" = "x" ]; then
162 useprefix=/
163 fi
164 perl ./Configure ${EXTRA_OECONF} shared --prefix=$useprefix --openssldir=${libdir}/ssl --libdir=`basename ${libdir}` $target
165}
166
167do_compile_prepend_class-target () {
168 sed -i 's/\((OPENSSL=\)".*"/\1"openssl"/' Makefile
169}
170
171do_compile () {
172 oe_runmake depend
173 oe_runmake
174}
175
176do_compile_ptest () {
177 # build dependencies for test directory too
178 rm -rf test/ssltest_old
179 rm -rf test/x509aux
180 rm -rf test/v3ext
181 export DIRS="$DIRS test"
182 oe_runmake depend
183 oe_runmake buildtest
184}
185
186do_install () {
187 # Create ${D}/${prefix} to fix parallel issues
188 mkdir -p ${D}/${prefix}/
189
190 oe_runmake INSTALL_PREFIX="${D}" MANDIR="${mandir}" DESTDIR="${D}" install
191
192 oe_libinstall -so libcrypto ${D}${libdir}
193 oe_libinstall -so libssl ${D}${libdir}
194 oe_libinstall -so capi ${D}${libdir}
195 oe_libinstall -so padlock ${D}${libdir}
196
197 install -d ${D}${includedir}
198 cp --dereference -R include/openssl ${D}${includedir}
199
200 install -Dm 0755 ${WORKDIR}/openssl-c_rehash.sh ${D}${bindir}/c_rehash
201 sed -i -e 's,/etc/openssl,${sysconfdir}/ssl,g' ${D}${bindir}/c_rehash
202
203 oe_multilib_header openssl/opensslconf.h
204 if [ "${@bb.utils.filter('PACKAGECONFIG', 'perl', d)}" ]; then
205 sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${libdir}/ssl/misc/CA.pl
206 sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${libdir}/ssl/misc/tsget
207 else
208 rm -f ${D}${libdir}/ssl/misc/CA.pl ${D}${libdir}/ssl/misc/tsget
209 fi
210
211 # Create SSL structure
212 install -d ${D}${sysconfdir}/ssl/
213 mv ${D}${libdir}/ssl/openssl.cnf \
214 ${D}${libdir}/ssl/certs \
215 ${D}${libdir}/ssl/private \
216 \
217 ${D}${sysconfdir}/ssl/
218 ln -sf ${sysconfdir}/ssl/certs ${D}${libdir}/ssl/certs
219 ln -sf ${sysconfdir}/ssl/private ${D}${libdir}/ssl/private
220 ln -sf ${sysconfdir}/ssl/openssl.cnf ${D}${libdir}/ssl/openssl.cnf
221}
222
223do_install_ptest () {
224 # cp -r -L Makefile.org Makefile test ${D}${PTEST_PATH}
225 cp -r -L Makefile test ${D}${PTEST_PATH}
226
227 # Replace the path to native perl with the path to target perl
228 sed -i 's,^PERL=.*,PERL=${bindir}/perl,' ${D}${PTEST_PATH}/Makefile
229
230 cp Configure config e_os.h ${D}${PTEST_PATH}
231 cp -r -L include ${D}${PTEST_PATH}
232 ln -sf ${libdir}/libcrypto.a ${D}${PTEST_PATH}
233 ln -sf ${libdir}/libssl.a ${D}${PTEST_PATH}
234 mkdir -p ${D}${PTEST_PATH}/crypto
235 cp include/internal/constant_time_locl.h ${D}${PTEST_PATH}/crypto
236 cp -r demos/certs ${D}${PTEST_PATH}
237 mkdir -p ${D}${PTEST_PATH}/apps
238 ln -sf ${libdir}/ssl/misc/CA.sh ${D}${PTEST_PATH}/apps
239 ln -sf ${sysconfdir}/ssl/openssl.cnf ${D}${PTEST_PATH}/apps
240 ln -sf ${bindir}/openssl ${D}${PTEST_PATH}/apps
241 cp apps/server.pem ${D}${PTEST_PATH}/apps
242 cp apps/server2.pem ${D}${PTEST_PATH}/apps
243 mkdir -p ${D}${PTEST_PATH}/util
244 install util/opensslwrap.sh ${D}${PTEST_PATH}/util
245 install util/shlib_wrap.sh ${D}${PTEST_PATH}/util
246 # Time stamps are relevant for "make alltests", otherwise
247 # make may try to recompile binaries. Not only must the
248 # binary files be newer than the sources, they also must
249 # be more recent than the header files in /usr/include.
250 #
251 # Using "cp -a" is not sufficient, because do_install
252 # does not preserve the original time stamps.
253 #
254 # So instead of using the original file stamps, we set
255 # the current time for all files. Binaries will get
256 # modified again later when stripping them, but that's okay.
257 touch ${D}${PTEST_PATH}
258 find ${D}${PTEST_PATH} -type f -print0 | xargs --verbose -0 touch -r ${D}${PTEST_PATH}
259}
260
261do_install_append_class-native() {
262 create_wrapper ${D}${bindir}/openssl \
263 OPENSSL_CONF=${libdir}/ssl/openssl.cnf \
264 SSL_CERT_DIR=${libdir}/ssl/certs \
265 SSL_CERT_FILE=${libdir}/ssl/cert.pem \
266 OPENSSL_ENGINES=${libdir}/ssl/engines
267}