summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb')
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb
new file mode 100644
index 00000000..53a21814
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.1.0h.bb
@@ -0,0 +1,79 @@
1require openssl-qoriq_1.1.0h.inc
2
3DISABLE_STATIC = ""
4# For target side versions of openssl enable support for OCF Linux driver
5# if they are available.
6DEPENDS += "cryptodev-linux"
7
8CFLAGS += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=d57d511030c9d66ef5f5966bee5a7eff"
11
12SRC_URI[md5sum] = "5271477e4d93f4ea032b665ef095ff24"
13
14export DIRS = "crypto ssl apps engines"
15export OE_LDFLAGS="${LDFLAGS}"
16
17SRC_URI = " \
18 https://www.openssl.org/source/openssl-1.1.0h.tar.gz \
19 file://openssl-c_rehash.sh \
20 file://run-ptest \
21 file://perlpath.pl \
22 file://find.pl \
23 file://debian/pic.patch \
24 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
25 file://openssl-1.0.2a-x32-asm.patch \
26 "
27# file://0001-Fix-build-with-clang-using-external-assembler.patch \
28# file://Use-SHA256-not-MD5-as-default-digest.patch \
29# file://openssl-util-perlpath.pl-cwd.patch \
30# file://parallel.patch \
31# file://configure-musl-target.patch \
32# file://ptest_makefile_deps.patch \
33# file://ptest-deps.patch \
34# file://Makefiles-ptest.patch \
35# file://openssl-fix-des.pod-error.patch \
36# file://openssl_fix_for_x32.patch \
37# file://debian1.0.2/soname.patch \
38# file://debian1.0.2/version-script.patch \
39# file://debian/no-symbolic.patch \
40# file://debian/no-rpath.patch \
41# file://debian/man-dir.patch \
42# file://debian/man-section.patch \
43# file://debian/debian-targets.patch \
44# file://debian/c_rehash-compat.patch \
45# file://debian/ca.patch \
46# file://debian1.0.2/block_digicert_malaysia.patch \
47# file://debian1.0.2/block_diginotar.patch \
48# file://engines-install-in-libdir-ssl.patch \
49# file://oe-ldflags.patch \
50# file://shared-libs.patch \
51# file://configure-targets.patch
52#
53
54S = "${WORKDIR}/openssl-1.1.0h/"
55
56PACKAGES =+ "${PN}-engines"
57
58FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines ${libdir}/engines-1.1/*.so"
59
60# The crypto_use_bigint patch means that perl's bignum module needs to be
61# installed, but some distributions (for example Fedora 23) don't ship it by
62# default. As the resulting error is very misleading check for bignum before
63# building.
64do_configure_prepend() {
65 mkdir -p ${S}/util/
66 cp ${WORKDIR}/perlpath.pl ${S}/util/
67 cp ${WORKDIR}/find.pl ${S}/util/
68 if ! perl -Mbigint -e true; then
69 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
70 fi
71}
72
73do_compile_ptest_base() {
74 echo
75}
76
77TARGET_CC_ARCH += "${LDFLAGS}"
78
79COMPATIBLE_MACHINE = "(qoriq)"