summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@foundries.io>2023-05-02 18:34:39 +0300
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2023-05-02 15:56:41 +0000
commit528a49b0437acbcf61028a8c97747ae714ed3b55 (patch)
treebbf37ff404bf81cd17b0657f1d3320a1f664eaa0
parent91a9885b98de7dcb7de9551d7a5d5f1b9da651c8 (diff)
downloadmeta-freescale-backport-1519-to-mickledore.tar.gz
imx-atf: Update lf-5.15.71-2.2.0 to lf-6.1.1-1.0.0backport-1519-to-mickledore
Update to the tag used in NXP BSP release L6.1.1-1.0.0. Remove obsolete patches. Relevant changes: - 616a4588f Merge remote-tracking branch 'origin/imx_v2.6' into lf_v2.6 - c65bd415f LF-8459-02: fix(imx): add the missing copyright - 496be8f7d LF-8459-01 refine(imx8ulp): remove the unused header file - cd1902146 LF-8455 Add LICENSE.txt file into tf-a root dir - 2a68527c6 LF-8322 Add the SCR file - 04edb4bb4 Merge remote-tracking branch 'origin/imx_v2.6' into lf_v2.6 - 5ad0acb25 LF-8199 fix(imx93): make sure mub side clock enabled - 8a12537ed Merge remote-tracking branch 'origin/imx_v2.6' into lf_v2.6 - 7aad24ff5 LF-8091 fix(imx93): fix uart/gpio wakeup if clock gated - 3d95ac039 Merge remote-tracking branch 'origin/imx_v2.6' into lf_v2.6 - d3745ad70 LF-8090 imx93: TRDC: Fix wrong fuse bits for USB1 and eQOS disable - de873017a LF-7968-02 fix: Binutils 2.39 now warns when a segment has RXW permissions[1]: - b308ea0ee LF-7968-01 fix(Makefile): Suppress array-bounds error - 40aa23587 Merge remote-tracking branch 'origin/imx_v2.6' into lf_v2.6 - 0b2fe165c LF-7951 feat(imx8ulp): add a flag check for the ddr status - 983e91d73 LF-7950-02 feat(imx93): enable mu1_b general interrupt 1 - ffa707885 LF-7950-01 feat(imx93): force m33 into suspend mode if not enabled - bda471529 LF-7949 feat(imx93): add system pll power down support - 49c4e267a Merge remote-tracking branch 'origin/imx_v2.6' into lf_v2.6 - 46af4ffd6 LF-7858 feat(imx93): add ddr frequency scaling support on imx93 - 5234dfb98 LF-7820 feat(imx93): support kicking M33 from non 0xFFE0000 address - 7e221852d Merge remote-tracking branch 'origin/imx_v2.6' into lf_v2.6 - efabee40f Merge remote-tracking branch 'origin/imx_v2.6' into lf_v2.6 - 722741791 LF-7819 imx8ulp: Fix suspend/resume issue when DBD owner is s400 only - 18973b8fc LF-7814 imx93: Update TRDC driver to protect fused modules Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@foundries.io> (cherry picked from commit 2fb5cf54c552669f2c78266c292988e0499344db)
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch47
-rw-r--r--recipes-bsp/imx-atf/imx-atf/rwx-segments.patch38
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb10
3 files changed, 3 insertions, 92 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch b/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch
deleted file mode 100644
index c7ace225..00000000
--- a/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch
+++ /dev/null
@@ -1,47 +0,0 @@
1From 85f576054a4d5496706bbd37a520942f51cb74b9 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Mon, 16 May 2022 13:45:16 -0500
4Subject: [PATCH] Makefile: Suppress array-bounds error
5
6The array-bounds error is triggered now in cases where it was silent
7before, causing errors like:
8
9```
10plat/imx/imx8m/hab.c: In function 'imx_hab_handler':
11plat/imx/imx8m/hab.c:64:57: error: array subscript 0 is outside array bounds of 'uint32_t[0]' {aka 'unsigned int[]'} [-Werror=array-bounds]
12 64 | #define HAB_RVT_CHECK_TARGET_ARM64 ((unsigned long)*(uint32_t *)(HAB_RVT_BASE + 0x18))
13 | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
14```
15
16The error is a false-positive and is entered as a bug [1]. The problem
17is fixed partially in GCC 12 and fully in GCC 13 [2].
18
19The partial fix does not work here because the constant addresses used
20are less than the 4kB boundary chosen for the partial fix, so suppress
21the error until GCC is upgraded to 13.
22
23[1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99578
24[2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99578#c39
25
26Upstream-Status: Inappropriate [other]
27Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
28---
29 Makefile | 2 +-
30 1 file changed, 1 insertion(+), 1 deletion(-)
31
32diff --git a/Makefile b/Makefile
33index c87c3ae08..2d6b90f47 100644
34--- a/Makefile
35+++ b/Makefile
36@@ -346,7 +346,7 @@ WARNINGS += -Wshift-overflow -Wshift-sign-overflow \
37 endif
38
39 ifneq (${E},0)
40-ERRORS := -Werror
41+ERRORS := -Werror -Wno-error=array-bounds
42 endif
43
44 CPPFLAGS = ${DEFINES} ${INCLUDES} ${MBEDTLS_INC} -nostdinc \
45--
462.17.1
47
diff --git a/recipes-bsp/imx-atf/imx-atf/rwx-segments.patch b/recipes-bsp/imx-atf/imx-atf/rwx-segments.patch
deleted file mode 100644
index a4518ec6..00000000
--- a/recipes-bsp/imx-atf/imx-atf/rwx-segments.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1Binutils 2.39 now warns when a segment has RXW permissions[1]:
2
3aarch64-none-elf-ld.bfd: warning: bl31.elf has a LOAD segment with RWX
4permissions
5
6However, TF-A passes --fatal-warnings to LD, so this is a build failure.
7
8There is a ticket filed upstream[2], so until that is resolved just
9remove --fatal-warnings.
10
11[1] https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=ba951afb99912da01a6e8434126b8fac7aa75107
12[2] https://developer.trustedfirmware.org/T996
13
14Upstream-Status: Inappropriate
15Signed-off-by: Ross Burton <ross.burton@arm.com>
16
17diff --git a/Makefile b/Makefile
18index 3941f8698..13bbac348 100644
19--- a/Makefile
20+++ b/Makefile
21@@ -418,7 +418,7 @@ TF_LDFLAGS += $(TF_LDFLAGS_$(ARCH))
22 # LD = gcc (used when GCC LTO is enabled)
23 else ifneq ($(findstring gcc,$(notdir $(LD))),)
24 # Pass ld options with Wl or Xlinker switches
25-TF_LDFLAGS += -Wl,--fatal-warnings -O1
26+TF_LDFLAGS += -O1
27 TF_LDFLAGS += -Wl,--gc-sections
28 ifeq ($(ENABLE_LTO),1)
29 ifeq (${ARCH},aarch64)
30@@ -435,7 +435,7 @@ TF_LDFLAGS += $(subst --,-Xlinker --,$(TF_LDFLAGS_$(ARCH)))
31
32 # LD = gcc-ld (ld) or llvm-ld (ld.lld) or other
33 else
34-TF_LDFLAGS += --fatal-warnings -O1
35+TF_LDFLAGS += -O1
36 TF_LDFLAGS += --gc-sections
37 # ld.lld doesn't recognize the errata flags,
38 # therefore don't add those in that case
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index 33663a3a..ea83b9e8 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -7,13 +7,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;m
7 7
8PV .= "+git${SRCPV}" 8PV .= "+git${SRCPV}"
9 9
10SRC_URI = " \ 10SRC_URI = "git://github.com/nxp-imx/imx-atf.git;protocol=https;branch=${SRCBRANCH}"
11 git://github.com/nxp-imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
12 file://0001-Makefile-Suppress-array-bounds-error.patch \
13 file://rwx-segments.patch \
14"
15SRCBRANCH = "lf_v2.6" 11SRCBRANCH = "lf_v2.6"
16SRCREV = "3c1583ba0a5d11e5116332e91065cb3740153a46" 12SRCREV = "616a4588f333522d50a55bedd2b9a90a51474a75"
17 13
18S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
19 15
@@ -26,7 +22,7 @@ ATF_PLATFORM ??= "INVALID"
26ATF_BOOT_UART_BASE ?= "" 22ATF_BOOT_UART_BASE ?= ""
27 23
28EXTRA_OEMAKE += " \ 24EXTRA_OEMAKE += " \
29 CROSS_COMPILE="${TARGET_PREFIX}" \ 25 CROSS_COMPILE=${TARGET_PREFIX} \
30 PLAT=${ATF_PLATFORM} \ 26 PLAT=${ATF_PLATFORM} \
31" 27"
32 28