summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-atf/imx-atf/rwx-segments.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-atf/imx-atf/rwx-segments.patch')
-rw-r--r--recipes-bsp/imx-atf/imx-atf/rwx-segments.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/rwx-segments.patch b/recipes-bsp/imx-atf/imx-atf/rwx-segments.patch
deleted file mode 100644
index a4518ec6..00000000
--- a/recipes-bsp/imx-atf/imx-atf/rwx-segments.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1Binutils 2.39 now warns when a segment has RXW permissions[1]:
2
3aarch64-none-elf-ld.bfd: warning: bl31.elf has a LOAD segment with RWX
4permissions
5
6However, TF-A passes --fatal-warnings to LD, so this is a build failure.
7
8There is a ticket filed upstream[2], so until that is resolved just
9remove --fatal-warnings.
10
11[1] https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=ba951afb99912da01a6e8434126b8fac7aa75107
12[2] https://developer.trustedfirmware.org/T996
13
14Upstream-Status: Inappropriate
15Signed-off-by: Ross Burton <ross.burton@arm.com>
16
17diff --git a/Makefile b/Makefile
18index 3941f8698..13bbac348 100644
19--- a/Makefile
20+++ b/Makefile
21@@ -418,7 +418,7 @@ TF_LDFLAGS += $(TF_LDFLAGS_$(ARCH))
22 # LD = gcc (used when GCC LTO is enabled)
23 else ifneq ($(findstring gcc,$(notdir $(LD))),)
24 # Pass ld options with Wl or Xlinker switches
25-TF_LDFLAGS += -Wl,--fatal-warnings -O1
26+TF_LDFLAGS += -O1
27 TF_LDFLAGS += -Wl,--gc-sections
28 ifeq ($(ENABLE_LTO),1)
29 ifeq (${ARCH},aarch64)
30@@ -435,7 +435,7 @@ TF_LDFLAGS += $(subst --,-Xlinker --,$(TF_LDFLAGS_$(ARCH)))
31
32 # LD = gcc-ld (ld) or llvm-ld (ld.lld) or other
33 else
34-TF_LDFLAGS += --fatal-warnings -O1
35+TF_LDFLAGS += -O1
36 TF_LDFLAGS += --gc-sections
37 # ld.lld doesn't recognize the errata flags,
38 # therefore don't add those in that case