summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq_3.12.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_3.12.bbappend')
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bbappend b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
new file mode 100644
index 0000000..8f669ce
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
@@ -0,0 +1,21 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_t4240rdb-64b = " file://dts/t4240rdb-usdpaa-enea.dts"
4SRC_URI_append_p2041rdb = " file://dts/p2041rdb-usdpaa-enea.dts"
5SRC_URI_append_p3041ds = " file://dts/p3041ds-usdpaa-enea.dts"
6
7KERNEL_DEVICETREE_append_t4240rdb-64b = " t4240rdb-usdpaa-enea.dtb"
8KERNEL_DEVICETREE_append_p2041rdb = " p2041rdb-usdpaa-enea.dtb"
9KERNEL_DEVICETREE_append_p3041ds = " p3041ds-usdpaa-enea.dtb"
10
11do_configure_prepend_t4240rdb-64b() {
12 cp ${WORKDIR}/dts/t4240rdb-usdpaa-enea.dts ${S}/arch/powerpc/boot/dts/
13}
14
15do_configure_prepend_p2041rdb() {
16 cp ${WORKDIR}/dts/p2041rdb-usdpaa-enea.dts ${S}/arch/powerpc/boot/dts/
17}
18
19do_configure_prepend_p3041ds() {
20 cp ${WORKDIR}/dts/p3041ds-usdpaa-enea.dts ${S}/arch/powerpc/boot/dts/
21}