summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq_3.12.bbappend
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-04-04 14:58:03 +0200
committerMartin Borg <martin.borg@enea.com>2016-04-13 14:44:41 +0200
commit4a594335ceb78a69f46a2ca63f22b464d1a76cf5 (patch)
tree7308f06929790731f816b0c51f24b83fdcf0c3c9 /recipes-kernel/linux/linux-qoriq_3.12.bbappend
parentb9ca1a2a5f1dd0a19d9acef95621e5ae902a8b4f (diff)
downloadmeta-enea-networking-4a594335ceb78a69f46a2ca63f22b464d1a76cf5.tar.gz
linux-qoriq: Add device trees for USDPAA
For now we're adding new device trees for p2041rdb, p3041ds and t4240rdb. This was necessary to allow the usage of an ethernet interface as a normal one, that interfaces with the Linux kernel network stack. In the beginning all the interfaces were allocated to USDPAA, so they were not visible to the Linux kernel. For the development process this would mean the impossibility to boot using a nfs or to connect via ssh. Moved from meta-enea-bsp-ppc. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: Martin Borg <martin.borg@enea.com>
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_3.12.bbappend')
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bbappend b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
new file mode 100644
index 0000000..8f669ce
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
@@ -0,0 +1,21 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_t4240rdb-64b = " file://dts/t4240rdb-usdpaa-enea.dts"
4SRC_URI_append_p2041rdb = " file://dts/p2041rdb-usdpaa-enea.dts"
5SRC_URI_append_p3041ds = " file://dts/p3041ds-usdpaa-enea.dts"
6
7KERNEL_DEVICETREE_append_t4240rdb-64b = " t4240rdb-usdpaa-enea.dtb"
8KERNEL_DEVICETREE_append_p2041rdb = " p2041rdb-usdpaa-enea.dtb"
9KERNEL_DEVICETREE_append_p3041ds = " p3041ds-usdpaa-enea.dtb"
10
11do_configure_prepend_t4240rdb-64b() {
12 cp ${WORKDIR}/dts/t4240rdb-usdpaa-enea.dts ${S}/arch/powerpc/boot/dts/
13}
14
15do_configure_prepend_p2041rdb() {
16 cp ${WORKDIR}/dts/p2041rdb-usdpaa-enea.dts ${S}/arch/powerpc/boot/dts/
17}
18
19do_configure_prepend_p3041ds() {
20 cp ${WORKDIR}/dts/p3041ds-usdpaa-enea.dts ${S}/arch/powerpc/boot/dts/
21}