summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNora Björklund <nora.bjorklund@enea.com>2016-01-26 17:00:08 +0100
committerMartin Borg <martin.borg@enea.com>2016-02-04 12:47:33 +0100
commit2fbbd79d364274c9cf659c9fe919e460de7aaab0 (patch)
tree4729af702fb0cf60d217fe18cc9ec7b6acf56a25
parent6bb676e6e47b3cd36df5e498b7487044a3b41784 (diff)
downloadmeta-el-common-2fbbd79d364274c9cf659c9fe919e460de7aaab0.tar.gz
libuio: remove libuio
Remove libuio since an updated version exists in meta-oe which is a dependency to this layer. Also remove run-ptest since it is empty. Signed-off-by: Nora Björklund <nora.bjorklund@enea.com> Signed-off-by: Martin Borg <martin.borg@enea.com>
-rw-r--r--recipes-extended/libuio/libuio/run-ptest3
-rw-r--r--recipes-extended/libuio/libuio_git.bb31
2 files changed, 0 insertions, 34 deletions
diff --git a/recipes-extended/libuio/libuio/run-ptest b/recipes-extended/libuio/libuio/run-ptest
deleted file mode 100644
index 46c80b5..0000000
--- a/recipes-extended/libuio/libuio/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2echo "SKIP: no upstream test"
3
diff --git a/recipes-extended/libuio/libuio_git.bb b/recipes-extended/libuio/libuio_git.bb
deleted file mode 100644
index 216c678..0000000
--- a/recipes-extended/libuio/libuio_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "libUIO"
2DESCRIPTION = "Provide a generic framework for handling devices in userspace."
3HOMEPAGE = "https://www.osadl.org/UIO.uio.0.html"
4SECTION = "libs"
5LICENSE = "GPLv2"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SRCREV = "cc233857ba1613801e7218d07127d19608a99702"
10PR = "r0"
11PV = "1.0+git${SRCPV}"
12
13SRC_URI = "git://git.linutronix.de/projects/libUIO;protocol=git \
14 file://run-ptest"
15
16DEPENDS = "virtual/libc"
17
18S = "${WORKDIR}/git"
19
20inherit autotools
21
22do_configure_prepend () {
23 touch ${S}/ChangeLog
24}
25
26do_install_append () {
27 if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
28 mkdir -p ${D}${PTEST_PATH}
29 install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}
30 fi
31}