summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libuio/libuio_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/libuio/libuio_git.bb')
-rw-r--r--recipes-extended/libuio/libuio_git.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/recipes-extended/libuio/libuio_git.bb b/recipes-extended/libuio/libuio_git.bb
deleted file mode 100644
index 216c678..0000000
--- a/recipes-extended/libuio/libuio_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "libUIO"
2DESCRIPTION = "Provide a generic framework for handling devices in userspace."
3HOMEPAGE = "https://www.osadl.org/UIO.uio.0.html"
4SECTION = "libs"
5LICENSE = "GPLv2"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SRCREV = "cc233857ba1613801e7218d07127d19608a99702"
10PR = "r0"
11PV = "1.0+git${SRCPV}"
12
13SRC_URI = "git://git.linutronix.de/projects/libUIO;protocol=git \
14 file://run-ptest"
15
16DEPENDS = "virtual/libc"
17
18S = "${WORKDIR}/git"
19
20inherit autotools
21
22do_configure_prepend () {
23 touch ${S}/ChangeLog
24}
25
26do_install_append () {
27 if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
28 mkdir -p ${D}${PTEST_PATH}
29 install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}
30 fi
31}