summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Hao <kexin.hao@windriver.com>2018-04-08 20:23:06 +0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-09 12:14:52 -0700
commitbac5c4c1295e6d2c085b8814b5d265ee827d2f63 (patch)
treea498effdd3845eb489c8b6fda3078eb1d61d64be
parenta60454d2b3fe9ae1f68f1842c433195a53df3f9a (diff)
downloadmeta-dpdk-bac5c4c1295e6d2c085b8814b5d265ee827d2f63.tar.gz
dpdk: Refresh the patches for the context changes
Using the following commands to refresh the patches in order to suppress the fuzz warnings. devtool modify dpdk devtool finish --force-patch-refresh dpdk meta-dpdk-dir No code change. Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
-rw-r--r--recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch14
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch28
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch14
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch16
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch12
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch16
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch8
7 files changed, 47 insertions, 61 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch b/recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch
index cc8041e..2facd39 100644
--- a/recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch
+++ b/recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch
@@ -1,4 +1,4 @@
1From 3924f5df5aca5ba23abbe9a84173280ede8be2dd Mon Sep 17 00:00:00 2001 1From 41ac64efa5050430b73e0f8813dffc7327083273 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 1 Aug 2017 20:18:46 -0700 3Date: Tue, 1 Aug 2017 20:18:46 -0700
4Subject: [PATCH] examples: Fix maybe-uninitialized warning 4Subject: [PATCH] examples: Fix maybe-uninitialized warning
@@ -8,16 +8,17 @@ Initialize arrays to 0, makes compiler happy about
8error: 'vals[0]' may be used uninitialized in this function [-Werror=maybe-uninitialized] 8error: 'vals[0]' may be used uninitialized in this function [-Werror=maybe-uninitialized]
9 9
10Signed-off-by: Khem Raj <raj.khem@gmail.com> 10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11
11--- 12---
12 examples/qos_sched/args.c | 2 +- 13 examples/qos_sched/args.c | 2 +-
13 examples/vhost/virtio_net.c | 2 +- 14 examples/vhost/virtio_net.c | 2 +-
14 2 files changed, 2 insertions(+), 2 deletions(-) 15 2 files changed, 2 insertions(+), 2 deletions(-)
15 16
16diff --git a/examples/qos_sched/args.c b/examples/qos_sched/args.c 17diff --git a/examples/qos_sched/args.c b/examples/qos_sched/args.c
17index 476a0ee..fd601c3 100644 18index 83eee95cc28e..3d2c0fbd6d0a 100644
18--- a/examples/qos_sched/args.c 19--- a/examples/qos_sched/args.c
19+++ b/examples/qos_sched/args.c 20+++ b/examples/qos_sched/args.c
20@@ -241,7 +241,7 @@ static int 21@@ -212,7 +212,7 @@ static int
21 app_parse_flow_conf(const char *conf_str) 22 app_parse_flow_conf(const char *conf_str)
22 { 23 {
23 int ret; 24 int ret;
@@ -27,10 +28,10 @@ index 476a0ee..fd601c3 100644
27 uint64_t mask; 28 uint64_t mask;
28 29
29diff --git a/examples/vhost/virtio_net.c b/examples/vhost/virtio_net.c 30diff --git a/examples/vhost/virtio_net.c b/examples/vhost/virtio_net.c
30index cc2c3d8..16b5392 100644 31index f6e00674d9af..a4a90704d7b4 100644
31--- a/examples/vhost/virtio_net.c 32--- a/examples/vhost/virtio_net.c
32+++ b/examples/vhost/virtio_net.c 33+++ b/examples/vhost/virtio_net.c
33@@ -327,7 +327,7 @@ vs_dequeue_pkts(struct vhost_dev *dev, uint16_t queue_id, 34@@ -293,7 +293,7 @@ vs_dequeue_pkts(struct vhost_dev *dev, uint16_t queue_id,
34 { 35 {
35 struct vhost_queue *queue; 36 struct vhost_queue *queue;
36 struct rte_vhost_vring *vr; 37 struct rte_vhost_vring *vr;
@@ -39,6 +40,3 @@ index cc2c3d8..16b5392 100644
39 uint32_t used_idx; 40 uint32_t used_idx;
40 uint32_t i = 0; 41 uint32_t i = 0;
41 uint16_t free_entries; 42 uint16_t free_entries;
42--
432.13.3
44
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch b/recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch
index 8786af7..7828333 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch
@@ -1,4 +1,4 @@
1From 8cd0a16af531cca0af6b4f9b729c252b8bdbf8e2 Mon Sep 17 00:00:00 2001 1From e7df50cd214e30741a4594c1fb969baa7574c303 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Tue, 5 Jul 2016 00:05:25 +0800 3Date: Tue, 5 Jul 2016 00:05:25 +0800
4Subject: [PATCH] Fix for misleading indentation error 4Subject: [PATCH] Fix for misleading indentation error
@@ -7,18 +7,19 @@ fix the indentation of the code to match the block structure. This may cause
7build errors if you have -Wall -Werror in your project. 7build errors if you have -Wall -Werror in your project.
8 8
9Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 9Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
10
10--- 11---
11 lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c | 8 ++++---- 12 lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c | 8 ++++----
12 lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c | 2 +- 13 lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c | 2 +-
13 2 files changed, 5 insertions(+), 5 deletions(-) 14 2 files changed, 5 insertions(+), 5 deletions(-)
14 15
15diff --git a/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c b/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c 16diff --git a/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c b/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c
16index df22470..ba28eba 100644 17index 1934a309cda4..58ed65f062ae 100644
17--- a/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c 18--- a/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c
18+++ b/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c 19+++ b/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c
19@@ -3302,8 +3302,8 @@ s32 e1000_read_phy_reg_mphy(struct e1000_hw *hw, u32 address, u32 *data) 20@@ -3287,8 +3287,8 @@ s32 e1000_read_phy_reg_mphy(struct e1000_hw *hw, u32 address, u32 *data)
20 /* Disable access to mPHY if it was originally disabled */ 21 /* Disable access to mPHY if it was originally disabled */
21 if (locked) 22 if (locked) {
22 ready = e1000_is_mphy_ready(hw); 23 ready = e1000_is_mphy_ready(hw);
23- if (!ready) 24- if (!ready)
24- return -E1000_ERR_PHY; 25- return -E1000_ERR_PHY;
@@ -26,10 +27,10 @@ index df22470..ba28eba 100644
26+ return -E1000_ERR_PHY; 27+ return -E1000_ERR_PHY;
27 E1000_WRITE_REG(hw, E1000_MPHY_ADDR_CTRL, 28 E1000_WRITE_REG(hw, E1000_MPHY_ADDR_CTRL,
28 E1000_MPHY_DIS_ACCESS); 29 E1000_MPHY_DIS_ACCESS);
29 30 }
30@@ -3367,8 +3367,8 @@ s32 e1000_write_phy_reg_mphy(struct e1000_hw *hw, u32 address, u32 data, 31@@ -3353,8 +3353,8 @@ s32 e1000_write_phy_reg_mphy(struct e1000_hw *hw, u32 address, u32 data,
31 /* Disable access to mPHY if it was originally disabled */ 32 /* Disable access to mPHY if it was originally disabled */
32 if (locked) 33 if (locked) {
33 ready = e1000_is_mphy_ready(hw); 34 ready = e1000_is_mphy_ready(hw);
34- if (!ready) 35- if (!ready)
35- return -E1000_ERR_PHY; 36- return -E1000_ERR_PHY;
@@ -37,20 +38,17 @@ index df22470..ba28eba 100644
37+ return -E1000_ERR_PHY; 38+ return -E1000_ERR_PHY;
38 E1000_WRITE_REG(hw, E1000_MPHY_ADDR_CTRL, 39 E1000_WRITE_REG(hw, E1000_MPHY_ADDR_CTRL,
39 E1000_MPHY_DIS_ACCESS); 40 E1000_MPHY_DIS_ACCESS);
40 41 }
41diff --git a/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c b/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c 42diff --git a/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c b/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c
42index 017dfe1..7248a7e 100644 43index 3f15912307ce..90635fc60520 100644
43--- a/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c 44--- a/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c
44+++ b/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c 45+++ b/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c
45@@ -870,7 +870,7 @@ s32 ixgbe_setup_mac_link_82599(struct ixgbe_hw *hw, 46@@ -855,7 +855,7 @@ s32 ixgbe_setup_mac_link_82599(struct ixgbe_hw *hw,
46 if (speed & IXGBE_LINK_SPEED_10GB_FULL) 47 if (speed & IXGBE_LINK_SPEED_10GB_FULL) {
47 if (orig_autoc & IXGBE_AUTOC_KX4_SUPP) 48 if (orig_autoc & IXGBE_AUTOC_KX4_SUPP)
48 autoc |= IXGBE_AUTOC_KX4_SUPP; 49 autoc |= IXGBE_AUTOC_KX4_SUPP;
49- if ((orig_autoc & IXGBE_AUTOC_KR_SUPP) && 50- if ((orig_autoc & IXGBE_AUTOC_KR_SUPP) &&
50+ if ((orig_autoc & IXGBE_AUTOC_KR_SUPP) && 51+ if ((orig_autoc & IXGBE_AUTOC_KR_SUPP) &&
51 (hw->phy.smart_speed_active == false)) 52 (hw->phy.smart_speed_active == false))
52 autoc |= IXGBE_AUTOC_KR_SUPP; 53 autoc |= IXGBE_AUTOC_KR_SUPP;
53 if (speed & IXGBE_LINK_SPEED_1GB_FULL) 54 }
54--
551.9.1
56
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch b/recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch
index e446ce4..603bd32 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch
@@ -1,4 +1,4 @@
1From 6c8d348190a8cf6c35111913cbf117ca98137e84 Mon Sep 17 00:00:00 2001 1From 0808b30cd00f307f182007d21a8be3a0866ccf83 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 18 Dec 2015 18:30:47 +0800 3Date: Fri, 18 Dec 2015 18:30:47 +0800
4Subject: [PATCH] dpdk v2.2.0: add RTE_KERNELDIR_OUT to split kernel build 4Subject: [PATCH] dpdk v2.2.0: add RTE_KERNELDIR_OUT to split kernel build
@@ -12,15 +12,16 @@ separate directories for kernel source and kernel artifacts.
12Upstream-Status: Inappropriate [configuration] 12Upstream-Status: Inappropriate [configuration]
13 13
14Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 14Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
15
15--- 16---
16 mk/rte.module.mk | 6 +++--- 17 mk/rte.module.mk | 6 +++---
17 1 file changed, 3 insertions(+), 3 deletions(-) 18 1 file changed, 3 insertions(+), 3 deletions(-)
18 19
19diff --git a/mk/rte.module.mk b/mk/rte.module.mk 20diff --git a/mk/rte.module.mk b/mk/rte.module.mk
20index 53ed4fe..b7a014b 100644 21index 1ada528a00b1..da0538cd5321 100644
21--- a/mk/rte.module.mk 22--- a/mk/rte.module.mk
22+++ b/mk/rte.module.mk 23+++ b/mk/rte.module.mk
23@@ -77,7 +77,7 @@ build: _postbuild 24@@ -48,7 +48,7 @@ build: _postbuild
24 # build module 25 # build module
25 $(MODULE).ko: $(SRCS_LINKS) 26 $(MODULE).ko: $(SRCS_LINKS)
26 @if [ ! -f $(notdir Makefile) ]; then ln -nfs $(SRCDIR)/Makefile . ; fi 27 @if [ ! -f $(notdir Makefile) ]; then ln -nfs $(SRCDIR)/Makefile . ; fi
@@ -29,7 +30,7 @@ index 53ed4fe..b7a014b 100644
29 CC="$(KERNELCC)" CROSS_COMPILE=$(CROSS) V=$(if $V,1,0) 30 CC="$(KERNELCC)" CROSS_COMPILE=$(CROSS) V=$(if $V,1,0)
30 31
31 # install module in $(RTE_OUTPUT)/kmod 32 # install module in $(RTE_OUTPUT)/kmod
32@@ -88,7 +88,7 @@ $(RTE_OUTPUT)/kmod/$(MODULE).ko: $(MODULE).ko 33@@ -59,7 +59,7 @@ $(RTE_OUTPUT)/kmod/$(MODULE).ko: $(MODULE).ko
33 34
34 # install module 35 # install module
35 modules_install: 36 modules_install:
@@ -38,7 +39,7 @@ index 53ed4fe..b7a014b 100644
38 modules_install 39 modules_install
39 40
40 .PHONY: clean 41 .PHONY: clean
41@@ -98,7 +98,7 @@ clean: _postclean 42@@ -69,7 +69,7 @@ clean: _postclean
42 .PHONY: doclean 43 .PHONY: doclean
43 doclean: 44 doclean:
44 @if [ ! -f $(notdir Makefile) ]; then ln -nfs $(SRCDIR)/Makefile . ; fi 45 @if [ ! -f $(notdir Makefile) ]; then ln -nfs $(SRCDIR)/Makefile . ; fi
@@ -47,6 +48,3 @@ index 53ed4fe..b7a014b 100644
47 @$(foreach FILE,$(SRCS-y) $(SRCS-n) $(SRCS-),\ 48 @$(foreach FILE,$(SRCS-y) $(SRCS-n) $(SRCS-),\
48 if [ -h $(notdir $(FILE)) ]; then rm -f $(notdir $(FILE)) ; fi ;) 49 if [ -h $(notdir $(FILE)) ]; then rm -f $(notdir $(FILE)) ; fi ;)
49 @if [ -h $(notdir Makefile) ]; then rm -f $(notdir Makefile) ; fi 50 @if [ -h $(notdir Makefile) ]; then rm -f $(notdir Makefile) ; fi
50--
511.9.1
52
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch b/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch
index 3719aa7..7a8b035 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch
@@ -1,4 +1,4 @@
1From f7be643cc62860a986c9e0aec990c90bfc58a941 Mon Sep 17 00:00:00 2001 1From 916378ef5ae45e63d12cc5235b2b59f90514ba25 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 1 Apr 2016 17:31:55 +0800 3Date: Fri, 1 Apr 2016 17:31:55 +0800
4Subject: [PATCH] dpdk: enable ip_fragmentation in common_base config 4Subject: [PATCH] dpdk: enable ip_fragmentation in common_base config
@@ -8,26 +8,24 @@ Upstream-Status: Inappropriate [Configuration]
8This configuration need to set for ip_fragmentation application. 8This configuration need to set for ip_fragmentation application.
9 9
10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
11
11--- 12---
12 config/common_base | 5 +++++ 13 config/common_base | 5 +++++
13 1 file changed, 5 insertions(+) 14 1 file changed, 5 insertions(+)
14 15
15diff --git a/config/common_base b/config/common_base 16diff --git a/config/common_base b/config/common_base
16index abd6a64..90259f0 100644 17index ad03cf43392f..ba5794d6c402 100644
17--- a/config/common_base 18--- a/config/common_base
18+++ b/config/common_base 19+++ b/config/common_base
19@@ -442,6 +442,11 @@ CONFIG_RTE_LIBRTE_POWER_DEBUG=n 20@@ -691,6 +691,11 @@ CONFIG_RTE_LIBRTE_POWER=n
21 CONFIG_RTE_LIBRTE_POWER_DEBUG=n
20 CONFIG_RTE_MAX_LCORE_FREQS=64 22 CONFIG_RTE_MAX_LCORE_FREQS=64
21 23
22 # 24+#
23+# Compile ip_fragmentation 25+# Compile ip_fragmentation
24+# 26+#
25+CONFIG_RTE_IP_FRAG=y 27+CONFIG_RTE_IP_FRAG=y
26+ 28+
27+# 29 #
28 # Compile librte_net 30 # Compile librte_net
29 # 31 #
30 CONFIG_RTE_LIBRTE_NET=y
31--
321.9.1
33
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
index a4c4711..18b761c 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
@@ -1,4 +1,4 @@
1From a33a9e7559b59bc5fb0988af85062436ec4389a4 Mon Sep 17 00:00:00 2001 1From d08d11c8b6fdfe73884d67a94d907000afd136ed Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 19 Aug 2016 11:57:49 +0800 3Date: Fri, 19 Aug 2016 11:57:49 +0800
4Subject: [PATCH] dpdk: add --sysroot option within app makefile 4Subject: [PATCH] dpdk: add --sysroot option within app makefile
@@ -10,23 +10,21 @@ under EXTRA_LDFLAGS. It causes --sysroot=<path> to not setup
10correctly when we depends on gcc to setup for GNU ld. 10correctly when we depends on gcc to setup for GNU ld.
11 11
12Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 12Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
13
13--- 14---
14 mk/rte.app.mk | 2 +- 15 mk/rte.app.mk | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-) 16 1 file changed, 1 insertion(+), 1 deletion(-)
16 17
17diff --git a/mk/rte.app.mk b/mk/rte.app.mk 18diff --git a/mk/rte.app.mk b/mk/rte.app.mk
18index eb28e11..296c8c7 100644 19index 3eb41d176d21..9ab6688718db 100644
19--- a/mk/rte.app.mk 20--- a/mk/rte.app.mk
20+++ b/mk/rte.app.mk 21+++ b/mk/rte.app.mk
21@@ -195,7 +195,7 @@ exe2cmd = $(strip $(call dotfile,$(patsubst %,%.cmd,$(1)))) 22@@ -300,7 +300,7 @@ exe2cmd = $(strip $(call dotfile,$(patsubst %,%.cmd,$(1))))
22 ifeq ($(LINK_USING_CC),1) 23 ifeq ($(LINK_USING_CC),1)
23 O_TO_EXE = $(CC) -o $@ $(CFLAGS) $(OBJS-y) $(call linkerprefix, \ 24 O_TO_EXE = $(CC) -o $@ $(CFLAGS) $(EXTRA_CFLAGS) $(OBJS-y) $(call linkerprefix, \
24 $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \ 25 $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
25- $(MAPFLAGS)) 26- $(MAPFLAGS))
26+ $(MAPFLAGS)) $(SYSROOTPATH) 27+ $(MAPFLAGS)) $(SYSROOTPATH)
27 else 28 else
28 O_TO_EXE = $(LD) -o $@ $(OBJS-y) \ 29 O_TO_EXE = $(LD) -o $@ $(OBJS-y) \
29 $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \ 30 $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
30--
311.9.1
32
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
index fc965fa..55f0c15 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
@@ -1,4 +1,4 @@
1From 4cdcb5ea4af9677677a007c4f9b286948123be87 Mon Sep 17 00:00:00 2001 1From 4a86048d44cae812b227b857772aeeb839502706 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 2 Sep 2016 15:48:52 +0800 3Date: Fri, 2 Sep 2016 15:48:52 +0800
4Subject: [PATCH] dpdk: fix for parellel make issue 4Subject: [PATCH] dpdk: fix for parellel make issue
@@ -8,28 +8,29 @@ libraries will be build before, And available at the time of
8linking example apps. 8linking example apps.
9 9
10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
11
11--- 12---
12 examples/Makefile | 1 + 13 examples/Makefile | 1 +
13 examples/ethtool/ethtool-app/Makefile | 1 + 14 examples/ethtool/ethtool-app/Makefile | 1 +
14 2 files changed, 2 insertions(+) 15 2 files changed, 2 insertions(+)
15 16
16diff --git a/examples/Makefile b/examples/Makefile 17diff --git a/examples/Makefile b/examples/Makefile
17index 18b41b9..c7c2beb 100644 18index 17ecf7f64cda..2a8e805b85a7 100644
18--- a/examples/Makefile 19--- a/examples/Makefile
19+++ b/examples/Makefile 20+++ b/examples/Makefile
20@@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor 21@@ -41,6 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_BBDEV) += bbdev_app
21 DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond 22 DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
22 DIRS-y += cmdline 23 DIRS-y += cmdline
23 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor 24 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
24+DEPDIRS-y += examples/ethtool/lib 25+DEPDIRS-y += examples/ethtool/lib
25 DIRS-y += ethtool 26 DIRS-y += ethtool
26 DIRS-y += exception_path 27 DIRS-y += exception_path
27 DIRS-y += helloworld 28 DIRS-$(CONFIG_RTE_LIBRTE_EFD) += server_node_efd
28diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile 29diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile
29index 09c66ad..ec068e6 100644 30index 4cd9efdd574b..d3c709ab2fef 100644
30--- a/examples/ethtool/ethtool-app/Makefile 31--- a/examples/ethtool/ethtool-app/Makefile
31+++ b/examples/ethtool/ethtool-app/Makefile 32+++ b/examples/ethtool/ethtool-app/Makefile
32@@ -47,6 +47,7 @@ SRCS-y := main.c ethapp.c 33@@ -19,6 +19,7 @@ SRCS-y := main.c ethapp.c
33 CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib 34 CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib
34 CFLAGS += $(WERROR_FLAGS) 35 CFLAGS += $(WERROR_FLAGS)
35 36
@@ -37,6 +38,3 @@ index 09c66ad..ec068e6 100644
37 LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib 38 LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
38 LDLIBS += -lrte_ethtool 39 LDLIBS += -lrte_ethtool
39 40
40--
411.9.1
42
diff --git a/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch
index f517167..0505888 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch
@@ -1,4 +1,4 @@
1From 363817bf84286fc167e0c3c255a7fd522bf87d8c Mon Sep 17 00:00:00 2001 1From 0be350c3b04d83ea9182f45936ef3219aed5c0c1 Mon Sep 17 00:00:00 2001
2From: Shashwat Pandey <shashwatx.p@intel.com> 2From: Shashwat Pandey <shashwatx.p@intel.com>
3Date: Mon, 20 Feb 2017 15:46:22 +0800 3Date: Mon, 20 Feb 2017 15:46:22 +0800
4Subject: [PATCH] dpdk: fix installation warning and issue 4Subject: [PATCH] dpdk: fix installation warning and issue
@@ -12,12 +12,13 @@ Added excluded files from bin and removing mk and app/dpdk-pmdinfogen files
12installation since it is not needed as a part of image. 12installation since it is not needed as a part of image.
13 13
14Signed-off-by: Shashwat Pandey <shashwatx.p@intel.com> 14Signed-off-by: Shashwat Pandey <shashwatx.p@intel.com>
15
15--- 16---
16 mk/rte.sdkinstall.mk | 29 ++++++++++++++--------------- 17 mk/rte.sdkinstall.mk | 29 ++++++++++++++---------------
17 1 file changed, 14 insertions(+), 15 deletions(-) 18 1 file changed, 14 insertions(+), 15 deletions(-)
18 19
19diff --git a/mk/rte.sdkinstall.mk b/mk/rte.sdkinstall.mk 20diff --git a/mk/rte.sdkinstall.mk b/mk/rte.sdkinstall.mk
20index dbac2a2..563954e 100644 21index 4e97feff9fde..42625333a4e2 100644
21--- a/mk/rte.sdkinstall.mk 22--- a/mk/rte.sdkinstall.mk
22+++ b/mk/rte.sdkinstall.mk 23+++ b/mk/rte.sdkinstall.mk
23@@ -115,16 +115,17 @@ endif 24@@ -115,16 +115,17 @@ endif
@@ -76,6 +77,3 @@ index dbac2a2..563954e 100644
76 $(Q)$(call rte_mkdir, $(DESTDIR)$(datadir)) 77 $(Q)$(call rte_mkdir, $(DESTDIR)$(datadir))
77- $(Q)cp -a $(RTE_SDK)/examples $(DESTDIR)$(datadir) 78- $(Q)cp -a $(RTE_SDK)/examples $(DESTDIR)$(datadir)
78+ $(Q)cp -r $(RTE_SDK)/examples $(DESTDIR)$(datadir) 79+ $(Q)cp -r $(RTE_SDK)/examples $(DESTDIR)$(datadir)
79--
801.9.1
81