summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch')
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch16
1 files changed, 7 insertions, 9 deletions
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
index fc965fa..55f0c15 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
@@ -1,4 +1,4 @@
1From 4cdcb5ea4af9677677a007c4f9b286948123be87 Mon Sep 17 00:00:00 2001 1From 4a86048d44cae812b227b857772aeeb839502706 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 2 Sep 2016 15:48:52 +0800 3Date: Fri, 2 Sep 2016 15:48:52 +0800
4Subject: [PATCH] dpdk: fix for parellel make issue 4Subject: [PATCH] dpdk: fix for parellel make issue
@@ -8,28 +8,29 @@ libraries will be build before, And available at the time of
8linking example apps. 8linking example apps.
9 9
10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> 10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
11
11--- 12---
12 examples/Makefile | 1 + 13 examples/Makefile | 1 +
13 examples/ethtool/ethtool-app/Makefile | 1 + 14 examples/ethtool/ethtool-app/Makefile | 1 +
14 2 files changed, 2 insertions(+) 15 2 files changed, 2 insertions(+)
15 16
16diff --git a/examples/Makefile b/examples/Makefile 17diff --git a/examples/Makefile b/examples/Makefile
17index 18b41b9..c7c2beb 100644 18index 17ecf7f64cda..2a8e805b85a7 100644
18--- a/examples/Makefile 19--- a/examples/Makefile
19+++ b/examples/Makefile 20+++ b/examples/Makefile
20@@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor 21@@ -41,6 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_BBDEV) += bbdev_app
21 DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond 22 DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
22 DIRS-y += cmdline 23 DIRS-y += cmdline
23 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor 24 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
24+DEPDIRS-y += examples/ethtool/lib 25+DEPDIRS-y += examples/ethtool/lib
25 DIRS-y += ethtool 26 DIRS-y += ethtool
26 DIRS-y += exception_path 27 DIRS-y += exception_path
27 DIRS-y += helloworld 28 DIRS-$(CONFIG_RTE_LIBRTE_EFD) += server_node_efd
28diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile 29diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile
29index 09c66ad..ec068e6 100644 30index 4cd9efdd574b..d3c709ab2fef 100644
30--- a/examples/ethtool/ethtool-app/Makefile 31--- a/examples/ethtool/ethtool-app/Makefile
31+++ b/examples/ethtool/ethtool-app/Makefile 32+++ b/examples/ethtool/ethtool-app/Makefile
32@@ -47,6 +47,7 @@ SRCS-y := main.c ethapp.c 33@@ -19,6 +19,7 @@ SRCS-y := main.c ethapp.c
33 CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib 34 CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib
34 CFLAGS += $(WERROR_FLAGS) 35 CFLAGS += $(WERROR_FLAGS)
35 36
@@ -37,6 +38,3 @@ index 09c66ad..ec068e6 100644
37 LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib 38 LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
38 LDLIBS += -lrte_ethtool 39 LDLIBS += -lrte_ethtool
39 40
40--
411.9.1
42