summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-arrow.inc15
-rw-r--r--meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb17
-rw-r--r--meta-openstack/recipes-devtools/python/python3-arrow_0.15.2.bb2
3 files changed, 19 insertions, 15 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-arrow.inc b/meta-openstack/recipes-devtools/python/python-arrow.inc
new file mode 100644
index 0000000..9556a6d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-arrow.inc
@@ -0,0 +1,15 @@
1DESCRIPTION = "Better dates and times for Python"
2HOMEPAGE = "https://github.com/crsmithdev/arrow"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=458d41a4064e4dc109666cfd941a29e4"
6
7SRC_URI[md5sum] = "554f18b0e23182ee0e8cb2a882d2f607"
8SRC_URI[sha256sum] = "10257c5daba1a88db34afa284823382f4963feca7733b9107956bed041aff24f"
9
10inherit pypi
11
12RDEPENDS_${PN} += " \
13 ${PYTHON_PN}-dateutil \
14 ${PYTHON_PN}-backports-functools-lru-cache \
15 "
diff --git a/meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb b/meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb
index d2d0616..e5deaad 100644
--- a/meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb
@@ -1,15 +1,2 @@
1DESCRIPTION = "Better dates and times for Python" 1require python-arrow.inc
2HOMEPAGE = "https://github.com/crsmithdev/arrow" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=458d41a4064e4dc109666cfd941a29e4"
6
7SRC_URI[md5sum] = "554f18b0e23182ee0e8cb2a882d2f607"
8SRC_URI[sha256sum] = "10257c5daba1a88db34afa284823382f4963feca7733b9107956bed041aff24f"
9
10inherit setuptools pypi
11
12RDEPENDS_${PN} += " \
13 python-dateutil \
14 python-backports-functools-lru-cache \
15 "
diff --git a/meta-openstack/recipes-devtools/python/python3-arrow_0.15.2.bb b/meta-openstack/recipes-devtools/python/python3-arrow_0.15.2.bb
new file mode 100644
index 0000000..99196ea
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-arrow_0.15.2.bb
@@ -0,0 +1,2 @@
1require python-arrow.inc
2inherit setuptools3