summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-06 11:15:00 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-08 16:24:33 -0500
commit204ffae30734169efb5da4520d9540e84e9a819f (patch)
treea6ed29313a365f50ee32b9ccbff1c49f58fd999c
parent9f20e83d6cb2c0937e62d5971e7e4d3586c700e9 (diff)
downloadmeta-cloud-services-204ffae30734169efb5da4520d9540e84e9a819f.tar.gz
python-arrow: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-arrow.inc15
-rw-r--r--meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb17
-rw-r--r--meta-openstack/recipes-devtools/python/python3-arrow_0.15.2.bb2
3 files changed, 19 insertions, 15 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-arrow.inc b/meta-openstack/recipes-devtools/python/python-arrow.inc
new file mode 100644
index 0000000..9556a6d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-arrow.inc
@@ -0,0 +1,15 @@
1DESCRIPTION = "Better dates and times for Python"
2HOMEPAGE = "https://github.com/crsmithdev/arrow"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=458d41a4064e4dc109666cfd941a29e4"
6
7SRC_URI[md5sum] = "554f18b0e23182ee0e8cb2a882d2f607"
8SRC_URI[sha256sum] = "10257c5daba1a88db34afa284823382f4963feca7733b9107956bed041aff24f"
9
10inherit pypi
11
12RDEPENDS_${PN} += " \
13 ${PYTHON_PN}-dateutil \
14 ${PYTHON_PN}-backports-functools-lru-cache \
15 "
diff --git a/meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb b/meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb
index d2d0616..e5deaad 100644
--- a/meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-arrow_0.15.2.bb
@@ -1,15 +1,2 @@
1DESCRIPTION = "Better dates and times for Python" 1require python-arrow.inc
2HOMEPAGE = "https://github.com/crsmithdev/arrow" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=458d41a4064e4dc109666cfd941a29e4"
6
7SRC_URI[md5sum] = "554f18b0e23182ee0e8cb2a882d2f607"
8SRC_URI[sha256sum] = "10257c5daba1a88db34afa284823382f4963feca7733b9107956bed041aff24f"
9
10inherit setuptools pypi
11
12RDEPENDS_${PN} += " \
13 python-dateutil \
14 python-backports-functools-lru-cache \
15 "
diff --git a/meta-openstack/recipes-devtools/python/python3-arrow_0.15.2.bb b/meta-openstack/recipes-devtools/python/python3-arrow_0.15.2.bb
new file mode 100644
index 0000000..99196ea
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-arrow_0.15.2.bb
@@ -0,0 +1,2 @@
1require python-arrow.inc
2inherit setuptools3