summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2017-07-26 08:42:08 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-07-26 10:07:52 -0400
commit4e05423f1542403651fe3e4623693aac857642bb (patch)
tree0cac68f1dfb6d45412e66ac66c8f89c8eb3eb5d5 /recipes-extended
parentab865e747303a1d62fa69fca66ca0c33e6657dd5 (diff)
downloadmeta-cloud-services-4e05423f1542403651fe3e4623693aac857642bb.tar.gz
librdmacm: add new recipe
User space RDMA 'socket' protocol and libraries for establising RDMA communication. Includes both Infiniband specific and general RDMA communication management libraries for unreliable datagram, reliable connected, and multicast data transfers. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/librdmacm/files/librdmacm-needs-libdl.patch21
-rw-r--r--recipes-extended/librdmacm/librdmacm_1.0.17.bb41
2 files changed, 62 insertions, 0 deletions
diff --git a/recipes-extended/librdmacm/files/librdmacm-needs-libdl.patch b/recipes-extended/librdmacm/files/librdmacm-needs-libdl.patch
new file mode 100644
index 0000000..bf15bea
--- /dev/null
+++ b/recipes-extended/librdmacm/files/librdmacm-needs-libdl.patch
@@ -0,0 +1,21 @@
1Librdmacm links against libibverbs, and the current version of libibverbs
2uses dlopen(), so librdmacm must also link against libdl.
3
4Upstream-Status: Pending
5
6Signed-off-by: Donn Seeley <donn.seeley@windriver.com>
7---
8 configure.in | 2 ++
9 1 file changed, 2 insertions(+)
10
11--- a/configure.in
12+++ b/configure.in
13@@ -39,6 +39,8 @@ AC_CHECK_SIZEOF(long)
14 dnl Checks for libraries
15 AC_CHECK_LIB(pthread, pthread_mutex_init, [],
16 AC_MSG_ERROR([pthread_mutex_init() not found. librdmacm requires libpthread.]))
17+AC_CHECK_LIB(dl, dlsym, [],
18+ AC_MSG_ERROR([dlsym() not found. librdmacm requires libdl.]))
19 if test "$disable_libcheck" != "yes"; then
20 AC_CHECK_LIB(ibverbs, ibv_get_device_list, [],
21 AC_MSG_ERROR([ibv_get_device_list() not found. librdmacm requires libibverbs.]))
diff --git a/recipes-extended/librdmacm/librdmacm_1.0.17.bb b/recipes-extended/librdmacm/librdmacm_1.0.17.bb
new file mode 100644
index 0000000..ba022b0
--- /dev/null
+++ b/recipes-extended/librdmacm/librdmacm_1.0.17.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Userspace RDMA Connection Manager"
2DESCRIPTION = "\
3User space RDMA 'socket' protocol and libraries for establising RDMA\
4communication. Includes both Infiniband specific and general RDMA\
5communication management libraries for unreliable datagram, reliable\
6connected, and multicast data transfers.\
7Also includes ACM (communication management assistant) service."
8
9HOMEPAGE = "http://www.openfabrics.org/downloads/rdmacm/"
10SECTION = "libs/devel"
11
12LICENSE = "BSD"
13LIC_FILES_CHKSUM = "file://COPYING;md5=39cc3044d68741f9005da73e9b92db95"
14
15DEPENDS = "libibverbs"
16
17# Repo is at http://git.openfabrics.org/git?p=~shefty/librdmacm.git
18SRC_URI = "http://www.openfabrics.org/downloads/rdmacm/${BPN}-${PV}.tar.gz \
19 file://librdmacm-needs-libdl.patch"
20
21SRC_URI[md5sum] = "da6fad887e9c24cb01b74b75f8449cb1"
22SRC_URI[sha256sum] = "9381e1bf2c7079fc257b8eee74e731d3e7eec70e539bb4245084a7b05aeecb2a"
23
24inherit autotools
25
26# Allow plug-in symlinks.
27INSANE_SKIP_${PN} += "dev-so"
28
29PACKAGES += "${PN}-utils"
30FILES_${PN} = "${libdir}/*.so.* ${libdir}/rsocket/*.so*"
31FILES_${PN}-utils = "${bindir}"
32FILES_${PN}-staticdev += "${libdir}/rsocket/librspreload.a"
33FILES_${PN}-dbg += "${libdir}/rsocket/.debug"
34
35PACKAGECONFIG ??= ""
36PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind,"
37
38do_install_append() {
39 rm -f ${D}${libdir}/librdmacm.la
40 rm -f ${D}${libdir}/rsocket/librspreload.la
41}