summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2017-07-26 08:42:07 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-07-26 10:07:52 -0400
commitab865e747303a1d62fa69fca66ca0c33e6657dd5 (patch)
tree67a8b8b2f057bdf13ffdad0643ec9e6005ffd6d3 /recipes-extended
parent955d8a234e748abe538dedd1602f3e4adfd30ff5 (diff)
downloadmeta-cloud-services-ab865e747303a1d62fa69fca66ca0c33e6657dd5.tar.gz
libibverbs: add new recpie
Libibverbs is a library that allows userspace processes to use InfiniBand/RDMA 'verbs' directly. libibverbs is now part of rdma-core and the standalone libibverbs project has been deprecated. Rough testing shows that we can move to use rdma-core however we have yet to perform extensive testing with this change. We therefor will continue to use the standalone libibverbs at this point in time. This is also inline with the upstream glusterfs project that still lists libibverbs as a dependency. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/libibverbs/libibverbs_1.1.7.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-extended/libibverbs/libibverbs_1.1.7.bb b/recipes-extended/libibverbs/libibverbs_1.1.7.bb
new file mode 100644
index 0000000..e75f90d
--- /dev/null
+++ b/recipes-extended/libibverbs/libibverbs_1.1.7.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Support InfiniBand verbs"
2DESCRIPTION = "Libibverbs is a library that allows userspace processes to use InfiniBand/RDMA 'verbs' directly."
3HOMEPAGE = "http://www.openfabrics.org/downloads/verbs/"
4SECTION = "libs/devel"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7c557f27dd795ba77cc419dddc656b51"
8
9# Official repo is at git://git.kernel.org/pub/scm/libs/infiniband/libibverbs.git
10SRC_URI = "http://www.openfabrics.org/downloads/verbs/${BPN}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "5aea59e4766ae4548419010ac84032ff"
13SRC_URI[sha256sum] = "31b4114bf32d41c9fc81a862ec5febed1e982975f21fa177ea9c7516c9064690"
14
15inherit autotools
16
17PACKAGES += "${PN}-utils"
18FILES_${PN} = "${sysconfdir} ${libdir}/*.so.*"
19FILES_${PN}-utils = "${bindir}"
20
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind,"
23
24do_install_append() {
25 mkdir -p ${D}${sysconfdir}/libibverbs.d
26 rm -f ${D}${libdir}/libibverbs.la
27}