summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-07-31 23:31:13 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-07-31 23:49:54 -0400
commit0cffcd09a44b2a58452a5bb13714bfc47d6546bf (patch)
treeb91584b573ce42431a35a9b8f064d8be57974e1e /recipes-connectivity
parente887a996155f8b9f22d6aca0e31b5fbccd82751e (diff)
downloadmeta-cloud-services-0cffcd09a44b2a58452a5bb13714bfc47d6546bf.tar.gz
global: overrides conversion
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/consul/consul_git.bb16
-rw-r--r--recipes-connectivity/serf/hashicorp-serf_0.8.5.bb4
2 files changed, 10 insertions, 10 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index a49d4a1..828a20e 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://${GO_IMPORT}.git;branch=main \
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15RDEPENDS_${PN}-dev_append = " bash" 15RDEPENDS:${PN}-dev:append = " bash"
16 16
17# Temporarily workaround an issue with GO 1.12.1 17# Temporarily workaround an issue with GO 1.12.1
18# http://www.lyddzz.com/github_/golang/go/issues/30768 18# http://www.lyddzz.com/github_/golang/go/issues/30768
@@ -23,21 +23,21 @@ inherit systemd go
23 23
24# Besides the hosts specified in goarch, we do not build for mips. 24# Besides the hosts specified in goarch, we do not build for mips.
25# 25#
26COMPATIBLE_HOST_mipsarch = "null" 26COMPATIBLE_HOST:mipsarch = "null"
27 27
28SYSTEMD_SERVICE_${PN} = "consul.service" 28SYSTEMD_SERVICE:${PN} = "consul.service"
29SYSTEMD_AUTO_ENABLE_${PN} = "disable" 29SYSTEMD_AUTO_ENABLE:${PN} = "disable"
30 30
31do_compile_prepend () { 31do_compile:prepend () {
32 export GO111MODULE=off 32 export GO111MODULE=off
33} 33}
34 34
35do_install_append() { 35do_install:append() {
36 install -d ${D}/${systemd_unitdir}/system 36 install -d ${D}/${systemd_unitdir}/system
37 cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system 37 cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system
38} 38}
39 39
40FILES_${PN} += "${systemd_unitdir}/system" 40FILES:${PN} += "${systemd_unitdir}/system"
41 41
42#for i586, executable consul contains textrel 42#for i586, executable consul contains textrel
43INSANE_SKIP_${PN} += "textrel" 43INSANE_SKIP:${PN} += "textrel"
diff --git a/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb b/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb
index 0b1517b..7e2a761 100644
--- a/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb
+++ b/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb
@@ -26,7 +26,7 @@ S = "${WORKDIR}/git"
26 26
27inherit go 27inherit go
28 28
29RDEPENDS_${PN}-dev += "bash make" 29RDEPENDS:${PN}-dev += "bash make"
30 30
31# Apache serf in oe-core is a completely different beast 31# Apache serf in oe-core is a completely different beast
32RCONFLICTS_${PN} = "serf" 32RCONFLICTS:${PN} = "serf"