summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/consul/consul_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/consul/consul_git.bb')
-rw-r--r--recipes-connectivity/consul/consul_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index a49d4a1..828a20e 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://${GO_IMPORT}.git;branch=main \
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15RDEPENDS_${PN}-dev_append = " bash" 15RDEPENDS:${PN}-dev:append = " bash"
16 16
17# Temporarily workaround an issue with GO 1.12.1 17# Temporarily workaround an issue with GO 1.12.1
18# http://www.lyddzz.com/github_/golang/go/issues/30768 18# http://www.lyddzz.com/github_/golang/go/issues/30768
@@ -23,21 +23,21 @@ inherit systemd go
23 23
24# Besides the hosts specified in goarch, we do not build for mips. 24# Besides the hosts specified in goarch, we do not build for mips.
25# 25#
26COMPATIBLE_HOST_mipsarch = "null" 26COMPATIBLE_HOST:mipsarch = "null"
27 27
28SYSTEMD_SERVICE_${PN} = "consul.service" 28SYSTEMD_SERVICE:${PN} = "consul.service"
29SYSTEMD_AUTO_ENABLE_${PN} = "disable" 29SYSTEMD_AUTO_ENABLE:${PN} = "disable"
30 30
31do_compile_prepend () { 31do_compile:prepend () {
32 export GO111MODULE=off 32 export GO111MODULE=off
33} 33}
34 34
35do_install_append() { 35do_install:append() {
36 install -d ${D}/${systemd_unitdir}/system 36 install -d ${D}/${systemd_unitdir}/system
37 cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system 37 cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system
38} 38}
39 39
40FILES_${PN} += "${systemd_unitdir}/system" 40FILES:${PN} += "${systemd_unitdir}/system"
41 41
42#for i586, executable consul contains textrel 42#for i586, executable consul contains textrel
43INSANE_SKIP_${PN} += "textrel" 43INSANE_SKIP:${PN} += "textrel"