summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-08-04 22:40:32 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-08-07 22:10:25 -0400
commitc68ae7abb7f5984ebab423325a6c49240abcb97d (patch)
treef4b477f211ce7ced1029f6b7651322a4a3389096 /meta-openstack
parent7d0747c45710d18b9cec56786024e562edee2d52 (diff)
downloadmeta-cloud-services-c68ae7abb7f5984ebab423325a6c49240abcb97d.tar.gz
python3-posix-ipc: Remove python recipe
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-posix-ipc.inc25
-rw-r--r--meta-openstack/recipes-devtools/python/python-posix-ipc_1.0.4.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb27
3 files changed, 25 insertions, 29 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-posix-ipc.inc b/meta-openstack/recipes-devtools/python/python-posix-ipc.inc
deleted file mode 100644
index 32557f0..0000000
--- a/meta-openstack/recipes-devtools/python/python-posix-ipc.inc
+++ /dev/null
@@ -1,25 +0,0 @@
1DESCRIPTION = "POSIX IPC primitives (semaphores, shared memory and message queues) for Python"
2HOMEPAGE = "http://semanchuk.com/philip/posix_ipc/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dc089fb2f37e90799a54c19a20c9880f"
6
7PYPI_PACKAGE = "posix_ipc"
8
9# Archived version so we need to overwrite what the pypi class will derive
10PYPI_SRC_URI = "https://pypi.python.org/packages/source/p/${PYPI_PACKAGE}/${PYPI_PACKAGE}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "c4fd0065244ccb2f59cb8ceedf287cf6"
13SRC_URI[sha256sum] = "ff6c9077633fc62a491d6997c43b094d885bb45a7ca1f36c9a0d647c54b74b14"
14
15inherit pypi
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 ${PYTHON_PN}-pip \
21 "
22
23# RDEPENDS_default:
24RDEPENDS_${PN} += " \
25 "
diff --git a/meta-openstack/recipes-devtools/python/python-posix-ipc_1.0.4.bb b/meta-openstack/recipes-devtools/python/python-posix-ipc_1.0.4.bb
deleted file mode 100644
index 9e79b1c..0000000
--- a/meta-openstack/recipes-devtools/python/python-posix-ipc_1.0.4.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1inherit setuptools3
2require python-posix-ipc.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb b/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb
index 9e79b1c..2e8dca0 100644
--- a/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb
+++ b/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb
@@ -1,2 +1,25 @@
1inherit setuptools3 1DESCRIPTION = "POSIX IPC primitives (semaphores, shared memory and message queues) for Python"
2require python-posix-ipc.inc 2HOMEPAGE = "http://semanchuk.com/philip/posix_ipc/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dc089fb2f37e90799a54c19a20c9880f"
6
7PYPI_PACKAGE = "posix_ipc"
8
9# Archived version so we need to overwrite what the pypi class will derive
10PYPI_SRC_URI = "https://pypi.python.org/packages/source/p/${PYPI_PACKAGE}/${PYPI_PACKAGE}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "c4fd0065244ccb2f59cb8ceedf287cf6"
13SRC_URI[sha256sum] = "ff6c9077633fc62a491d6997c43b094d885bb45a7ca1f36c9a0d647c54b74b14"
14
15inherit setuptools3 pypi
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 ${PYTHON_PN}-pip \
21 "
22
23# RDEPENDS_default:
24RDEPENDS_${PN} += " \
25 "