summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-08-04 22:40:30 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-08-07 22:10:25 -0400
commit7d0747c45710d18b9cec56786024e562edee2d52 (patch)
tree74e5dee512116577db5ea1667fe353638752d39d /meta-openstack
parent5f7fefe50b2b7e4b4814ae1b88c6451475de8a94 (diff)
downloadmeta-cloud-services-7d0747c45710d18b9cec56786024e562edee2d52.tar.gz
python3-os-traits: change to python3
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-traits_git.bb29
-rw-r--r--meta-openstack/recipes-devtools/python/python3-os-traits_2.4.0.bb22
2 files changed, 22 insertions, 29 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-os-traits_git.bb b/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
deleted file mode 100644
index 70b7b69..0000000
--- a/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1DESCRIPTION = "OpenStack library containing standardized trait strings."
2HOMEPAGE = "https://github.com/openstack/os-traits"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://github.com/openstack/os-traits.git;branch=stable/pike \
9 "
10
11PV = "0.3.3+git${SRCPV}"
12SRCREV = "3e8b4a77aaf2d8b64f89ba3b479113d0b44bbe2f"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21# Satisfy setup.py 'setup_requires'
22DEPENDS += " \
23 python-pbr-native \
24 "
25
26RDEPENDS_${PN} += " \
27 python-pbr \
28 python-six \
29 "
diff --git a/meta-openstack/recipes-devtools/python/python3-os-traits_2.4.0.bb b/meta-openstack/recipes-devtools/python/python3-os-traits_2.4.0.bb
new file mode 100644
index 0000000..72bd1b2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-os-traits_2.4.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "OpenStack library containing standardized trait strings."
2HOMEPAGE = "https://github.com/openstack/os-traits"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[sha256sum] = "af1df9485a3119c2a6647639c8bb8bb852cb839ad9c12fa1d9e72f402c66af49"
8
9inherit setuptools3 pypi
10
11DEPENDS += " \
12 python3-pbr \
13 "
14
15DEPENDS += " \
16 python3-pbr-native \
17 "
18
19RDEPENDS_${PN} += " \
20 python3-pbr \
21 python3-six \
22 "