summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-04-04 16:02:48 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-04-09 10:48:36 -0400
commit5842513569f1cc7e18e0504fbd7122a41cbc10bf (patch)
tree927aab64751222e3ce923065731ad2df1872ada4 /meta-openstack
parent174eee1e0242058c0443a1ea3beacc0580b936a5 (diff)
downloadmeta-cloud-services-5842513569f1cc7e18e0504fbd7122a41cbc10bf.tar.gz
python-os-win: initial version (v2.2.0)
Required by the stable/pike version of python-nova. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-win_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-os-win_git.bb b/meta-openstack/recipes-devtools/python/python-os-win_git.bb
new file mode 100644
index 0000000..a742506
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-os-win_git.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Windows / Hyper-V library for OpenStack projects."
2HOMEPAGE = "https://github.com/openstack/os-win"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7SRC_URI = "\
8 git://github.com/openstack/os-win.git;branch=stable/pike \
9 "
10
11PV = "2.2.0+git${SRCPV}"
12SRCREV = "b507ec4e7cb5eead7a008e4d002bc31b85359908"
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 python-babel \
24 python-eventlet \
25 python-oslo.concurrency \
26 python-oslo.config \
27 python-oslo.log \
28 python-oslo.utils \
29 python-oslo.i18n \
30 "