summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-04-04 16:02:47 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-04-09 10:48:36 -0400
commit174eee1e0242058c0443a1ea3beacc0580b936a5 (patch)
tree1f076ea4d71db5bf0e9da485a34d7ac1a7066884 /meta-openstack
parent5c674203597743efae27be50b1c9903975cc8ab8 (diff)
downloadmeta-cloud-services-174eee1e0242058c0443a1ea3beacc0580b936a5.tar.gz
python-os-vif: initial version (v1.7.0)
Required by python-nova. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-vif_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-os-vif_git.bb b/meta-openstack/recipes-devtools/python/python-os-vif_git.bb
new file mode 100644
index 0000000..52fa05e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-os-vif_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "OpenStack integration library between network and compute providers."
2HOMEPAGE = "https://github.com/openstack/os-vif"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://github.com/openstack/os-vif.git;branch=stable/pike \
9 "
10
11PV = "1.7.0+git${SRCPV}"
12SRCREV = "5184b7fc3b8d1689823eacb859087c8a943f9a09"
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 python-netaddr \
24 python-oslo.concurrency \
25 python-oslo.config \
26 python-oslo.log \
27 python-oslo.i18n \
28 python-oslo.privsep \
29 python-oslo.versionedobjects \
30 python-six \
31 python-stevedore \
32 "
33 \ No newline at end of file