summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-09 10:04:50 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-09 12:23:58 -0500
commit8e747fd2ab71d93a7d9b5bfa0bbe54705f56e2ce (patch)
tree7aec036fb590b27bae7d593bf7ab9b8ad22713b1 /meta-openstack/recipes-support
parenteeabc7a45f9463c7862de8392b6c5f121b4c93a6 (diff)
downloadmeta-cloud-services-8e747fd2ab71d93a7d9b5bfa0bbe54705f56e2ce.tar.gz
mod-wsgi: uprev to use git and latest release
Apache2 was just uprev'd to the latest release in meta-oe so we should really matching this. Additionally the version we are replacing had build issue with the latest gcc, so the uprev solves these as well. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch125
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb (renamed from meta-openstack/recipes-support/mod-wsgi/mod-wsgi_3.4.bb)21
2 files changed, 135 insertions, 11 deletions
diff --git a/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch b/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
new file mode 100644
index 0000000..4683db0
--- /dev/null
+++ b/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
@@ -0,0 +1,125 @@
1From a2b1b01045f908815090904239f24eb696d9dbd2 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Thu, 5 Jan 2017 16:51:02 -0500
4Subject: [PATCH] configure.ac: allow PYTHON values to be passed via env
5
6This allows the recipe to specify specific values instead of them
7being 'discovered' which may lead to host contamination or similar
8issues.
9
10Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
11---
12 configure.ac | 41 +++++++++++++++++++++++++++++++++++++++++
13 1 file changed, 41 insertions(+)
14
15diff --git a/configure.ac b/configure.ac
16index 25afe44..b5a9e03 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -100,26 +100,38 @@ fi
20
21 AC_SUBST(PYTHON)
22
23+if test -z "${PYTHON_VERSION}"; then
24 PYTHON_VERSION=`${PYTHON} -c 'from sys import stdout; \
25 from distutils import sysconfig; \
26 stdout.write(sysconfig.get_config_var("VERSION"))'`
27+fi
28
29+if test -z "${PYTHON_LDVERSION}"; then
30 PYTHON_LDVERSION=`${PYTHON} -c 'from sys import stdout; \
31 from distutils import sysconfig; \
32 stdout.write(sysconfig.get_config_var("LDVERSION") or "")'`
33+fi
34
35 if test x"${PYTHON_LDVERSION}" = x""; then
36 PYTHON_LDVERSION=${PYTHON_VERSION}
37 fi
38
39+if test -z "${PYTHON_INCLUDEPY}"; then
40 CPPFLAGS1=`${PYTHON} -c 'from sys import stdout; \
41 from distutils import sysconfig; \
42 stdout.write("-I" + sysconfig.get_config_var("INCLUDEPY"))'`
43+else
44+CPPFLAGS1="${PYTHON_INCLUDEPY}"
45+fi
46
47+if test -z "${PYTHON_CFLAGS}"; then
48 CPPFLAGS2=`${PYTHON} -c 'from sys import stdout; \
49 from distutils import sysconfig; \
50 stdout.write(" ".join(filter(lambda x: x.startswith("-D"), \
51 sysconfig.get_config_var("CFLAGS").split())))'`
52+else
53+CPPFLAGS2="${PYTHON_CFLAGS}"
54+fi
55
56 if test "${ENABLE_EMBEDDED}" != "yes"; then
57 CPPFLAGS3="-DMOD_WSGI_DISABLE_EMBEDDED"
58@@ -131,22 +143,43 @@ CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}"
59
60 AC_SUBST(CPPFLAGS)
61
62+if test -z "${PYTHON_LIBDIR}"; then
63 PYTHONLIBDIR=`${PYTHON} -c 'from sys import stdout; \
64 from distutils import sysconfig; \
65 stdout.write(sysconfig.get_config_var("LIBDIR"))'`
66+else
67+PYTHONLIBDIR="${PYTHON_LIBDIR}"
68+fi
69+if test -z "${PYTHON_CFGDIR}"; then
70 PYTHONCFGDIR=`${PYTHON} -c 'from sys import stdout; \
71 import distutils.sysconfig; \
72 stdout.write(distutils.sysconfig.get_python_lib(plat_specific=1, \
73 standard_lib=1) +"/config")'`
74+else
75+PYTHONCFGDIR="${PYTHON_CFGDIR}"
76+fi
77+if test -z "${PYTHON_FRAMEWORKDIR}"; then
78 PYTHONFRAMEWORKDIR=`${PYTHON} -c 'from sys import stdout; \
79 from distutils import sysconfig; \
80 stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORKDIR"))'`
81+else
82+PYTHONFRAMEWORKDIR="${PYTHON_FRAMEWORKDIR}"
83+fi
84+
85+if test -z "${PYTHON_FRAMEWORKPREFIX}"; then
86 PYTHONFRAMEWORKPREFIX=`${PYTHON} -c 'from sys import stdout; \
87 from distutils import sysconfig; \
88 stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORKPREFIX"))'`
89+else
90+PYTHONFRAMEWORKPREFIX="${PYTHON_FRAMEWORKPREFIX}"
91+fi
92+if test -z "${PYTHON_FRAMEWORK}"; then
93 PYTHONFRAMEWORK=`${PYTHON} -c 'from sys import stdout; \
94 from distutils import sysconfig; \
95 stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORK"))'`
96+else
97+PYTHONFRAMEWORK="${PYTHON_FRAMEWORK}"
98+fi
99
100 if test "${PYTHON_LDVERSION}" != "${PYTHON_VERSION}"; then
101 PYTHONCFGDIR="${PYTHONCFGDIR}-${PYTHON_LDVERSION}"
102@@ -170,12 +203,20 @@ if test "${PYTHONFRAMEWORKDIR}" = "no-framework" -o \
103 LDLIBS1="-lpython${PYTHON_VERSION}"
104 fi
105
106+ if test -z "${PYTHON_LIBS}"; then
107 LDLIBS2=`${PYTHON} -c 'from sys import stdout; \
108 from distutils import sysconfig; \
109 stdout.write(sysconfig.get_config_var("LIBS"))'`
110+ else
111+ LDLIBS2="${PYTHON_LIBS}"
112+ fi
113+ if test -z "${PYTHON_SYSLIBS}"; then
114 LDLIBS3=`${PYTHON} -c 'from sys import stdout; \
115 from distutils import sysconfig; \
116 stdout.write(sysconfig.get_config_var("SYSLIBS"))'`
117+ else
118+ LDLIBS3="${PYTHON_SYSLIBS}"
119+ fi
120 else
121 LDFLAGS1="-Wl,-F${PYTHONFRAMEWORKPREFIX} -framework ${PYTHONFRAMEWORK}"
122
123--
1242.7.4
125
diff --git a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_3.4.bb b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
index c221b6b..eab28b0 100644
--- a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_3.4.bb
+++ b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
@@ -7,23 +7,22 @@ DESCRIPTION = "\
7 7
8HOMEPAGE = "http://code.google.com/p/modwsgi/" 8HOMEPAGE = "http://code.google.com/p/modwsgi/"
9LICENSE = "Apache-2.0" 9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57" 10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRCREV = "f22376f5141e8505f183b1b48f276c31168e2b6a"
13PV = "4.5.13+git${SRCPV}"
14
15S = "${WORKDIR}/git"
11 16
12SRCNAME = "mod_wsgi" 17SRCNAME = "mod_wsgi"
13SRC_URI = "\ 18SRC_URI = "\
14 http://modwsgi.googlecode.com/files/${SRCNAME}-${PV}.tar.gz \ 19 git://github.com/GrahamDumpleton/mod_wsgi.git \
15 file://configure_var.patch \ 20 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \
16 file://build-fix-builds-that-have-separated-build-dir.patch \
17 " 21 "
18 22
19S = "${WORKDIR}/${SRCNAME}-${PV}" 23inherit autotools-brokensep distutils-base
20
21SRC_URI[md5sum] = "f42d69190ea0c337ef259cbe8d94d985"
22SRC_URI[sha256sum] = "ae85c98e9e146840ab3c3e4490e6774f9bef0f99b9f679fca786b2adb5b4b6e8"
23
24inherit autotools distutils-base
25 24
26DEPENDS += "apache2-native apache2 python-native" 25DEPENDS += "apache2-native apache2 python"
27RDEPENDS_${PN} = "python" 26RDEPENDS_${PN} = "python"
28 27
29EXTRA_OECONF = "\ 28EXTRA_OECONF = "\