summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb')
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
new file mode 100644
index 0000000..eab28b0
--- /dev/null
+++ b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
@@ -0,0 +1,57 @@
1SUMMARY = "Supports the Python WSGI interface"
2DESCRIPTION = "\
3 The aim of mod_wsgi is to implement a simple to use Apache module which can host \
4 any Python application which supports the Python WSGI interface. The module would \
5 be suitable for use in hosting high performance production web sites, as well as \
6 your average self managed personal sites running on web hosting services."
7
8HOMEPAGE = "http://code.google.com/p/modwsgi/"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRCREV = "f22376f5141e8505f183b1b48f276c31168e2b6a"
13PV = "4.5.13+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17SRCNAME = "mod_wsgi"
18SRC_URI = "\
19 git://github.com/GrahamDumpleton/mod_wsgi.git \
20 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \
21 "
22
23inherit autotools-brokensep distutils-base
24
25DEPENDS += "apache2-native apache2 python"
26RDEPENDS_${PN} = "python"
27
28EXTRA_OECONF = "\
29 --with-apxs=${STAGING_BINDIR_CROSS}/apxs \
30 --disable-framework \
31 PYTHON_VERSION=${PYTHON_BASEVERSION} \
32 PYTHON_INCLUDEPY=-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
33 PYTHON_CFLAGS='-DNDEBUG' \
34 PYTHON_LIBDIR=${STAGING_LIBDIR} \
35 PYTHON_CFGDIR=${STAGING_LIBDIR}/python${PYTHON_BASEVERSION}/config \
36 PYTHON_FRAMEWORKDIR='no-framework' \
37 PYTHON_FRAMEWORKPREFIX=' ' \
38 PYTHON_FRAMEWORK=' ' \
39 PYTHON_LIBS='-lpthread -ldl -lpthread -lutil' \
40 PYTHON_SYSLIBS='-lm' \
41 "
42
43CFLAGS += " -I${STAGING_INCDIR}/apache2"
44
45FILES_${PN} += "/etc/apache2/"
46FILES_${PN}-dbg += "${libdir}/apache2/modules/.debug"
47
48do_install_append() {
49 mkdir -p ${D}/etc/apache2/modules.d/
50 echo "LoadModule wsgi_module ${libdir}/apache2/modules/mod_wsgi.so" > \
51 ${D}/etc/apache2/modules.d/wsgi.load
52}
53
54# to load:
55# LoadModule wsgi_module modules/mod_wsgi.so
56
57# Apache/2.2.2 (Unix) mod_wsgi/1.0 Python/2.3 configured