summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-07-22 10:58:44 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-07-30 00:50:20 -0400
commit4123ed064a5b45d96f79f8cec4e75e98b5572bc1 (patch)
tree9beca4696bb64509ebcbdbd68f373f82ab97da03 /meta-openstack/recipes-devtools
parentf5ed5c7fd63b257aabcca0512e46d117121c9e16 (diff)
downloadmeta-cloud-services-4123ed064a5b45d96f79f8cec4e75e98b5572bc1.tar.gz
keystone: package python-keystone-hybrid-backend
This project provides two alternative backends for Keystone: hybrid SQL and LDAP backends for OpenStack Keystone Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone-hybrid-backend_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone-hybrid-backend_git.bb b/meta-openstack/recipes-devtools/python/python-keystone-hybrid-backend_git.bb
new file mode 100644
index 0000000..8d38426
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-keystone-hybrid-backend_git.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "hybrid SQL + LDAP backend for openstack keystone"
2HOMEPAGE = "https://github.com/SUSE-Cloud/keystone-hybrid-backend"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://hybrid_identity.py;beginline=1;endline=14;md5=06c14f61d807564e89a36bc1b33465d5"
6
7PR = "r0"
8
9SRC_URI = "git://github.com/SUSE-Cloud/keystone-hybrid-backend.git;branch=havana"
10
11PV="git${SRCPV}"
12SRCREV="0bd376242f8522edef7031d2339b9533b86c17aa"
13S = "${WORKDIR}/git"
14
15inherit python-dir
16
17do_install_append() {
18 install -D -m 0644 hybrid_assignment.py ${D}/${PYTHON_SITEPACKAGES_DIR}/keystone/assignment/backends/hybrid_assignment.py
19 install -D -m 0644 hybrid_identity.py ${D}/${PYTHON_SITEPACKAGES_DIR}/keystone/identity/backends/hybrid_identity.py
20}
21
22FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"