summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone-hybrid-backend_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone-hybrid-backend_git.bb b/meta-openstack/recipes-devtools/python/python-keystone-hybrid-backend_git.bb
new file mode 100644
index 0000000..8d38426
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-keystone-hybrid-backend_git.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "hybrid SQL + LDAP backend for openstack keystone"
2HOMEPAGE = "https://github.com/SUSE-Cloud/keystone-hybrid-backend"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://hybrid_identity.py;beginline=1;endline=14;md5=06c14f61d807564e89a36bc1b33465d5"
6
7PR = "r0"
8
9SRC_URI = "git://github.com/SUSE-Cloud/keystone-hybrid-backend.git;branch=havana"
10
11PV="git${SRCPV}"
12SRCREV="0bd376242f8522edef7031d2339b9533b86c17aa"
13S = "${WORKDIR}/git"
14
15inherit python-dir
16
17do_install_append() {
18 install -D -m 0644 hybrid_assignment.py ${D}/${PYTHON_SITEPACKAGES_DIR}/keystone/assignment/backends/hybrid_assignment.py
19 install -D -m 0644 hybrid_identity.py ${D}/${PYTHON_SITEPACKAGES_DIR}/keystone/identity/backends/hybrid_identity.py
20}
21
22FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"