summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:20:10 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commitc2363428352028dba9aac77323ab0e8cb0e1fea1 (patch)
tree9930448fe728753c71955406aab3379a1a6c696c /meta-openstack/recipes-devtools/ruby
parentd7a5b77542baed187b67d63aa3c72f2baab1018e (diff)
downloadmeta-cloud-services-c2363428352028dba9aac77323ab0e8cb0e1fea1.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/mime-types_git.bb
The mime-types library provides a library and registry for information about MIME content type definitions. It can be used to determine defined filename extensions for MIME types, or to use filename extensions to look up the likely MIME type definitions. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/mime-types_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/mime-types_git.bb b/meta-openstack/recipes-devtools/ruby/mime-types_git.bb
new file mode 100644
index 0000000..a24c1bb
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/mime-types_git.bb
@@ -0,0 +1,27 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Provides a library and registry for info about MIME content type definitions."
5DESCRIPTION = "The mime-types library provides a library and registry \
6for information about MIME content type definitions. It can be used to \
7determine defined filename extensions for MIME types, or to use \
8filename extensions to look up the likely MIME type definitions."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://Licence.rdoc;md5=4e3affb3326cd205b1b30bc0e1e8fd66"
12
13PR = "r0"
14
15BPV = "1.25.1"
16PV = "${BPV}"
17SRCREV = "6be836f59a041893cfc1c25668b3aa3552a7e334"
18
19S = "${WORKDIR}/git"
20
21SRC_URI = " \
22 git://github.com/halostatue/mime-types.git \
23 "
24
25inherit ruby
26
27BBCLASSEXTEND = "native"