summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:19:50 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commitd7a5b77542baed187b67d63aa3c72f2baab1018e (patch)
treeac55a25bcf8bf8089fb7f2b771e463515b16c13a /meta-openstack/recipes-devtools/ruby
parentb653407b44b851f5c3e794de697bf37be3f6f2e5 (diff)
downloadmeta-cloud-services-d7a5b77542baed187b67d63aa3c72f2baab1018e.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/method-source_git.bb
A utility to return a method's sourcecode as a Ruby string. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/method-source/gemspec-bump-version.patch29
-rw-r--r--meta-openstack/recipes-devtools/ruby/method-source_git.bb28
2 files changed, 57 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/method-source/gemspec-bump-version.patch b/meta-openstack/recipes-devtools/ruby/method-source/gemspec-bump-version.patch
new file mode 100644
index 0000000..fbb625c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/method-source/gemspec-bump-version.patch
@@ -0,0 +1,29 @@
1From e98b5737a61b676cba5f8935d56839e1f36faddf Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Wed, 14 May 2014 09:05:35 -0400
4Subject: [PATCH] gemspec: bump version
5
6When the release was tagged the version bump was missed in the
7gemspec file.
8
9Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
10---
11 method_source.gemspec | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/method_source.gemspec b/method_source.gemspec
15index d24b3d9..75e3b5b 100644
16--- a/method_source.gemspec
17+++ b/method_source.gemspec
18@@ -2,7 +2,7 @@
19
20 Gem::Specification.new do |s|
21 s.name = "method_source"
22- s.version = "0.8.1"
23+ s.version = "0.8.2"
24
25 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
26 s.authors = ["John Mair (banisterfiend)"]
27--
281.8.3.2
29
diff --git a/meta-openstack/recipes-devtools/ruby/method-source_git.bb b/meta-openstack/recipes-devtools/ruby/method-source_git.bb
new file mode 100644
index 0000000..39b24d1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/method-source_git.bb
@@ -0,0 +1,28 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "A utility to return a method's sourcecode as a Ruby string."
5DESCRIPTION = "A utility to return a method's sourcecode as a Ruby string."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=7d1a6fbb73f604e1e716380490938bd4"
9
10PR = "r0"
11
12BPV = "0.8.2"
13PV = "${BPV}"
14SRCREV = "1b1f8323a7c25f29331fe32511f50697e5405dbd"
15
16S = "${WORKDIR}/git"
17
18SRC_URI = " \
19 git://github.com/banister/method_source.git \
20 file://gemspec-bump-version.patch \
21 "
22
23inherit ruby
24
25RUBY_BUILD_GEMS = "method_source.gemspec"
26RUBY_INSTALL_GEMS = "method_source-${BPV}.gem"
27
28BBCLASSEXTEND = "native"