summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:18:18 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commitab1857c8e0c35c38b9ea1a5307a73ca7f2f60500 (patch)
treef3f98cf3c4ee23c7b3ad0b6b649c18f5a506810a /meta-openstack/recipes-devtools/ruby
parentf5931f4de9a62fd9c2af6727ec7d777495cf89da (diff)
downloadmeta-cloud-services-ab1857c8e0c35c38b9ea1a5307a73ca7f2f60500.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/erubis_git.bb
Erubis is an implementation of eRuby. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/erubis_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/erubis_git.bb b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
new file mode 100644
index 0000000..08e0f28
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
@@ -0,0 +1,32 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Erubis is an implementation of eRuby."
5DESCRIPTION = "Erubis is an implementation of eRuby."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=3014a71019e3adb4bd2c1de02a7195d0"
9
10PR = "r0"
11
12BPV = "2.7.0"
13PV = "${BPV}"
14SRCREV = "1f0b38d9e66885f8af0244d12d1a6702fc04a8de"
15
16S = "${WORKDIR}/git"
17
18SRC_URI = " \
19 git://github.com/kwatch/erubis.git \
20 "
21
22inherit ruby
23
24do_patch_append() {
25 bb.build.exec_func('do_fixup_gemspec', d)
26}
27
28do_fixup_gemspec() {
29 sed -e "s:\\\$Release\\\$:${BPV}:g" -i ${S}/${BPN}.gemspec
30}
31
32BBCLASSEXTEND = "native"