summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:17:59 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commitf5931f4de9a62fd9c2af6727ec7d777495cf89da (patch)
tree8f9e0a144cfb53f7f79f16e28077cf01f8d37c0a /meta-openstack/recipes-devtools/ruby
parent9ead73adc4bdf74fa719f00718ae263b6e24ee25 (diff)
downloadmeta-cloud-services-f5931f4de9a62fd9c2af6727ec7d777495cf89da.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/diff-lcs_git.bb
Diff::LCS computes the difference between two Enumerable sequences using the McIlroy-Hunt longest common subsequence (LCS) algorithm. It includes utilities to create a simple HTML diff output format and a standard diff-like tool. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb b/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb
new file mode 100644
index 0000000..fc7956d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb
@@ -0,0 +1,27 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Computes the difference between two Enumerable sequences."
5DESCRIPTION = "Diff::LCS computes the difference between two \
6Enumerable sequences using the McIlroy-Hunt longest common subsequence \
7(LCS) algorithm. It includes utilities to create a simple HTML diff \
8output format and a standard diff-like tool."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://License.rdoc;md5=debd9dff6792a920e1ca0ee909e1926a"
12
13PR = "r0"
14
15BPV = "1.2.5"
16PV = "${BPV}"
17SRCREV = "d53e92242b9dd6745e56a0ff4ba15d2f62052b91"
18
19S = "${WORKDIR}/git"
20
21SRC_URI = " \
22 git://github.com/halostatue/diff-lcs.git \
23 "
24
25inherit ruby
26
27BBCLASSEXTEND = "native"