summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:24:47 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit961b8f54f74c3956694df67d2d296bfcf93e2b8a (patch)
tree8e510e22df1c2122451394a054954c6fd922f624 /meta-openstack/recipes-devtools/ruby
parent76a0fd8f546fc0a5407e154331f5ba7be331cefe (diff)
downloadmeta-cloud-services-961b8f54f74c3956694df67d2d296bfcf93e2b8a.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/rack_git.bb
Provides a minimal, modular and adaptable interface for developing web applications in Ruby. By wrapping HTTP requests and responses in the simplest way possible, it unifies and distills the API for web servers, web frameworks, and software in between (the so-called middleware) into a single method call. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/rack_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/rack_git.bb b/meta-openstack/recipes-devtools/ruby/rack_git.bb
new file mode 100644
index 0000000..7d6ab81
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/rack_git.bb
@@ -0,0 +1,28 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Provides an interface for developing web applications in Ruby."
5DESCRIPTION = "Provides a minimal, modular and adaptable interface for \
6developing web applications in Ruby. By wrapping HTTP requests and \
7responses in the simplest way possible, it unifies and distills the \
8API for web servers, web frameworks, and software in between (the \
9so-called middleware) into a single method call."
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://COPYING;md5=53d9c9f5c6fd716007e621045f6caa49"
13
14PR = "r0"
15
16BPV = "1.5.2"
17PV = "${BPV}"
18SRCREV = "ac590d055c936bb9a618e955a690dc836c625211"
19
20S = "${WORKDIR}/git"
21
22SRC_URI = " \
23 git://github.com/rack/rack.git \
24 "
25
26inherit ruby
27
28BBCLASSEXTEND = "native"