summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:24:32 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit76a0fd8f546fc0a5407e154331f5ba7be331cefe (patch)
tree2335d0b08c8c4df93eb87f42f0a807b895421657 /meta-openstack/recipes-devtools/ruby
parent614b4a5196ab7cecef46616805a77ab09702e569 (diff)
downloadmeta-cloud-services-76a0fd8f546fc0a5407e154331f5ba7be331cefe.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/pry_git.bb
Pry is a powerful alternative to the standard IRB shell for Ruby. It is written from scratch to provide a number of advanced features. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry/rdoc-fixup-opt.banner-heredoc.patch67
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry_git.bb35
2 files changed, 102 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/pry/rdoc-fixup-opt.banner-heredoc.patch b/meta-openstack/recipes-devtools/ruby/pry/rdoc-fixup-opt.banner-heredoc.patch
new file mode 100644
index 0000000..b6612c9
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/pry/rdoc-fixup-opt.banner-heredoc.patch
@@ -0,0 +1,67 @@
1From 55f81df0bb27c68d2a817cade5e0eb472acf24e5 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Wed, 14 May 2014 10:43:04 -0400
4Subject: [PATCH] rdoc: fixup opt.banner heredoc
5
6rdoc has some quirks with heredoc which in this case would
7manifest in to a parse error.
8
9| RDoc::Parser::Ruby failure around line 25 of
10| lib/pry/commands/ls.rb
11
12Fixup the heredoc to use a more standard format which is known
13not to mess up rdoc processing.
14
15Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
16---
17 lib/pry/commands/ls.rb | 34 +++++++++++++++++-----------------
18 1 file changed, 17 insertions(+), 17 deletions(-)
19
20diff --git a/lib/pry/commands/ls.rb b/lib/pry/commands/ls.rb
21index 6ce49bb..b78f7e1 100644
22--- a/lib/pry/commands/ls.rb
23+++ b/lib/pry/commands/ls.rb
24@@ -6,23 +6,23 @@ class Pry
25 command_options :shellwords => false, :interpolate => false
26
27 def options(opt)
28- opt.banner unindent <<-'BANNER'
29- Usage: ls [-m|-M|-p|-pM] [-q|-v] [-c|-i] [Object]
30- ls [-g] [-l]
31-
32- ls shows you which methods, constants and variables are accessible to Pry. By
33- default it shows you the local variables defined in the current shell, and any
34- public methods or instance variables defined on the current object.
35-
36- The colours used are configurable using Pry.config.ls.*_color, and the separator
37- is Pry.config.ls.separator.
38-
39- Pry.config.ls.ceiling is used to hide methods defined higher up in the
40- inheritance chain, this is by default set to [Object, Module, Class] so that
41- methods defined on all Objects are omitted. The -v flag can be used to ignore
42- this setting and show all methods, while the -q can be used to set the ceiling
43- much lower and show only methods defined on the object or its direct class.
44- BANNER
45+ opt.banner = <<-EOF
46+Usage: ls [-m|-M|-p|-pM] [-q|-v] [-c|-i] [Object]
47+ ls [-g] [-l]
48+
49+ls shows you which methods, constants and variables are accessible to Pry. By
50+default it shows you the local variables defined in the current shell, and any
51+public methods or instance variables defined on the current object.
52+
53+The colours used are configurable using Pry.config.ls.*_color, and the separator
54+is Pry.config.ls.separator.
55+
56+Pry.config.ls.ceiling is used to hide methods defined higher up in the
57+inheritance chain, this is by default set to [Object, Module, Class] so that
58+methods defined on all Objects are omitted. The -v flag can be used to ignore
59+this setting and show all methods, while the -q can be used to set the ceiling
60+much lower and show only methods defined on the object or its direct class.
61+ EOF
62
63 opt.on :m, :methods, "Show public methods defined on the Object (default)"
64 opt.on :M, "instance-methods", "Show methods defined in a Module or Class"
65--
661.8.3.2
67
diff --git a/meta-openstack/recipes-devtools/ruby/pry_git.bb b/meta-openstack/recipes-devtools/ruby/pry_git.bb
new file mode 100644
index 0000000..91e3c43
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/pry_git.bb
@@ -0,0 +1,35 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Pry is an alternative to the standard IRB shell for Ruby."
5DESCRIPTION = "Pry is a powerful alternative to the standard IRB shell \
6for Ruby. It is written from scratch to provide a number of advanced \
7features."
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=7d1a6fbb73f604e1e716380490938bd4"
11
12PR = "r0"
13
14BPV = "0.9.12.6"
15PV = "${BPV}"
16SRCREV = "047788c4225b25bb0462e06715616964e4f0da15"
17
18S = "${WORKDIR}/git"
19
20SRC_URI = " \
21 git://github.com/pry/pry.git \
22 file://rdoc-fixup-opt.banner-heredoc.patch \
23 "
24
25inherit ruby
26
27RUBY_COMPILE_FLAGS = ""
28
29RDEPENDS += " \
30 coderay \
31 method-source \
32 slop \
33 "
34
35BBCLASSEXTEND = "native"