summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2015-01-28 10:03:36 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-01-30 00:19:10 -0500
commit7ee6d9c99ab2a27ee700a53e47854e3c8eee7671 (patch)
tree321244a6af41f332c67e271bac2d5f20d5f5dcca /meta-openstack/recipes-devtools/ruby
parent08f5108740cf64a696d2552e9922c6de72a9cee6 (diff)
downloadmeta-cloud-services-7ee6d9c99ab2a27ee700a53e47854e3c8eee7671.tar.gz
yajl-ruby: Don't compile extensions
Module mkmf is used to generate Makefile, but it uses native libraries instead of target libraries. To avoid arch problem, we don't compile the extension. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/yajl-ruby/0001-Don-t-compile-extensions.patch20
-rw-r--r--meta-openstack/recipes-devtools/ruby/yajl-ruby_git.bb1
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/yajl-ruby/0001-Don-t-compile-extensions.patch b/meta-openstack/recipes-devtools/ruby/yajl-ruby/0001-Don-t-compile-extensions.patch
new file mode 100644
index 0000000..8ebd35d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/yajl-ruby/0001-Don-t-compile-extensions.patch
@@ -0,0 +1,20 @@
1From 8aec601d3531e7e0ba40df9d712e3754c5404f1a Mon Sep 17 00:00:00 2001
2From: Qian Lei <qianl.fnst@cn.fujitsu.com>
3Date: Tue, 27 Jan 2015 19:13:16 +0800
4Subject: [PATCH] Don't compile extensions.
5
6Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com>
7---
8 yajl-ruby.gemspec | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/yajl-ruby.gemspec b/yajl-ruby.gemspec
12index f601263..ecfeacf 100644
13--- a/yajl-ruby.gemspec
14+++ b/yajl-ruby.gemspec
15@@ -9 +9 @@ Gem::Specification.new do |s|
16- s.extensions = ["ext/yajl/extconf.rb"]
17+# s.extensions = ["ext/yajl/extconf.rb"]
18--
191.8.3.1
20
diff --git a/meta-openstack/recipes-devtools/ruby/yajl-ruby_git.bb b/meta-openstack/recipes-devtools/ruby/yajl-ruby_git.bb
index 2bdd218..9531142 100644
--- a/meta-openstack/recipes-devtools/ruby/yajl-ruby_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/yajl-ruby_git.bb
@@ -23,3 +23,4 @@ SRC_URI = " \
23inherit ruby 23inherit ruby
24 24
25BBCLASSEXTEND = "native" 25BBCLASSEXTEND = "native"
26 file://0001-Don-t-compile-extensions.patch \