summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2015-01-28 10:03:35 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-01-30 00:19:09 -0500
commit08f5108740cf64a696d2552e9922c6de72a9cee6 (patch)
tree844108833d032399c820de5d3116025c8376e48f /meta-openstack/recipes-devtools/ruby
parentfe7f9088c29cc4041d0ee5f08871308139311127 (diff)
downloadmeta-cloud-services-08f5108740cf64a696d2552e9922c6de72a9cee6.tar.gz
json: Don't compile extensions
Module mkmf is used to generate Makefile, but it uses native libraries instead of target libraries. To avoid arch problem, we don't compile the extension. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/json/0001-Dont-compile-extensions.patch20
-rw-r--r--meta-openstack/recipes-devtools/ruby/json_git.bb1
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/json/0001-Dont-compile-extensions.patch b/meta-openstack/recipes-devtools/ruby/json/0001-Dont-compile-extensions.patch
new file mode 100644
index 0000000..0c2f513
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/json/0001-Dont-compile-extensions.patch
@@ -0,0 +1,20 @@
1From 8c6e4b688cc7feade17caa832f9304262025fd17 Mon Sep 17 00:00:00 2001
2From: Qian Lei <qianl.fnst@cn.fujitsu.com>
3Date: Tue, 27 Jan 2015 19:34:26 +0800
4Subject: [PATCH] Dont compile extensions
5
6Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com>
7---
8 json.gemspec | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/json.gemspec b/json.gemspec
12index 75926b1..af7e9ca 100644
13--- a/json.gemspec
14+++ b/json.gemspec
15@@ -13 +13 @@ Gem::Specification.new do |s|
16- s.extensions = ["ext/json/ext/generator/extconf.rb", "ext/json/ext/parser/extconf.rb"]
17+# s.extensions = ["ext/json/ext/generator/extconf.rb", "ext/json/ext/parser/extconf.rb"]
18--
191.8.3.1
20
diff --git a/meta-openstack/recipes-devtools/ruby/json_git.bb b/meta-openstack/recipes-devtools/ruby/json_git.bb
index d3431c7..a852500 100644
--- a/meta-openstack/recipes-devtools/ruby/json_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/json_git.bb
@@ -22,3 +22,4 @@ SRC_URI = " \
22inherit ruby 22inherit ruby
23 23
24BBCLASSEXTEND = "native" 24BBCLASSEXTEND = "native"
25 file://0001-Dont-compile-extensions.patch \