summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:24:15 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit614b4a5196ab7cecef46616805a77ab09702e569 (patch)
tree7a88e4c7e5b40bd54da685b1d49c2460f11b01e1 /meta-openstack/recipes-devtools/ruby
parent014bda085ad4ca42295317a5c4f3599cddbb468c (diff)
downloadmeta-cloud-services-614b4a5196ab7cecef46616805a77ab09702e569.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/ohai_git.bb
Ohai detects data about your operating system. It can be used standalone, but it's primary purpose is to provide node data to Chef. Ohai will print out a JSON data blob for all the known data about your system. When used with Chef, that data is reported back via node attributes. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/ohai_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/ohai_git.bb b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
new file mode 100644
index 0000000..3dbfe00
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
@@ -0,0 +1,39 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Ohai detects data about your operating system."
5DESCRIPTION = "Ohai detects data about your operating system. It can \
6be used standalone, but it's primary purpose is to provide node data \
7to Chef. Ohai will print out a JSON data blob for all the known data \
8about your system. When used with Chef, that data is reported back via \
9node attributes."
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
13
14PR = "r0"
15
16BPV = "7.0.4"
17PV = "${BPV}"
18SRCREV = "b306186701201bfc78b7bcc8908ee3524434cc93"
19
20S = "${WORKDIR}/git"
21
22SRC_URI = " \
23 git://github.com/opscode/ohai.git \
24 "
25
26inherit ruby
27
28RDEPENDS += " \
29 mime-types \
30 ipaddress \
31 mixlib-cli \
32 mixlib-config \
33 mixlib-log \
34 mixlib-shellout \
35 systemu \
36 yajl-ruby \
37 "
38
39BBCLASSEXTEND = "native"