summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:20:30 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commit6ea28094981423679b9e1d9fa9ea01f240ae943b (patch)
tree66ae3a12ac39837d64bfcc45fbdb0e4cbc16c553 /meta-openstack/recipes-devtools/ruby
parentc2363428352028dba9aac77323ab0e8cb0e1fea1 (diff)
downloadmeta-cloud-services-6ea28094981423679b9e1d9fa9ea01f240ae943b.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/mixlib-authentication_git.bb
Mixlib::Authentication provides a class-based header signing authentication object, like the one used in Chef Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
new file mode 100644
index 0000000..eb152e8
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
@@ -0,0 +1,29 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Provides a class-based header signing authentication object"
5DESCRIPTION = "Mixlib::Authentication provides a class-based header \
6signing authentication object, like the one used in Chef."
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
10
11PR = "r0"
12
13BPV = "1.3.0"
14PV = "${BPV}"
15SRCREV = "db24a56c6f5b99114998a50942220a7023060229"
16
17S = "${WORKDIR}/git"
18
19SRC_URI = " \
20 git://github.com/opscode/mixlib-authentication.git \
21 "
22
23inherit ruby
24
25RDEPENDS += " \
26 mixlib-log \
27 "
28
29BBCLASSEXTEND = "native"