summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:23:58 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit014bda085ad4ca42295317a5c4f3599cddbb468c (patch)
treee0b2816ef092bc2f031c3eaa0795cb88081868cd /meta-openstack/recipes-devtools/ruby
parent44a51c96a6c40577959ebc8c734096765ce49a96 (diff)
downloadmeta-cloud-services-014bda085ad4ca42295317a5c4f3599cddbb468c.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/net-ssh_git.bb
Net::SSH is a pure-Ruby implementation of the SSH2 client protocol. It allows you to write programs that invoke and interact with processes on remote servers, via SSH2. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch32
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh_git.bb27
2 files changed, 59 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch b/meta-openstack/recipes-devtools/ruby/net-ssh/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch
new file mode 100644
index 0000000..ff2b35a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch
@@ -0,0 +1,32 @@
1From b0d2d6650bb4924f4dfc3b429835b9ba19f1067e Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Wed, 14 May 2014 09:29:35 -0400
4Subject: [PATCH] gemspec: don't force the use of gem-private_key.pem
5
6This will have security implications but it doesn't affect
7core functionality and allows the build to complete when
8this certificate is not available.
9
10Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
11---
12 net-ssh.gemspec | 4 +++-
13 1 file changed, 3 insertions(+), 1 deletion(-)
14
15diff --git a/net-ssh.gemspec b/net-ssh.gemspec
16index edbbeaa..856bc1e 100644
17--- a/net-ssh.gemspec
18+++ b/net-ssh.gemspec
19@@ -180,7 +180,9 @@ Gem::Specification.new do |s|
20 s.require_paths = ["lib"]
21 s.rubyforge_project = "net-ssh"
22 s.rubygems_version = "1.8.23"
23- s.signing_key = "/mnt/gem/gem-private_key.pem"
24+ if File.exists?("/mnt/gem/gem-private_key.pem")
25+ s.signing_key = "/mnt/gem/gem-private_key.pem"
26+ end
27 s.summary = "Net::SSH: a pure-Ruby implementation of the SSH2 client protocol."
28
29 if s.respond_to? :specification_version then
30--
311.8.3.2
32
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb
new file mode 100644
index 0000000..f2591ff
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb
@@ -0,0 +1,27 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Ruby implementation of the SSH2 client protocol."
5DESCRIPTION = "Net::SSH is a pure-Ruby implementation of the SSH2 \
6client protocol. It allows you to write programs that invoke and \
7interact with processes on remote servers, via SSH2."
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6c99c0cc0901fbc3607fe997f9898d69"
11
12PR = "r0"
13
14BPV = "2.9.1"
15PV = "${BPV}"
16SRCREV = "9f8607984d8e904f211cc5edb39ab2a2ca94008e"
17
18S = "${WORKDIR}/git"
19
20SRC_URI = " \
21 git://github.com/net-ssh/net-ssh.git \
22 file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
23 "
24
25inherit ruby
26
27BBCLASSEXTEND = "native"