summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:19:10 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commit4789b4a205de6c8aa830a45f3d5537a902120309 (patch)
treea1125f699b629d2e9fdca9c37f49859819e85dcf /meta-openstack/recipes-devtools/ruby
parent33c92db4cfabd16538472ce0f7ff1c255588d228 (diff)
downloadmeta-cloud-services-4789b4a205de6c8aa830a45f3d5537a902120309.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/ipaddress_git.bb
IPAddress is a Ruby library designed to make the use of IPv4 and IPv6 addresses simple, powerful and enjoyable. It provides a complete set of methods to handle IP addresses for any need, from simple scripting to full network design. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/ipaddress_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb b/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb
new file mode 100644
index 0000000..116bcf5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb
@@ -0,0 +1,28 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Ruby library designed to make the use of IPv4 and IPv6 addresses simple"
5DESCRIPTION = "IPAddress is a Ruby library designed to make the use of \
6IPv4 and IPv6 addresses simple, powerful and enjoyable. It provides a \
7complete set of methods to handle IP addresses for any need, from \
8simple scripting to full network design."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=52f3a53aa4932dc3fbda4d659f7baa8c"
12
13PR = "r0"
14
15BPV = "0.8.0"
16PV = "${BPV}"
17# SRCREV is one above release as upstream tag was off
18SRCREV = "96aaf68210d644157bd57a6ec3e38c49f38bfc34"
19
20S = "${WORKDIR}/git"
21
22SRC_URI = " \
23 git://github.com/bluemonk/ipaddress.git \
24 "
25
26inherit ruby
27
28BBCLASSEXTEND = "native"