summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:18:47 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commit33c92db4cfabd16538472ce0f7ff1c255588d228 (patch)
tree3cb80b8a00080bb35934fcba80d8067d682fcb84 /meta-openstack/recipes-devtools/ruby
parentf3531056fee40ece3d92cc032839a8bdb46b0305 (diff)
downloadmeta-cloud-services-33c92db4cfabd16538472ce0f7ff1c255588d228.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/highline_git.bb
HighLine was designed to ease the tedious tasks of doing console input and output with low-level methods like gets() and puts(). HighLine provides a robust system for requesting data from a user, without needing to code all the error checking and validation rules and without needing to convert the typed Strings into what your program really needs. Just tell HighLine what you're after, and let it do all the work. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/highline_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/highline_git.bb b/meta-openstack/recipes-devtools/ruby/highline_git.bb
new file mode 100644
index 0000000..c8994ce
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/highline_git.bb
@@ -0,0 +1,30 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Provides a robust system for requesting data from a user."
5DESCRIPTION = "HighLine was designed to ease the tedious tasks of \
6doing console input and output with low-level methods like gets() and \
7puts(). HighLine provides a robust system for requesting data from a \
8user, without needing to code all the error checking and validation \
9rules and without needing to convert the typed Strings into what your \
10program really needs. Just tell HighLine what you're after, and let it \
11do all the work."
12
13LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=884766faee6a0d2931af978757e1a5fc"
15
16PR = "r0"
17
18BPV = "1.6.21"
19PV = "${BPV}"
20SRCREV = "4d5ec40d20853c73f1fd75c7681397bf50b05517"
21
22S = "${WORKDIR}/git"
23
24SRC_URI = " \
25 git://github.com/JEG2/highline.git \
26 "
27
28inherit ruby
29
30BBCLASSEXTEND = "native"