summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:23:28 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit44a51c96a6c40577959ebc8c734096765ce49a96 (patch)
tree2881524a43874a60cf4f69973689b37a0e5705b1 /meta-openstack/recipes-devtools/ruby
parent1e0654f49b615e01ab8741d262d0062513ee3b88 (diff)
downloadmeta-cloud-services-44a51c96a6c40577959ebc8c734096765ce49a96.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/net-ssh-multi_git.bb
A library for controlling multiple Net::SSH connections via a single interface. It exposes an API similar to that of Net::SSH::Connection::Session and Net::SSH::Connection::Channel, making it simpler to adapt programs designed for single connections to be used with multiple connections. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-multi/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch32
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb34
2 files changed, 66 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-multi/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch b/meta-openstack/recipes-devtools/ruby/net-ssh-multi/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch
new file mode 100644
index 0000000..db78b05
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-multi/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch
@@ -0,0 +1,32 @@
1From 2c32d889b64510e1547fa85407beb65c2c3ee89a Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Wed, 14 May 2014 09:21:45 -0400
4Subject: [PATCH] gemspec: don't force the use of gem-private_key.pem
5
6This will have security implications but it doesn't affect
7core functionality and allows the build to complete when
8this certificate is not available.
9
10Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
11---
12 net-ssh-multi.gemspec | 4 +++-
13 1 file changed, 3 insertions(+), 1 deletion(-)
14
15diff --git a/net-ssh-multi.gemspec b/net-ssh-multi.gemspec
16index 2232ad1..f595779 100644
17--- a/net-ssh-multi.gemspec
18+++ b/net-ssh-multi.gemspec
19@@ -48,7 +48,9 @@ Gem::Specification.new do |s|
20 s.require_paths = ["lib"]
21 s.rubyforge_project = "net-ssh-multi"
22 s.rubygems_version = "1.8.25"
23- s.signing_key = "/mnt/gem/gem-private_key.pem"
24+ if File.exists?("/mnt/gem/gem-private_key.pem")
25+ s.signing_key = "/mnt/gem/gem-private_key.pem"
26+ end
27 s.summary = "Control multiple Net::SSH connections via a single interface."
28
29 if s.respond_to? :specification_version then
30--
311.8.3.2
32
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
new file mode 100644
index 0000000..11527be
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
@@ -0,0 +1,34 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "A library for controlling multiple ssh connections via a single interface"
5DESCRIPTION = "A library for controlling multiple Net::SSH connections \
6via a single interface. It exposes an API similar to that of \
7Net::SSH::Connection::Session and Net::SSH::Connection::Channel, \
8making it simpler to adapt programs designed for single connections to \
9be used with multiple connections."
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6c99c0cc0901fbc3607fe997f9898d69"
13
14PR = "r0"
15
16BPV = "1.2.0"
17PV = "${BPV}"
18SRCREV = "b659f2884b2c9abdbe3bbf3c844937a0799ed5ac"
19
20S = "${WORKDIR}/git"
21
22SRC_URI = " \
23 git://github.com/net-ssh/net-ssh-multi.git \
24 file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
25 "
26
27inherit ruby
28
29RDEPENDS += " \
30 net-ssh \
31 net-ssh-gateway \
32 "
33
34BBCLASSEXTEND = "native"