summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:22:25 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit1e0654f49b615e01ab8741d262d0062513ee3b88 (patch)
treee2547aae8daac1836d32d5aa6b5a8440a9e65d3c /meta-openstack/recipes-devtools/ruby
parent3c237f2e18e4a54850a713cb35e23ddfde187906 (diff)
downloadmeta-cloud-services-1e0654f49b615e01ab8741d262d0062513ee3b88.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/net-ssh-gateway_git.bb
A library for programmatically tunnelling connections to servers via a single "gateway" host. It is useful for establishing Net::SSH connections to servers behind firewalls, but can also be used to forward ports and establish connections of other types, like HTTP, to servers with restricted access. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-gateway/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch32
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb33
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch
new file mode 100644
index 0000000..6cd73c7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway/gemspec-don-t-force-the-use-of-gem-private_key.pem.patch
@@ -0,0 +1,32 @@
1From c910f1b0eea4fbfe0aabdb7d42cf8119c585eade Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Wed, 14 May 2014 09:36:05 -0400
4Subject: [PATCH] gemspec: don't force the use of gem-private_key.pem
5
6This will have security implications but it doesn't affect
7core functionality and allows the build to complete when
8this certificate is not available.
9
10Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
11---
12 net-ssh-gateway.gemspec | 4 +++-
13 1 file changed, 3 insertions(+), 1 deletion(-)
14
15diff --git a/net-ssh-gateway.gemspec b/net-ssh-gateway.gemspec
16index 85aeebe..c38717e 100644
17--- a/net-ssh-gateway.gemspec
18+++ b/net-ssh-gateway.gemspec
19@@ -34,7 +34,9 @@ Gem::Specification.new do |s|
20 s.require_paths = ["lib"]
21 s.rubyforge_project = "net-ssh-gateway"
22 s.rubygems_version = "1.8.25"
23- s.signing_key = "/mnt/gem/gem-private_key.pem"
24+ if File.exists?("/mnt/gem/gem-private_key.pem")
25+ s.signing_key = "/mnt/gem/gem-private_key.pem"
26+ end
27 s.summary = "A simple library to assist in establishing tunneled Net::SSH connections"
28
29 if s.respond_to? :specification_version then
30--
311.8.3.2
32
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
new file mode 100644
index 0000000..7c46b5a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
@@ -0,0 +1,33 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "A library for tunnelling connections to servers via a gateway"
5DESCRIPTION = "A library for programmatically tunnelling connections \
6to servers via a single “gateway” host. It is useful for establishing \
7Net::SSH connections to servers behind firewalls, but can also be used \
8to forward ports and establish connections of other types, like HTTP, \
9to servers with restricted access."
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6c99c0cc0901fbc3607fe997f9898d69"
13
14PR = "r0"
15
16BPV = "1.2.0"
17PV = "${BPV}"
18SRCREV = "1de7611a7f7cedbe7a4c6cf3798c88d00637582d"
19
20S = "${WORKDIR}/git"
21
22SRC_URI = " \
23 git://github.com/net-ssh/net-ssh-gateway.git \
24 file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
25 "
26
27inherit ruby
28
29RDEPENDS += " \
30 net-ssh \
31 "
32
33BBCLASSEXTEND = "native"