summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:22:02 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commit3c237f2e18e4a54850a713cb35e23ddfde187906 (patch)
tree45dedd8c3ae4975e70fbf2679149b4d6e038cfb2 /meta-openstack/recipes-devtools/ruby
parenta7693a333bcb306088e2ebeb50e509eda30b7f21 (diff)
downloadmeta-cloud-services-3c237f2e18e4a54850a713cb35e23ddfde187906.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/mixlib-shellout_git.bb
Provides a simplified interface to shelling out yet still collecting both standard out and standard error and providing full control over environment, working directory, uid, gid, etc. No means for passing input to the subprocess is provided. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb
new file mode 100644
index 0000000..3ee593f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb
@@ -0,0 +1,29 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Provides a simplified interface to shelling"
5DESCRIPTION = "Provides a simplified interface to shelling \
6out yet still collecting both standard out and standard error \
7and providing full control over environment, working directory, \
8uid, gid, etc. No means for passing input to the subprocess is \
9provided."
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
13
14PR = "r0"
15
16BPV = "1.4.0"
17PV = "${BPV}"
18SRCREV = "a04ce6db22edf0575c50e18ae2db09adced7dedc"
19
20S = "${WORKDIR}/git"
21
22SRC_URI = " \
23 git://github.com/opscode/mixlib-shellout.git \
24 "
25
26inherit ruby
27
28BBCLASSEXTEND = "native"
29