summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:20:50 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commit0b1906dcf559e1c788f6313c60291e6f758651b7 (patch)
treedf9f571e1e236789a3ef71732edcc86fe26021aa /meta-openstack/recipes-devtools/ruby
parent6ea28094981423679b9e1d9fa9ea01f240ae943b (diff)
downloadmeta-cloud-services-0b1906dcf559e1c788f6313c60291e6f758651b7.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/mixlib-cli_git.bb
Provides a class-based command line option parsing object, like the one used in Chef, Ohai and Relish. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb
new file mode 100644
index 0000000..02bf49c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb
@@ -0,0 +1,25 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Provides a class-based command line option parsing object"
5DESCRIPTION = "Provides a class-based command line option parsing \
6object, like the one used in Chef, Ohai and Relish."
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
10
11PR = "r0"
12
13BPV = "1.5.0"
14PV = "${BPV}"
15SRCREV = "b3b3c12141b5380ec61945770690fc1ae31d92b0"
16
17S = "${WORKDIR}/git"
18
19SRC_URI = " \
20 git://github.com/opscode/mixlib-cli.git \
21 "
22
23inherit ruby
24
25BBCLASSEXTEND = "native"